
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2008 г 



 



 1

 
 
 
Введение.................................................................................................................................... 3 
1 Среда проектирования Microwave Office............................................................................ 4 

1.1 Запуск Microwave Office ................................................................................................ 4 
1.2 Компоненты среды проектирования ............................................................................. 4 
1.3 Работа с проектами ......................................................................................................... 6 
1.4 Основные элементы среды проектирования ................................................................ 6 
1.5 Сценарии и мастера ...................................................................................................... 13 
1.6 Помощь .......................................................................................................................... 13 

2. Линейное моделирование .................................................................................................. 15 
2.1. Моделирование ФНЧ на сосредоточенных элементах ............................................ 15 
2.2. Моделирование микрополоскового заграждающего фильтра ................................ 23 
2.3. Моделирование микрополоскового аттенюатора на резисторах ............................ 30 
2.4. Моделирование микрополоскового 2-х диодного аттенюатора.............................. 34 

3. Нелинейное моделирование .............................................................................................. 44 
3.1. Моделирование усилителя мощности. ...................................................................... 44 
3.2. Моделирование балансного смесителя на диодах.................................................... 56 

4. Создание топологии схемы ............................................................................................... 64 
5. Электромагнитное моделирование................................................................................... 75 

5.1. Моделирование встречноштыревого микрополоскового фильтра ......................... 75 
5.2. Моделирование микрополоскового аттенюатора ..................................................... 88 
5.3 Моделирование микрополоскового двухсекционного делителя мощности. .......... 96 
5.4. Моделирование микрополоскового двухсекционного симметрированного 
направленного ответвителя.............................................................................................. 102 

 



 2

 
 
 



 3

Настоящее пособие не раскрывает всех возможностей программы Microwave Office 
2007. Его цель – помочь быстро освоить основы работы в среде моделирования этой 
программы на конкретных примерах. Пособие составлено с использованием Getting 
Started, входящего в состав документации Microwave Office 2007 и которое содержит 
примеры по различным видам моделирования. К этим примерам добавлен ряд других, 
чтобы показать дополнительные особенности работы в среде моделирования, которые 
полезно освоить уже при первом знакомстве с работой программы. 

 
Е.Е. Дмитриев 

 

Введение 
Одним из популярных программных продуктов, используемым для проектирования радиочас-

тотных устройств и устройств СВЧ, является AWR DESIGN ENVIRONMENT (AWRDE) компании Ap-
plied Wave Research. Он включает в себя три мощных инструментальных средства: Microwave Office 
(MWO), Visual System Simulator (VSS) и Analog Office (ANO). Эти средства интегрированы в единую 
среду проектирования и могут использоваться вместе, не выходя из среды проектирования. Это пособие 
включает информацию только о Microwave Office. 

Microwave Office позволяет создавать схемы, состоящие из элементов схем (сосредоточенных и 
распределённых) и электромагнитных структур. Для моделирования можно использовать один из мето-
дов: линейное моделирование, усовершенствованный гармонический баланс, ряды Вольтера, электро-
магнитное моделирование (EMSight) или дополнительный имитатор HSPICE. Результаты могут выво-
диться в различных графических формах или в таблице в зависимости от цели проводимого анализа. 
Можно настраивать или оптимизировать проекты и все изменения немедленно и автоматически отража-
ются на графиках и в топологии. 

Справочная система Microwave Office обеспечивает информацию обо всех окнах, пунктах меню, 
и концепциях. К справочной системе можно обратиться через Пуск > Программы > AWR 2007 > Awr 
Design Environment Help, или выбрав Help из выпадающего меню, или нажав клавишу F1. 

Для инсталляции Microwave Office компьютер должен удовлетворять следующим минимальным 
требованиям (в скобках указаны рекомендуемые требования): 
 

o процессор Pentium III (многоядерный процессор). AWR рекомендует использовать про-
цессоры Intel; 

o 512 Мб (1 Гб) оперативной памяти; 
o 250 Мб свободного места на жёстком диске; 
o операционная система Microsoft Windows 2000, XP или Vista. 

 
Если вы обновляете версию Microwave Office, то сохраните старую версию до тех пор, пока не 

проверите, работают ли ваши проекты в новой версии. 
 
 



1 Среда проектирования Microwave Office 

1.1 Запуск Microwave Office 
Чтобы запустить Microwave Office, сделайте следующее: 

o Нажмите кнопку Пуск; 
o Выберите Программы>AWR2007>AWR Design Environment. Откроется главное окно 

Microwave Office, показанное на рис. 1.1. 
Если при инсталляции Microwave Office не был сконфигурирован так, чтобы находиться в меню 

Программы, тогда щёлкните значок Мой компьютер на рабочем столе, выберите диск и папку, в кото-
рую установлен Microwave Office, найдите файл MWOffice.exe и запустите его. После запуска про-
граммы откроется главное окно Microwave Office (рис 1.1): 

Рис. 1.1 

1.2 Компоненты среды проектирования 
Главное окно Microwave Office содержит все компоненты, которые составляют среду проектиро-

вания. Именно через это окно проектируются линейные и нелинейные схемы, устанавливаются электро-
магнитные структуры (EM), создаются топологии, исполняется моделирование, и отображаются графи-
ки. Основные компоненты среды проектирования описаны ниже: 

Компонент Описание 
Меню Строка выпадающих меню, расположенная в верхней части окна, для выполнения 

различных задач Microwave Office. 
Панель инструмен-
тов 

Строка значков, расположенных ниже выпадающего меню, которые обеспечивают 
доступ к часто используемым командам типа создания новых схем, выполнения 
моделирования, или настройки значений параметров или переменных. 

Окно просмотра 
проекта 

Древовидная структура групп и модулей, которая определяет активный проект 
Microwave Office, включая схемы, электромагнитные структуры (ЕМ), частоты 
моделирования и выходные графики. 

Рабочее поле Зона, в которой проектируются схемы, электромагнитные структуры (EM), ото-
бражаются и редактируются топологии, и выводятся графики. 

Панели Строка панелей, расположенная в нижней части левого окна, которая позволяет 
переключать содержание этого окна.  
Project – включает окно просмотра проекта. 
Elements – включает окно просмотра элементов для формирования схем. 
Layout – включает окно менеджера топологии, которое позволяет определить па-
раметры для черчения и просмотра топологии. 
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Многие функции и команды, доступные из меню, также доступны через панель инструментов 
и/или окно просмотра проекта. 

Вид и состав меню и панели инструментов динамически изменяются в зависимости от открытого 
активного окна. Установите курсор на значок панели инструментов, чтобы увидеть его описание. 

Окно просмотра проекта всегда активно после загрузки Microwave Office. Щёлкните правой 
кнопкой мышки по группе в окне просмотра проекта, чтобы вызвать всплывающее меню с соответст-
вующими этой группе командами. 

В пределах рабочего поля вы можете перемещаться, используя вертикальную и горизонтальную 
полосы скроллинга и изменять размеры внутри окна, используя значки на панели инструментов. Вы мо-
жете нажимать на элементы схемы правой кнопкой мышки, чтобы вызвать всплывающее меню с соот-
ветствующими командами. Вы можете также копировать и вставлять элементы, порты и проводники из 
одной схемы или проекта в другие, используя значки панели инструментов. 

На вкладке Project левого окна проекта отображается дерево групп и модулей, которые уже ис-
пользуются, а также могут быть использованы в данном проекте. Сюда входят: 

 
o модуль примечаний к проекту (Design Notes); 
o модуль задания глобальных опций проекта (Project Options); 
o модуль глобальных выражений (Global Equations); 
o модуль использования внешних файлов данных (Data Files); 
o группа используемых схем системы для VSS, если VSS инсталлировано (System Diagrams); 
o группа используемых схематических модулей (Circuit Schematics); 
o группа используемых электромагнитных структур (EM Structures); 
o модуль выходных соотношений (Output Equations); 
o группа отображения результатов анализа (Graphs); 
o группа целей оптимизации (Optimizer Goals); 
o группа целей статистического анализа (Yield Goals); 
o список выходных файлов (Output Files); 
o группа мастеров (Wizards); 

 
Чтобы раскрыть группу, содержащую подгруппы, нужно щёлкнуть мышкой по значку “+” слева 

от группы. У раскрытой группы значок “+” меняется на “-”, щелчок мышкой по которому сворачивает 
группу. 

Двойной щелчок мышкой по группе или модулю вызывает различные действия в зависимости от 
назначения группы или модуля. Двойной щелчок по Design Notes, Global Definitions и Output Equations 
открывает соответственно окна для создания примечаний к проекту (это одно из немногих мест в Micro-
wave Office, где можно использовать русские буквы), создания глобальных определений проекта и соз-
дания выходных соотношений. Двойной щелчок по Project Options, System Diagrams и Circuit Sche-
matics открывает диалоговые окна для определения соответствующих опций. Двойной щелчок по ос-
тальным группам и модулям не вызывает никаких действий. 

Щелчок правой кнопкой мышки по любой группе или модулю, а также по любому объекту про-
екта, открывает контекстные меню, предлагающие на выбор список возможных дальнейших действий. 

На вкладке Elements отображается дерево используемых библиотек "зашитых" моделей элемен-
тов построения схематических модулей: портов, источников, сосредоточенных и распределенных, ли-
нейных и нелинейных, идеальных и неидеальных элементов, а также внешних импортируемых библио-
тек моделей и подсхем. Все модели объединены в соответствующие группы, содержание которых отра-
жается в нижней части окна. Добавление того или иного элемента в схему проекта производится при-
вычным методом Drag-and-Drop (возьми-и-брось), а редактирование параметров - или в списке прямо на 
схеме, или в специальном диалоговом окне, открывающемся при двойном щелчке по элементу. 

Контекстное меню, появляющееся при щелчке правой кнопкой мышки по элементу, даёт воз-
можность изменить отображение элементов в окне, а также содержит команду вызова справки об этом 
элементе. 

Группа отображения результатов анализа на вкладке Project предлагает наглядную демонстра-
цию результатов расчета на диаграммах различного типа в зависимости от выбранного типа анализа. 

Здесь возможно простое отображение S-параметров схем на диаграммах Смита, графиках в пря-
моугольных и полярных координатах, а также более сложная прорисовка форм и спектров сигналов в 
различных точках схемы или диаграмм направленности антенн, да еще и в диапазоне частот. 

Заметим также, что именно эта группа, совместно с используемыми моделями элементов и сиг-
нальных портов, является определяющей при выборе того метода анализа, который будет использоваться 
в вашем проекте. Кроме того, в одном проекте могут комбинироваться различные методы анализа, а их 
результаты отражаться на одних и тех же графиках. 

Группа оптимизации содержит список назначенных целей оптимизации текущей схемы. Под це-
лью оптимизации здесь подразумевается некоторая граница изменения какой-либо характеристики ана-
лизируемой схемы, к которой должен стремиться выбранный метод оптимизации при изменении опреде-
ленных параметров элементов. 



Каждая введенная цель оптимизации сразу же отображается на соответствующем графике, что 
позволяет в последующем легко проверить ее параметры, а также легко изменить их тут же на графике с 
помощью мышки. 

Заметим, что оптимизация и настройка не работают в электромагнитном моделировании, кото-
рое позволяет выполнить анализ созданной топологии на электродинамическом уровне. Структура, по-
строенная из набора проводящих и резистивных полигонов, а также межслойных соединений произволь-
ной геометрической формы, анализируется внутри ограниченной многослойной области прямоугольной 
формы. Боковые границы этой области всегда идеально проводящие, а верхняя и нижняя границы могут 
быть заданы тремя различными способами: проводящая поверхность с потерями (или без них), эквива-
лент открытого пространства и бесконечного волновода. Количество анализируемых слоев, межслойных 
соединений и внешних портов теоретически неограниченно. 

Графические возможности модуля электродинамического анализа позволяют пользователю на-
блюдать цветное трехмерное анимационное изображение токов высокой частоты, на котором отобража-
ется не только амплитуда, но и направление этих токов. 

1.3 Работа с проектами 
В среде проектирования Microwave Office используются проекты, организуемые и управляемые 

из древовидной структуры в окне просмотра проектов. 
Проект представляет собой любой желательный набор моделей и может включать одну или бо-

лее линейных схем, нелинейных схем, и/или электромагнитных структур. Проект также включает всё 
связанное с проектом, типа глобальных значений параметров, импортированных файлов, топологий и 
выходных графиков. При сохранении проекта автоматически сохраняется всё связанное с ним. Проекты 
в Microwave Office сохраняются как *.emp файлы. 

После создания проекта вы можете реализовывать свои замыслы. Вы можете генерировать топо-
логию этого проекта и выводить её в DXF, GDSII или Garber файлах. Вы можете выполнить моделирова-
ние, чтобы сделать анализ проекта и просмотреть результаты на ряде графиков, которые вы определили. 
После этого вы можете настраивать или оптимизировать значения параметров или переменных. Так как 
все части Microwave Office интегрированы, все ваши модификации автоматически отображаются на схе-
ме и в топологии. 

1.4 Основные элементы среды проектирования 
В этом разделе описаны только основные окна, пункты меню и команды, необходимые для вы-

полнения основных задач Microwave Office, таких как: создание проекта, схемы, рисунка электромагнит-
ных структур, топологий, выполнение моделирования и отображение выходных графиков.  

Многие, описанные здесь операции по созданию проекта, могут быть выполнены различными 
способами: из основного меню, из панели инструментов, из всплывающих меню и/или окна просмотра 
проекта. В этом руководстве не описываются все способы выполнить определённую операцию. 
 
Создание, открытие и запись проектов. 

Создание проекта – первый шаг к формированию и моделированию ваших проектов. Организа-
ция и управление проектом и всем связанным с ним производится в древовидной структуре групп и мо-
дулей в окне просмотра проектов при нажатой панели Project (рис. 1.2). После запуска Microwave Office 
по умолчанию загруженным или активным является проект без названия (Untitled Project). Имя активно-
го проекта отображается в заголовке основного окна. 

Для создания нового проекта нужно выбрать в меню File>New Project. Затем нужно дать имя 
новому проекту, выбрав File>Save Project As в том же меню. Имя проекта отображается в заголовке ок-
на. 

Для открытия существующего проекта нужно выбрать File>Open Project.  
Для сохранения текущего проекта нужно выбрать File>Save Project. 
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Создание схем и списка цепей. 
Схемы – это графическое изображение схем, а список цепей – это текстовое описание схем. Про-

ект Microwave Office может включать множество линейных и нелинейных схем и/или списков цепей, а 
также электромагнитных структур. 

Чтобы создать новую схему или список цепей, нужно щёлкнуть правой кнопкой мышки по груп-
пе Circuit Schematics и выбрать New Schematic или New Netlist и, в открывшемся поле ввода, ввести 
имя схемы или списка цепей (рис. 1.3). Если на жёстком диске имеется файл, который содержит схему, 
то схему из этого файла можно импортировать в проект. В этом случае схема включается в состав проек-
та. Для этого нужно выбрать Import Schematic. Или можно связать схему из файла с проектом, выбрав 
Link To Schematic. В этом случае схема не включается в проект, а осуществляется только связь с ней и 
файл со связанной схемой нельзя удалять или переносить в другую директорию, чтобы эта связь не 
оборвалась. Аналогичные операции можно выполнять и для списков цепей. 

Если в проекте создано много схем и/или списков цепей, их можно сгруппировать в папки, вы-
брав Create Folder. 

После того, как определено имя схемы или списка цепей, на рабочем поле открывается пустое 
окно схемы (рис. 1.3) или списка цепей, в заголовке которого отображается присвоенное имя, а в окне 
просмотра проектов отображается новая схема или список цепей, как подгруппа в группе Circuit Sche-
matics. Подгруппа новой схемы или списка цепей содержат все параметры и опции, которые определяют 
и описывают схему или список цепей. Кроме того, меню и панель инструментов отображают новый спе-
цифический набор команд и инструментов для формирования и моделирования схемы или списка цепей. 

Рис. 1.3 

 
Добавление элементов в схему. 

Чтобы добавить элементы в схему, необходимо в левом окне проекта открыть вкладку просмот-
ра элементов, щёлкнув левой кнопкой мышки по панели Elements в нижней части левого окна (рис. 1.4). 

Нажимая значки + или – возле группы, можно развернуть или свернуть группу, а при нажатии на 
значок желательной подгруппы, например, Capacitor (Конденсатор) или Inductor (Индуктивность), в 

Рис. 1.4
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нижней части окна просмотра элементов отображаются доступные элементы из этой подгруппы. 
Чтобы поместить нужный элемент в схему, поместите курсор на элемент, нажмите левую кнопку 

мышки и, не отпуская кнопки, переместите его в окно схемы. Здесь, в любом свободном месте окна, от-
пустите кнопку. Щёлкая правой кнопкой мышки, можно вращать элемент, чтобы получить нужную ори-
ентацию. Затем, не нажимая кнопок мышки, элемент нужно поместить в соответствующее место и за-
фиксировать его, щёлкнув левой кнопкой мышки. 

Параметры элемента располагаются в окне схемы рядом с элементом. Чтобы изменить значение 
какого либо параметра, нужно дважды щёлкнуть левой кнопкой мышки по этому параметру. Откроется 
поле ввода, в котором можно отредактировать значение параметра. Или можно дважды щёлкнуть левой 
кнопкой мышки по элементу. В этом случае открывается диалоговое окно свойств элемента, в котором 
можно изменить значения всех параметров элемента. 

Если поместить курсор на отображаемые параметры элемента и нажать левую кнопку мышки, 
можно переместить отображение параметров в любое другое место для удобства чтения схемы. 

Кроме обычных элементов в Microwave Office включён ряд “интеллектуальных” элементов и Х-
моделей. “Интеллектуальные” (ICell) элементы отличаются тем, что они не требуют ввода никаких пара-
метров. Все значения параметров они автоматически получают от подключённых к ним других элемен-
тов. В окне просмотра элементов такие элементы на конце имеют символ $. Х-модели являются элемен-
тами, параметры которых определены с помощью электромагнитного моделирования и сохраняются в 
специальных таблицах. Эти элементы на конце имеют символ Х. Х-модели позволяют совместить высо-
кую точность модели, быстроту анализа и возможность настройки и оптимизации. Однако перед приме-
нением Х-модели должны быть заполнены, что занимает значительное время. Но однажды заполненная 
Х-модель затем может использоваться в любом проекте. В Microwave Office включены Х-модели, уже 
заполненные для некоторых распространённых диэлектриков. Файлы Х-моделей имеют расширение 
EMX и хранятся в папке EM_Models. Например, имя файла Microstrip_10p2_MOPENX.EMX говорит о 
том, что это Х-модель разомкнутого конца в отрезке микрополосковой линии на диэлектрике с диэлек-
трической проницаемостью 10.2. Наличие готовых Х-моделей даёт возможность вместо заполнения Х-
модели использовать готовую для диэлектрика с близким значением диэлетрической проницаемости, 
возможно с небольшой потерей в точности. Например, если в параметрах элемента подложки ввести 
Er=10 и ErNom=10, и в схеме имеется Х-модель, то анализ выполняться не будет. Появится окно сооб-
щения,что Х-модель не заполнена и требуется её заполнить. Но если изменить значение ErNom и в пара-
метрах подложки ввести Er=10 и ErNom=10.2, то анализ будет выполнен. 

В Microwave Office в схему можно включать подсхемы в виде блоков, что позволяет создавать 
иерархические структуры схем. Таким блоком могут быть схемы, списки цепей, электромагнитные 
структуры или файлы данных. 

Чтобы добавить подсхему, нужно щёлкнуть мышкой по Subcircuits (Подсхемы) в окне просмот-
ра элементов. Доступные подсхемы отображаются в нижней части этого окна. Они включают все схемы, 
списки цепей и электромагнитные структуры, связанные с проектом, а также любые импортированные 
файлы данных, определённые для проекта. 

Чтобы добавить файл данных как подсхему, он должен быть сначала импортирован и добавлен к 
проекту как объект. Чтобы сделать это, выберите Project>Add Data File в окне просмотра проекта. Лю-
бые импортированные файлы данных автоматически отображаются в перечне доступных подсхем в окне 
просмотра элементов. 

Для размещения желательной подсхемы, её нужно просто перетащить мышкой в окно схем, при 
необходимости повернуть, щёлкая правой кнопкой мышки, и установить в нужное место. 

Для редактирования параметров подсхемы нужно щёлкнуть по подсхеме правой кнопкой и вы-
брать Edit Subcircuit во всплывающем меню. Или открыть схему, список цепей, электромагнитную 
структуру или файл данных на рабочем поле (через окно просмотра проектов), соответствующие редак-
тируемой подсхеме. Редактирование делается так же, как и редактирование параметров отдельного эле-
мента. 

 
Добавление портов (входов) и проводов в схему. 

Чтобы добавить в схему обычный порт для линейного моделирования, щёлкните по группе Ports 
(Порты) в окне просмотра элементов, перетащите элемент PORT в окно схемы, при необходимости раз-
верните его, щёлкая правой кнопкой мышки, установите в нужное место схемы и щёлкните левой кноп-
кой мышки, чтобы зафиксировать порт. Этот порт можно так же добавить в схему, щёлкнув по значку 

Port  на панели инструментов. 
Чтобы добавить специальный порт к схеме, например, порт для гармонического баланса, нужно 

раскрыть группу Ports в окне просмотра элементов, затем щёлкнуть левой кнопкой мышки по нужной 
подгруппе портов. Доступные типы портов будут отображены в нижней части левого окна. 

Отредактировать параметры порта можно двойным щелчком мышки по порту в окне схем. От-
кроется диалоговое окно, в котором можно ввести новые значения параметра. 

Чтобы добавить в схему землю, щёлкните по значку Ground  на панели инструментов. 
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Чтобы соединить два элемента схемы проводом, нужно установить курсор возле точки элемента 

схемы, к которой нужно подключить начало провода. Курсор должен отображаться в виде соленоида . 
Нажмите в этой позиции левую кнопку мышки, чтобы зафиксировать начало провода, и, отпустив кноп-
ку мышки, двигайте мышкой к месту, где нужно сделать изгиб провода. Щёлкните снова левой кнопкой, 
чтобы зафиксировать изгиб. Изгибов можно делать сколько угодно. Чтобы закончить подключение про-
вода, щелкните по другому элементу, к которому нужно присоединить провод, или по другому проводу. 
Для отмены соединения проводом нажмите клавишу Esc. 
 
Добавление данных к списку цепей. 

При создании списка цепей открывается пустое окно Netlist, в котором вы вводите базовый текст 
описания схемы. Данные списка цепи размещаются в блоках в особом порядке, где каждый блок опреде-
ляет различные атрибуты элемента, типа единиц измерения, уравнений или элементных связей. Для 
большей информации о создании списка цепи см. Руководство пользователя Microwave Office. 
 
Создание топологии схем. 

 
Топология – это изображение физического представления цепей, в котором каждому компоненту 

схемы соответствует элемент топологии. В объектно-ориентированной среде Microwave Office топология 
тесно связана со схемой и электромагнитной структурой, которые она представляет, это просто другой 
вид тех же самых цепей. Любые изменения, сделанные в схеме или электромагнитной структуре, автома-
тически и немедленно отображаются в соответствующей топологии. 

Для создания топологии схемы, щёлкните по схеме, чтобы сделать её активной и выберите 
View>New Layout View в меню или 
щёлкните по значку New Schematic 

Layout View  на панели инстру-
ментов. На рабочем поле откроется 
окно топологии с автоматически соз-
данной топологией схемы, если для 
элементов схемы имеются соответст-
вующие элементы топологии. Однако 
элементы топологии могут быть со-
единены между собой неверно или не 
соединены вовсе, как показано на рис. 
15, при этом пунктирными красными 

линиями указываются общие точки соединения элементов топологии, т.е. точки, в которых эти элементы 
должны быть соединены. Чтобы правильно скомпоновать топологию, выберите в меню Edit>Select All, 
чтобы выделить все элементы топологии, затем выберите в меню Edit>Snap Together или щёлкните по 

значку Snap Together  на панели инструментов. Топология будет скомпонована автоматически, как 
показано на рис. 1.6. При 
желании это можно сде-
лать и вручную. Для это-
го установите курсор на 
элемент, который нужно 
переместить в другое 
место, нажмите левую 
кнопку мышки и, не от-
пуская кнопки, перемес-

тите элемент. 

Рис. 1.5 

Рис. 1.6 

Когда после выполнения команды View>New Layout View создана топология схемы, элементы 
топологии автоматически назначаются для тех элементов схемы, у которых имеется элемент топологии, 
соответствующий электрическому элементу. Это такие элементы, как элементы симметричной и микро-
полосковой линии, компланарного волновода и т.п. На схеме элементы, для которых в топологии создан 
топологический элемент, будут отображаться сиреневым цветом. Те элементы схемы, для которых нет 
топологического представления (например, транзистор), в схеме будут отображаться синим цветом. 

Для элементов схемы, у которых нет соответствующих топологических элементов, вы должны 
их создать сами или импортировать через менеджера топологии (Layout Manager), как будет описано 
далее. 

Изменять атрибуты топологии, свойства черчения и создавать новые элементы топологии, кото-
рых нет среди задаваемых по умолчанию, можно нажав панель Layout в нижней части левого окна. Ме-
неджер топологии заменит при этом окно просмотра проектов (рис. 1.7). 
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Группа Layer Setup (Установка Слоёв) в менеджере топологии определяет атрибуты, такие как 
свойства черчения (цвет линии, рисунок слоя и т.д.), 3-х мерные свойства (толщина и т.д.) и положение 
слоёв. Чтобы изменить атрибуты слоя, щёлкните правой кнопкой мышки по Layer Setup и выберите Edit 
Drawing Layers (Редактирование слоёв черчения) во всплывающем меню. Вы можете также импортиро-
вать файл обработки слоя (LPF) для определения его атрибутов, щёлкнув правой кнопкой мышки Layer 
Setup и выбирая Import Process Definition из всплывающего меню. 

Рис. 1.7 

Группа Cell Libraries (Библиотека элементов) в Менеджере топологии позволяет создавать шаб-
лоны ячеек для элементов, которых нет в задаваемых по умолчанию. Редактор элементов включает такие 
возможности, как покоординатный ввод, булевы операции для вычитания и объединения форм, копиро-
вание массива, произвольное вращение, группировку и инструментальные средства совмещения. Вы мо-
жете так же импортировать библиотеки шаблонов элементов типа CDSII или DXF в Microwave Office. 

Как только библиотеки элементов топологии созданы или импортированы, их можно просмат-
ривать и выбирать необходимые элементы для включения в топологию. Нажмите обозначения + или – , 
чтобы развернуть или свернуть библиотеки элементов топологии и выберите необходимый элемент. Дос-
тупные элементы топологии отображаются в нижней части левого окна. Чтобы поместить элемент топо-
логии в окно топологии, просто нажмите на него левой кнопкой мышки и переместите в окно топологии. 
Отпустив кнопку мышки, позиционируйте его и щёлкните левой кнопкой мышки, чтобы зафиксировать. 

Ячейка топологии может выводиться в файл в формате GDSII или DXF. Для экспортирования 
ячейки в файл, щёлкните правой кнопкой мышки по её имени в Менеджере топологии и выберите Export 
Layout Cell. 

Вся топология схемы также может выводиться в файлах GDSII или DXF. Для вывода топологии 
сделайте активным окно топологии схемы, и выберите в меню Layout>Export. 

 
Создание электромагнитных структур (ЕМ). 

В 7-ой версии Microwave Office интерфейс пользователя для работы с электромагнитными 
структурами значительно изменился. Прежним остался только способ создания электромагнитных 
структур. 

Электромагнитная структура представляет собой набор из одного или нескольких диэлектриче-
ских слоёв, расположенных в прямоугольном корпусе. На каждом из диэлектрических слоёв могут быть 
нанесены слои материала для топологических форм (проводящих и резистивных полосок или полигонов, 
межслойных перемычек). Чтобы можно было отличить слои друг от друга, диэлектрическим слоям на-



значаются номера (нумерация слоёв начинается с верхнего слоя). Слоям материалов назначаются инди-
видуальные имена для каждого типа материалов. При этом нужно различать два типа слоёв материалов: 

o Слои модели (Model Layers), которые содержат информацию для параметризированных ячеек 
топологии и для ячеек топологического чертежа (фотошаблона). 

o Слои черчения (Drawing Layers), которые используются для вычерчивания топологических 
форм и для экспорта топологии. Эти слои содержат информацию, необходимую для выполнения 
чертежа (тип и толщина линий, текстура и цвет заполнения и т.п.). 
Слои модели и слои черчения обычно имеют одни и те же имена, хотя это и не обязательно. 
Номер слоя диэлектрика, на котором вычерчиваются формы топологии, указывается в поле EM 

Layer в окне свойств каждой из форм или в окне менеджера топологии. Имя материала для каждой топо-
логической формы указывается в поле Material в указанных выше окнах. 

Поскольку на одном и том же диэлектрическом слое могут быть размещены топологические 
формы из разных материалов, для каждого из материалов должен быть назначен свой слой черчения. 
Этот слой указывается в поле Drawing Layer в окне свойств топологической формы. Конкретные спосо-
бы назначения слоёв и материалов будут показаны далее в примерах моделирования электромагнитных 
структур. 

Выполненная установка слоёв и материалов достаточна для выполнения анализа электромагнит-
ной структуры. Однако этого не достаточно для выполнения некоторых других операций, например, для 
импорта топологии из DXF или GDSII файлов. Имена слоёв должны быть записаны в DXF файле. Кроме 
того должны быть созданы таблицы соответствия между слоями: 

o Model Layer Mapping – таблица соответствия между слоями модели (Model Layer) и слоями 
черчения (Drawing Layer). 

o EM Layer Mapping – таблица соответствия между слоями черчения (Drawing Layer) и слоями 
диэлектрика (EM Layer). 
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o File Export Mapping – таблица соответствия между слоями черчения (Drawing Layer) и слоями, 
записываемыми в файл (File Layer). 
Эти таблицы доступны выбором в меню Options>Drawing Options. 

Чтобы создать новую электромагнитную 
структуру, щёлкните правой кнопкой мышки по 
группе EM Structures в окне просмотра проектов и 
выберите New EM Structure. Или щёлкните левой 

кнопкой мышки по значку New EM Structure  на 
панели инструментов (рис. 1.8). Откроется диалого-
вое окно, в котором нужно присвоить имя создавае-
мой электромагнитной структуре и выбрать решаю-
щее устройство для анализа структуры (рис. 1.9). 

После присвоения имени электромагнитной 
структуре на рабочем поле открывается пустое окно 
электромагнитной структуры (рис. 1.8) и в окне про-
смотра проекта отображается новая электромагнит-
ная структура, как подгруппа в группе EM Struc-
tures. Подгруппа новой электромагнитной структуры 
содержит все параметры и опции, которые опреде-
ляют и описывают её. Кроме того, в меню и на пане-

Рис. 1.8 

Рис. 1.9 



ли инструментов появляются новые пункты для черчения и моделирования электромагнитных структур. 
Прежде чем начертить электромагнитную структуру, необходимо определить параметры корпу-

са. Корпус определяется краевыми условиями и диэлектрическими материалами каждого слоя структу-
ры. 

Для определения корпуса дважды щёлкните по подгруппе Enclosure (Корпус) в окне просмотра 
проектов (рис. 1.10). Откроется диалоговое окно, в котором можно ввести необходимую информацию. 

После определения параметров корпуса можно чертить проводники, выбрав Draw (Рисовать) в 
выпадающем меню, чтобы отобразить опции рисования, или, щёлкая соответствующие значки на панели 
инструментов. Можно чертить элементы топологии типа проводников различной формы, межслойных 
переходов и портов. Так же можно вычерчивать дополнительные элементы топологии, такие как репер-
ные знаки, технологические площадки, текстовые надписи (можно использовать русские буквы) и т.п. 

Электромагнитные структуры можно просматривать в 2-х и в 3-х мерном отображении, выбрав 
команду View (Просмотр) из выпадающего меню. Токи в структуре и электромагнитные поля можно 
просмотреть, выбрав команду Animate (Анимация) из выпадающего меню. 

 
Замечание. При создании топологии в электромагнитных структурах обратите внимание, что в 
7-ой версии Microwave Office изменено направление оси Y. Теперь она направлена снизу вверх. 
 

Рис. 1.10 

Создание выходных графиков и добавление единиц измерения. 
Microwave Office даёт возможность просматривать результаты моделирования в виде различных 

графиков. Перед выполнением моделирования необходимо создать график. Необходимо так же опреде-
лить данные или единицы измерения, которые вы хотите видеть на графике, типа усиления, шумов или 
коэффициентов отражения. 

Чтобы создать график, щёлкните правой кнопкой мышки по группе Graphs (Графики) в окне 
просмотра проектов и выберите Add Graph (Добавить график) из всплывающего меню. Или щёлкните 

левой кнопкой мышки по значку New Graph  на панели инструментов. Появится диалоговое окно, в 
котором нужно задать имя графика и его тип. Пустой график появится на рабочем поле, и имя графика 
появится как подгруппа в группе Graphs в окне просмотра проекта. Доступны следующие виды графи-
ков: 

 Тип графика  Описание 

Прямоугольный Отображает измеряемые величины по осям X – Y, обычно по частоте 

Диаграмма Смита Отображает импедансы или адмитансы на круговой диаграмме 

Полярный Отображает величины и углы измеряемых величин  

Гистограммы Отображает измеряемые величины в виде гистограммы 

Антенная диаграмма Отображает измеряемые величины в виде диаграммы направленности 

Таблица Отображает измеряемые величины в виде таблицы, обычно по частоте 
Чтобы определить, какие данные вы хотите видеть на графике, щёлкните правой кнопкой мышки 

по имени нового графика в окне просмотра проекта и выберите Add Measurement во всплывающем ме-
ню или щёлкните правой кнопкой мышки по графику и выберите Add Measurement. Откроется диалого-
вое окно, в котором можно выбрать необходимое из списка измеряемых величин. 
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Чтобы просмотреть справку о различных параметрах единицы измерения, выделите представ-
ляющую интерес единицу измерения в диалоговом окне Add Measurement и нажмите Meas. Help. 

Полученный после выполнения анализа график можно закрепить, чтобы его можно было срав-
нить с другими вариантами моделирования, например, при каких-то изменениях в схеме. Чтобы закре-
пить график выберите в меню Graph>Freeze Traces при активном окне графика. Затем выполните изме-
нение в схеме и выполните анализ снова. Чтобы снять закрепление графика выберите в меню 
Graph>Clear Frozen. 
 
Установка частот для анализа и выполнение моделирования. 

Чтобы установить частоты для моделирования, дважды щёлкните по группе Options (Опции) в 
окне просмотра проектов или выберите в меню Options>Project Options. Откроется диалоговое окно, на 
вкладке Frequencies которого можно определить частоты для моделирования. По умолчанию все соз-
данные в проекте схемы используют для анализа частоты, установленные в этом окне. Для любой схемы 
или электромагнитной структуры проекта вы можете отменить использование частот проекта и назна-
чить индивидуальные частоты для анализа данной схемы или структуры. Для этого щёлкните правой 
кнопкой мышки по имени схемы или электромагнитной структуры в окне просмотра проекта и выберите 
Options. В открывшемся диалоговом окне снимите “галочку” в Use project defaults и введите частоты, 
которые будут использоваться только для выбранной схемы или структуры. 

Чтобы выполнить моделирование созданного проекта, выберите в меню Simulate>Analyze или 

щёлкните левой кнопкой мышки по значку Analyze  на панели инструментов. 
Microwave Office выполнит модели-

рование, автоматически выполняя соответст-
вующий метод моделирования для различных 
частей проекта, т. е. линейное моделирование, 
гармонический баланс, моделирование нели-
нейными рядами Вольтера, или моделирова-
ние электромагнитной структуры. 

После окончания моделирования, ре-
зультаты можно просматривать на созданных 
графиках (рис. 1.11) и затем настраивать 
и/или оптимизировать при необходимости. 
Блок настройки Microwave Office в режиме 
реального времени позволяет сразу же на-
блюдать изменение выходных параметров на 
графике при изменении параметров схемы 
движком тюнера или при проведении оптими-

зации. При настройке или оптимизации автоматически изменяется схема и связанные с изменяемыми 

параметрами элементы топологии. Для настройки схемы нажмите значок Tune Tool  

Рис. 1.11 

на панели инст-
рументов и выберите параметры в схеме, которые вы желаете настроить. Затем нажмите значок Tune, 

 чтобы их настроить. 

1.5 Сценарии и мастера 
Сценарии и мастера позволяют автоматизировать и расширить функциональные возможности 

Microwave Office. 
Сценарии – это программы Basic, которые пользователи могут записывать, чтобы, например, ав-

томатизировать задачи формирования схемы в Microwave Office. Чтобы получить доступ к созданию 
сценариев, выберите в меню Tools>Scripting Editor. 

Мастера – это файлы динамически загружаемых библиотек (DLL), которые можно использовать, 
как добавочные инструментальные средства, например, для синтеза фильтров. Мастера отображаются 
как подгруппы в группе Wizards в окне просмотра проекта. 

1.6 Помощь 
Страницы помощи Microwave Office обеспечивают необходимую информацию об окнах, пунк-

тах меню, диалоговых окнах, а так же обо всех элементах Microwave Office. 
Для получения справки выберите в меню Help или нажмите клавишу F1. Кроме того доступна 

также следующая контекстная помощь: 
 

o Кнопки помощи Help имеются в большинстве диалоговых окон. 
o Помощь по каждому элементу схемы можно получить, если выделить элемент на схеме и нажать 

Alt+F1. Или дважды щёлкнуть по элементу на схеме левой кнопкой мышки и в открывшемся 
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окне щёлкнуть по кнопке Element Help. Или в окне просмотра элементов щёлкнуть по элементу 
правой кнопкой мышки и выбрать Element Help. 

o Помощь по любой измеряемой величине для графиков можно получить, если щёлкнуть правой 
кнопкой мышки по имени графика в окне просмотра проекта, выбрать Add Measurement и в от-
крывшемся окне щёлкнуть по кнопке Meas Help. Или щёлкнуть правой кнопкой мышки по име-
ни измеряемой величины в окне просмотра проекта, выбрать Properties и в открывшемся окне 
щёлкнуть по кнопке Meas Help. 

 
 



2. Линейное моделирование 
Линейное моделирование для определения характеристик электрической цепи использует метод 

узловых напряжений. Оно может применяться для цепей типа усилителей в линейном режиме, фильтров, 
направленных ответвителей, делителей мощности и других, чьи элементы могут быть описаны матрицей 
полных проводимостей. Для линейного моделирования характерно определение измеряемых величин 
типа усиления, устойчивости, коэффициента отражения, коэффициента передачи. 

В блок линейного программирования включён блок настройки в реальном масштабе времени, 
который позволяет настраивать элементы схемы и сразу наблюдать результаты настройки. Имеется воз-
можность также выполнить оптимизацию различными методами и статистический анализ. 

Следующие примеры иллюстрируют некоторые из основных особенностей линейного модели-
рования в Microwave Office. 

2.1. Моделирование ФНЧ на сосредоточенных элементах 
Этот пример показывает, как использовать Microwave Office для моделирования ФНЧ на базо-

вых сосредоточенных элементах, используя линейное моделирование. Такое моделирование включает 
следующие основные шаги: 

• Создание схемы; 
• Добавление графиков и измеряемых величин; 
• Анализ схемы; 
• Настройка схемы; 
• Создание переменных для оптимизации; 
• Оптимизация схемы. 

Создание нового проекта. 
Сначала нужно создать новый проект. Для его создания сделайте следующее: 

1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта (например, linear-example) и нажмите Сохранить. 

По умолчанию Microwave Office обычно предлагает сохранить проект в папке Мои 
документы\AWR Project. Чтобы изменить папку, предлагаемую по умолчанию, выберите в меню Op-
tions>Environment Options (Опции>Опции среды). В открывшемся окне на вкладке File Locations (Раз-
мещение файлов) в текстовом поле Default Design Directory: (Директория, назначаемая по умолчанию:) 
введите путь к нужной папке, например, E:\USER\AWR2007, или нажмите кнопку Browse (Просмотр) 
справа от этого поля и выберите нужную папку. 

 
Установка единиц измерения, используемых по умолчанию. 

Чтобы установить единицы измерения, которые будут использоваться в проекте по умолчанию: 
1. Выберите в меню 

Options>Project Options 
(Опции>Опции проекта). 
Откроется диалоговое ок-
но Project Options (рис. 
2.1). 
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2. Нажмите панель Global 
Units (Глобальные опции) 
в верхней части диалого-
вого окна. 

3. Установите нужные еди-
ницы измерения, щёлкая 
по стрелкам, справа от 
поля ввода соответст-
вующей единицы так, 
чтобы они соответствова-
ли показанным на рис. 2.1, 
снимите флажок в поле 
Metric units (Метриче-

ские единицы), установите mil в поле Length type и нажмите OK. 
Рис. 2.1 

 
Создание схемы. 

Чтобы создать схему: 
 



1. Выберите Project>Add Schematic>New Schematic (Проект > Добавить схему > Новая схе-

ма) в выпадающем меню или щёлкните по значку New Schematic  на панели инстру-
ментов. Откроется диалоговое окно Create New Schematic (Создание новой схемы). 

щёлкните левой 

тора CAP и, не отпуская кнопки мышки, перетащите её в окно 

рисунке 

 

 Используйте полосы скроллинга справа и внизу окна схемы, чтобы отобразить в ок-
емы, с которой вы работаете. 

2. Наберите имя схемы, например, lpf и нажмите OK. Откроется окно схемы на рабочем поле 
и схема появится, как подгруппа lpf в группе Circuit Schematics (Схемы цепи) в окне про-
смотра проекта. 

 
Размещение элементов в схеме. 

Чтобы разместить элементы в схеме: 
1. Нажмите панель Elements в нижней части левого окна, чтобы открыть окно просмотра эле-

ментов (см. рис. 2.2). 
2. В категории Circuit Elements разверните группу сосредоточенных элементов (Lumped 

Element), щёлкнув по значку + слева от этой группы. 
3. Щёлкните левой кнопкой мышки по подгруппе Inductor (Индуктивности) в окне просмотра 

элементов. В нижней части окна появятся изображения доступных индуктивностей. 
4. Нажмите левой кнопкой мышки на модель индуктивности IND и, не отпуская кнопки мыш-

ки, перетащите её в окно схемы. Отпустите кнопку мышки, поместите элемент, как показа-
но на рисунке 2.2 и зафиксируйте, щёлкнув левой кнопкой мышки. 

5. Повторите шаг 4 три раза, совмещая и подключая каждую индуктивность, как показано на 
рисунке 2.3. 

6. Чтобы соединить один 
элемент с другим эле-
ментом, вы должны 
поместить элемент 
так, чтобы его узел 
присоединился к узлу 
другого элемента. При 
правильном соедине-
нии узел отображается 
в виде маленького зе-
лёного квадрата. Если 
сразу соединить эле-
менты не удалось, на-
жмите нужный эле-
мент левой кнопкой 
мышки и, не отпуская 
кнопки, переместите 
элемент в надлежащее 
место. 

7. Теперь 

Рис. 2.2 

кнопкой мышки по под-
группе Capacitor (Конден-
саторы) в окне просмотра 
элементов. В нижней части 
окна появятся изображения 
доступных конденсаторов. 

8. Нажмите на модель конденса

Рис. 2.3 

схемы, отпустите кнопку, щёлкните правой кнопкой мышки, чтобы повернуть элемент, по-
местите его, как показано на 
рисунке 2.4 и зафиксируйте, 
щёлкнув левую кнопку 
мышки. 

9. Повторите шаг 7 дважды, 
соединяя каждый конденса-
тор, как показано на 
2.4. 

Примечания. 

не ту часть сх

Рис. 2.4 

 Чтобы увеличить часть схемы, щёлкните по значку View Area  (Показать об-
ласть) на панели инструментов, курсор будет отображаться в виде лупы с крестиком. Пе-
реместите курсор в окно схемы, поместите курсор крестиком в левый верхний угол участка 
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схемы, который надо увеличить, нажмите на левую кнопку мышки и, не отпуская кнопки, 
переместите курсор в правый нижний угол выделяемого участка (выделяемая часть схемы 
будет обводиться прямоугольником). Отпустите кнопку мышки. 

 Чтобы уменьшить изображение схемы, щёлкните по значку Zoom Out  (Умень-
шить масштаб) на панели инструментов. 

 Чтобы отобразить всю схему, щёлкните по значку View All  (Показать всё) на 

 левой кнопкой мышки по этому элемен-
ту в схеме и нажмите клавишу Delete. 

Сое

ы первого конденсатора C1. Курсор будет отобра-
леноида, как показано на рисунке 2.5. 
нажмите и отпустите) левой кнопкой мышки, чтобы зафиксировать начало 

 

 

кой 

чку Por

панели инструментов. 
 Чтобы удалить элемент из схемы, щелкните

 
динение проводом. 

Чтобы соединить нижние клеммы конденсаторов: 
. Поместите курсор возле нижней клемм1
жаться в виде со

2. Щёлкните (т. е. 
провода, перетащите курсор к нижней клемме второго конденсатора С2, затем к нижней
клемме последнего конденсатора C3 и снова щёлкните левой кнопкой мышки (рис. 2.6). 

Рис. 2.5 Рис. 2.6 

Размещение портов. 
Чтобы разместить порты (входы): 

1. Выберите в меню Draw>Add Port (Рисовать>Добавить порт) или щёлкните левой кноп

t мышки по зна  на панели инструментов. 
емы, 

 к последней индук-

ой клемме по-

 
Ра

 меню Draw>Add Gr  (Рисовать>Добавить землю) или щёлкните левой 

ачку Ground 

2. Переместите курсор в окно сх
поместите порт на левой клемме 
первой индуктивности и щёлкните 
левой кнопкой мышки, чтобы за-
фиксировать его. 

3. Повторите шаги 1 и 2, чтобы под-
ключить порт
тивности, но после перемещения 
его в окно схемы, щёлкните два 
раза правой кнопкой мышки, что-
бы развернуть его на 180 градусов, 
подведите к прав

Рис. 2.7 

следней индуктивности и зафиксируйте, щёлкнув левой кнопкой (рис. 2.7). 

змещение земли. 
Чтобы поместить землю: 

ound1. Выберите в

кнопкой мышки по зн  на панели инструментов. 

 

1. Поместите курсор на элемент IND L1 (на катушку) в окне схемы и дважды щёлкните левой 
 окно Element Options (Опции элемента) 

2. Переместите курсор в окно схемы, поместите землю на нижней клемме конденсатора C1 и 
зафиксируйте, щёлкнув левой кнопкой мышки (см. рис. 2.7). 

Редактирование параметров элементов. 
Чтобы отредактировать параметры элементов: 

кнопкой мышки. Откроется диалоговое
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ение будет 

ано на рисунке 

тоты для моделирования: 
 по панели Project в нижней части левого окна, чтобы от-

ptions (Опции проекта). Откроется диалоговое окно 

ниц измерения дан-

Заменить). 

в поле 

жается частотный 

 
Создание

Что
1. Щёлкните правой кнопкой мыш-

е Graphs (Графики) 
проекта и вы-

2. На вкладке Parameters этого окна в текстовое поле, расположенное в столбце Value (Зна-
чение) напротив значения индуктивности (L), введите 15 и нажмите OK. Измен
отражено на схеме (рис. 2.8). Альтернативно, можно дважды щёлкнуть левой кнопкой 
мышки по значению параметра в схеме (в данном случае по параметру L=1 nH индуктивно-
сти ID=L1). Откроется поле редактирования, которое позволяет изменить значение пара-
метра непосредственно в схеме. 

3. По аналогии с шагами 1 
и 2 редактируйте значе-
ния индуктивностей и 
емкостей так, чтобы их 
значения были такими, 
как показ
2.8. (Чтобы редактиро-
вать ёмкости, выберите 
C в окне списка пара-
метров). 

 частот для моделирования. 
Чтобы задать час

 
Задание

1. Щёлкните левой кнопкой мышки
крыть окно просмотра проекта. 

2. Дважды щёлкните по группе Project O
Project Options. 

3. В этом окне откройте вкладку 
Frequencies (Частота). 

4. В области Data Entry Units 
(Ввод еди
ных) установите MHz, щёлкая 
по кнопкам в правом конце 
этого поля. 

5. Отметьте Replace (
Наберите 100 в поле Start (На-
чальная частота), 1000 
Stop (Конечная частота) и 10 
поле Step (Шаг). Нажмите Ap-
ply (Применить). В окне Cur-
rent Range (Текущий диапа-
зон) отобра
диапазон с заданным шагом по 
частоте (рис. 2.9). Нажмите 
OK. 

Примечание. Переход между полями ввода можно делать, щёлкая левой кнопкой мышки по 
нужному полю или нажимая клавишу Tab. 

 графика. 
бы создать график: 

Рис. 2.8 

Рис. 2.9 

ки по групп
в окне просмотра 
берите Add Graph (Добавить 
график) во всплывающем меню 
или щёлкните по значку  New 

Graph  на панели инстру-
ментов. Откроется диалоговое 
окно Create Graph (Создание 
графика). 

2. Наберите S21 and S11 в поле 
Graph Name (Имя графика). 
Отметьте Rectangular (Прямо-

фика появляется как подгруппа в группе Graphs в окне просмотра проекта (рис. 2.10). 

угольный) в переключателе 
Graph Type (Тип графика) и на-
жмите OK. Окно графика созда-
ётся на рабочем поле и имя гра-Рис. 2.10



Добавление к графику измеряемых величин. 
Чтобы добавить измеряемые величины к графику: 

1. Щёлкните правой кнопкой мышки по имени графика S21 and S11 в окне просмотра проекта 
и выберите Add Measurement (Добавить измеряемую величину) во всплывающем меню. 
Или щёлкните левой кнопкой мышки по значку Add Measurement на панели инструментов. 

Откроется диалоговое окно Add 
Measurement (см. рис. 2.11). 

2. Выберите Linear и затем Port 
Parameters (Параметры порта) в 
области Meas Type (Тип 
измеряемых величин). Выберите S 
в области Measurement 
(Измеряемая величина). Выберите 
lpf (т.е. имя схемы, которое вы ей 
дали) в поле Data Source Name 
(Имя источника данных, т. е. 
имеется ввиду имя схемы), 
нажимая на стрелку, справа от 
этого поля. Выберите 1 в поле To 
Port Index (Индекс входного 
порта), и в поле From Port Index 
(Индекс выходного порта), 
нажимая на стрелки, справа от 
этих полей. Отметьте dB в области 
Result Type (Тип результата), 

отметьте Mag (Модуль) в переключателе Complex Modifier (Представление комплексной 
величины) и нажмите Apply (Применить). 

Рис. 2.11 

3. Измените значение в поле To Port Index на 2 и нажмите Apply. 
4. Нажмите OK. Измеряемые величины lpf.DB(|S[1,1]|) и lpf.DB(|S[2,1]|) появятся как 

подгруппы в группе S21 and S11 в окне просмотра проекта. 
 
Анализ схемы. 

Чтобы выполнить анализ схемы: 
1. Выберите в меню 

Simulate>Analyze 
(Моделирование>Анализ) или 
щёлкните левой кнопкой мышки 

по значку Analyze  на панели 
инструментов. Результаты анализа 
отображаются на графике рис. 2. 
12. 

На графике в прямоугольнике 
отображается, какая кривая какой измеряемой 
величине соответствует. Размеры этого 
прямоугольника можно изменять, если щёлкнуть 
по нему левой кнопкой мышки, установить курсор 
на ромбик в середине любой стороны или на 
квадратик в углу (курсор при этом должен 

отображаться в виде двойной стрелки), нажать левую кнопку мышки и, не отпуская её, 
двигать курсор. Размер шрифта при этом изменяется автоматически. Весь этот 
прямоугольник можно переместить в любое место графика, если поместить курсор в 
прямоугольник (курсор при этом должен отображаться в виде перекрестия) и затем, нажав 
левую кнопку мышки и не отпуская её, двигать мышкой. 

При желании можно распечатать график, нажав левой кнопкой мышки на значок 
Print на панели инструментов при активном окне графика. 

Рис. 2.12 

 
Настройка схемы. 

Чтобы настроить схему: 
1. Щёлкните левой кнопкой мышки по окну схемы, чтобы сделать его активным. Или 

дважды щёлкните левой кнопкой мышки по имени схемы в окне просмотра элементов. 
2. Сначала нужно указать параметры элементов, которые необходимо изменять при 

настройке. Чтобы сделать это, щёлкните по значку Tune Tool  (Инструмент настройки) на 
панели инструментов. 
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3. Поместите курсор на параметр L индуктивности L1. Курсор должен отображаться в ви-
де перекрестия, как показано на рис. 2.13 (белое перекрестие в чёрном кружке). 

4. Щёлкните левой кнопкой мышки, чтобы активизировать параметр L для настройки. 
5. Повторите шаги со 

2-го по 4-ый для конденса-
торов C1, C3 и индуктив-
ности L4. Значения пара-
метров, назначенных для 
настройки, будут отобра-
жаться синим цветом. 

6. Щёлкните по окну 
графика, чтобы сделать его 
активным. 

Рис. 2.13 

7. Выберите Simulate>Tune в выпа-
дающем меню или щёлкните по значку Tune 

 на панели инструментов. Откроется диа-
логовое окно Variable Tuner (Блок настрой-
ки переменных), показанное на рис. 2.14. 

8. Нажмите левой кнопкой мышки на 

 Передвиньте бегунки настройки пе-

Variable Tuner. 
 

оздание переменных параметров для оптимизации. 
ссе оптимизации параметры симмет-

ричных

елать его активным. 
вить уравнение) или щёлкните по 

бегунок настройки и, не отпуская кнопки, 
двигайте его вверх и вниз. Результаты на-
стройки переменных наблюдайте на графи-
ке. 

9.
ременных в положения, указанные на рисун-
ке 2.14, и посмотрите результаты настройки 
на графике. 

10. Закройте окно Рис. 2.14 

С
Фильтры – это типично симметричные схемы. Т.е. в проце

 элементов должны изменяться на одинаковую величину. Поэтому оптимизируемый параметр 
каждой пары тех симметричных элементов, которые должны быть включены в процесс оптимизации, 
нужно заменить одним общим переменным параметром. Для этого сначала необходимо создать такой 
переменный параметр для каждой пары оптимизируемых симметричных элементов и затем заменить 
созданным параметром соответствующие параметры у обоих симметричных элементов. Для среднего 
элемента, если он в схеме один (в данном случае конденсатор C2) это делать не обязательно. 

Чтобы создать переменные параметры: 
1. Щёлкните по окну схемы, чтобы сд
2. Выберите в меню Draw>Add Equation (Рисовать>Доба

значку Equation  на панели инструментов. 
3. Переместите курсор в окно схемы. Появится окошко редактора в виде небольшого квадрата. 

ровать его. 

то-

е 

 

тобы назначить переменные для оптимизации: 
les или View>Variables. Или выберите в меню 

котором перечислены все переменные и параметры элементов с указанием схемы, к кото- 

4. Поместите окошко редактора выше 
схемы и щёлкните левой кнопкой 
мышки, чтобы зафикси
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5. Наберите IND=15 в окошко редактора 
и щёлкните мышкой вне этого окна. 

6. Повторите шаги со 2-го по 5-ый, ч
бы открыть второе окошко редактора, 
но наберите CAP=8, и щёлкнит
мышкой вне этого окошка. Результат 
показан на рис. 2.15. 

7. Дважды щёлкните по параметру L значения индуктивности IND L1. Появится окошко ре-

Рис. 2.15 

дактора. Наберите значение IND и щёлкните левой кнопкой мышки вне окошка редактора. 
8. Повторите шаг 7, чтобы заменить параметр L индуктивности IND L4 на IND, и параметры

конденсаторов CAP C1 и CAP C3 на CAP, как показано на рисунке 2.15. Переменные IND 
и CAP нужно назначить для оптимизации. 

 
Ч

1. Выберите в меню Simulate>View Variab
Simulate>Optimize и в открывшемся окне щёлкните левой кнопкой мышки по панели 
Variables в левой нижней части окна. Откроется диалоговое окно Variables (рис. 2.16), в 



рой они относятся. 
Обратите внима-
ние, в столбце Ele-
ment указывается 
тип элемента (в 
данном случае ём-
кость или индук-
тивность), а в 
столбце ID (Иден-
тификатор) указы-
вается идентифика-
тор (т.е. имя эле-
мента) на схеме. 
Для переменных в 
столбце ID указы-
вается имя схемы, к 
которой добавлена 
данная переменная. 

2. В столбце Opti-
mize отметьте пе-
ременные IND, 
CAP и параметр C 
для идентификато-

ра C2 элемента CAP, чтобы назначить их для оптимизации. Закройте окно переменных. 

Рис. 2.16 

 
За
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х и 
параметров элементов, изменяемых в процессе оптимизации. В тоже время на практике 

 желательно ограничить пределы возможных изменений параметров, например, чтобы 

ложения столбцов можно и мышкой. Для этого устано-

менные и параметры элементов. Другой способ, в котором каждая пере-

 
Доб

которая граница изменения какой-либо характери-
тики анализируемой схемы, к которой должен стремиться выбранный метод оптимизации при измене-

та отражения в полосе пропускания. Для этого щёлкните пра-
ation Goals (Цели оптимизации) и выберите Add Opt Goal 

. Откроется диалоговое окно New Op-

оле Stop, введите –17 в поле Goal 
(Цель), и нажмите OK. 

мечания. 
• В данном случае мы не накладываем никаких ограничений на значения переменны

часто
не получить нереализуемые значения размеров топологии. Чтобы ограничить пределы 
изменения значений переменных и параметров элементов, отметьте столбец Constrained 
(Ограничить). В столбце Lower (Нижний) введите нижний допустимый предел изменения 
параметра, а в столбце Upper (Верхний) введите верхний допустимый предел изменения 
параметра. Если этих столбцов нет в окне Variables, щёлкните правой кнопкой мышки по 
строке имён столбцов в верхней части окна и в открывшемся дополнительном окне 
отметьте Constrained, Lower и Upper. На рис. 2.16 показано окно Variables с открытым 
дополнительным окном для установки недостающих столбцов или для удаления ненужных 
столбцов. Заметим, что таким же образом можно добавить столбцы, чтобы назначать 
переменные для статистического анализа. 

• Если щёлкнуть левой кнопкой мышки по нижней строчке More (Больше) в дополнительном 
окне, то дополнительно можно изменять ширину столбцов или менять порядок их распо-
ложения. Изменить порядок распо
вите курсор на имя столбца, нажмите левую кнопку мышки и просто перетащите столбец 
на новое место. 

• Указанный способ назначения переменных для оптимизации не является единственным. Он 
удобен тем, что в одном диалоговом окне можно назначить для оптимизации сразу все не-
обходимые пере
менная или параметры каждого элемента назначаются для оптимизации индивидуально, 
мы рассмотрим в следующем примере. 

авление целей оптимизации. 
Под целью оптимизации подразумевается не

с
нии определённых параметров элементов. 

Чтобы добавить цели оптимизации: 
1. Откройте вкладку Project в левом окне проекта. 
2. Введите цель для коэффициен

вой кнопкой мышки по Optimiz
(Добавить цель оптимизации) во всплывающем меню
timization Goal (Новая цель оптимизации) (см. рис. 2.17). 

3. Выделите lpf:DB(|S[1,1]|) в окне списка измеряемых величин Measurement. Отметьте 
Meas<Goal (Измеряемая величина<Цель) в области Goal Type (Тип цели), уберите “галоч-
ку” в поле Max в области Range (Предел), введите 500 в п
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 в поле Goal и на-

е –30 в поле Goal и на-

граждения. 
 -17 – желательное предельное значение коэффициента отражения S11 в полосе про-

оэффициента передачи S21 в полосе 

циента передачи S21 в полосе загра-

отображаются на гра-
фике в
и мо
тимизации ышки по 
мени цели в окне просмотра проекта и выберите 

Propert

 

Чтобы выполнить оптимизацию: 
ню Simulate>Optimize (Моделирование > Оптимизация). Откроется диало-

). 

мизации), наберите 5000 в поле Maximum Iteration (Мак-

4. Введите цель для коэффициента пе-
редачи в полосе пропускания. Для 
этого повторите шаги 2 и 3, но вы-
делите lpf: DB(|S[2,1]|) в окне спи-
ска измеряемых величин, отметьте 
Meas>Goal в области Goal Type, 
уберите “галочку” в поле Max в об-
ласти Range, введите 500 в поле 
Stop, введите –1
жмите OK. 

5. Введите цель для коэффициента пе-
редачи в полосе заграждения. Для 
этого повторите шаги 2 и 3 снова, 
но введите lpf: DB(|S[2,1]|) в окне 
списка измеряемых величин, от-
метьте Meas<Goal в поле Goal 
Type, уберите “галочку” в поле Min 
в области Range, введите 700 в поле 
Start, введит
жмите OK. 

 
Примечание. Ведённые значения означают следующее: 

 500 MHz – это верхняя (максимальная) частота полосы пропускания, 700 MHz – это 
нижняя (минимальна

Рис. 2.17 

я) частота полосы за

пускания; -1 – желательное предельное значение к
пропускания. 

 -30 – желательное предельное значение коэффи
ждения. 

 
Цели оптимизации 

 виде границ со штриховкой (см. рис. 2.18) 
гут быть изменены. Для изменения цели оп-

 щёлкните правой кнопкой м
и

ies. Откроется диалоговое окно для изме-
нения цели, аналогичное окну рис. 2.17, в котором 
можно изменить цель оптимизации. Цель оптими-
зации можно изменить и непосредственно на гра-
фике. Чтобы изменить цели оптимизации непо-
средственно на графике, щёлкните по нужной це-
ли левой кнопкой мышки. Затем поместите курсор 
на заштрихованный участок цели на графике (кур-
сор отображается в виде перекрестия), или помес-
тите курсор на квадратик в уголке цели (курсор 
отображается в виде двойной стрелки), нажмите 
левую кнопку мышки и, не отпуская её, двигайте в 
нужном направлении. Изменять цель при этом 

можно как по величине параметра, так и по частоте. 
Обратите внимание, что направление штриховки у цели на графике указывает на недопустимые 

значения измеряемой величины. 

Рис. 2.18 

Оптимизация схемы. 

1. Выберите в ме
говое окно Optimize (рис. 2.19

2. Выберите метод оптимизации Random (Local) (Случайный (Локальный)) в области Opti-
mization Methods (Методы опти
симум итераций), щёлкая по стрелке справа от поля, и нажмите Start, чтобы начать оптими-
зацию. 



3. Когда оптимизация 
закончится, за-
кройте диалоговое 
окно Optimize. Ре-
зультаты оптими-
зации отобража-
ются на графике и 
на схеме, как пока-
зано на рисунках 
2.20 и 2.21. 

В заключение вы 
можете, при желании, сохра-
нить вашу работу, выбрав в 
меню File>Save Project 
(Файл>Сохранить проект) 
или щёлкнув левой кнопкой 
мышки по значку Save Pro-
ject  на панели инструмен-
тов. 
 
 
 Рис. 2.19 

Рис. 2.21 Рис. 2.20 

2.2. Моделирование микрополоскового заграждающего фильт-
ра 

 
Создание нового проекта. 

Для создания нового проекта сделайте следующее: 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта (например, Fil-z) и нажмите Сохранить. 

 
Установка единиц измерения, используемых по умолчанию. 

Установите единицы измерения, которые будут использоваться по умолчанию, как описано в 
примере 2.1, но для частоты установите GHz, установите флажок в поле Metric units и mm в Length 
type. 

 
Создание схемы. 

Чтобы создать схему: 

1. Щёлкните по значку New Schematic  на панели инструментов. 
2. Наберите имя схемы, например, zfil и нажмите OK. 

 
Размещение элементов в схеме. 

1. Нажмите панель Elements в нижней части левого окна. 
2. Щёлкните по значку + слева от группы Microstrip (Микрополоска) в окне просмотра эле-

ментов. 
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3. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 
4. Найдите модель MLIN, пользуясь полосой скроллинга, переместите её в окно схемы и за-

фиксируйте, щёлкнув левой кнопкой мышки. 
5. Щёлкните по подгруппе Junction (Соединения) в окне просмотра элементов. 
6. Найдите модель MTEE$, переместите её окно схемы, подсоедините к правому концу эле-

мента MLIN и зафиксируйте, щёлкнув левой кнопкой мышки. 
7. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 
8. Найдите модель MLEF, переместите её окно схемы, щёлкните три раза правой кнопкой 

мышки, чтобы повернуть элемент, подсоедините его к плечу 3 элемента MTEE$ и зафикси-
руйте, щёлкнув левой кнопкой мышки. 

9. Нажмите клавишу Shift и, не отпуская её, щелкните по очереди по моделям MLIN 
(ID=TL1), MTEE$ (ID=TL2) и MLEF (ID=TL3), затем отпустите клавишу Shift. 

10. Щёлкните по значку Copy (Копировать)  на панели инструментов. 
11. Щёлкните по значку Paste (Вставить)  на панели инструментов. 
12. Подключите скопированную группу к плечу 2 элемента MTEE$ (ID=TL2) и зафиксируйте 

её, щелкнув левой кнопкой мышки. 
13. Снова щёлкните по значку Paste на панели инструментов, подключите скопированную 

группу к плечу 2 элемента MTEE$ (ID=TL6) . и зафиксируйте её, щёлкнув левой кнопкой 
мышки. 

14. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 
15. Найдите модель MLIN, переместите её в окно схемы, подсоедините её к плечу 2 последнего 

элемента MTEE$ (ID=TL6) и зафиксируйте её, щёлкнув левой кнопкой мышки. 
 
Размещение портов. 

1. Щёлкните по значку Port  на панели инструментов. 
2. Поместите порт на левом конце первого элемента MLIN. 
3. Снова щёлкните по значку Port на панели инструментов. 
4. Поместите порт на правом конце последнего элемента MLIN, предварительно развернув 

его на 180 градусов, щёлкая правой кнопкой мышки. 
 
Определение параметров подложки. 

1. Щёлкните по группе Substrates (Подложки) в окне просмотра элементов. 
2. Перетащите элемент MSUB в окно схемы, поместите его на свободном месте, например, 

ниже схемы. 
3. Дважды щёлкните по элементу MSUB в окне схемы. Откроется окно редактирования. Вве-

дите: 
• Er=10.44 – относительная диэлектрическая проницаемость; 
• H=0.5 – толщина подложки; 
• T=0.005 – толщина проводника; 
• Rho=1 – удельное сопротивление металла проводника, нормированное к золоту; 
• Tang=0.0001 – тангенс угла потерь; 
• ErNom=10.44 – номинальная диэлектрическая проницаемость; 
• Name=SUB1 – имя подложки. 

4. Нажмите OK. 
 
Добавление переменных. 

При настройке или оптимизации одинаковым образом должны изменяться параметры второго и 
третьего элементов MLIN (расстояний между шлейфами), а так же параметры первого и третьего эле-
ментов MLEF. Поэтому добавим в схему следующие переменные: 

1. Щёлкните левой кнопкой мышки по значку Equation  на панели инструментов. 
2. Переместите курсор в окно схемы и щёлкните левой кнопкой мышки на свободном месте 

выше схемы. В открывшееся  поле введите LL=3.5 (длина второго и третьего элементов 
MLIN) и щёлкните левой кнопкой мышки вне этого поля. 

3. Повторяя шаги 1 и 2, введите переменные WL=0.45 (ширина второго и третьего элементов 
MLIN), L1=3.5 и W1=0.45 (длина и ширина первого и третьего элементов MLEF). 
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Редактирование параметров элементов. 
1. Дважды щёлкните по 

первому элементу 
MLIN. В открывшемся 
окне (рис. 2.22) введите 
W=0.45 mm (т.е. введите 
0.45 в поле Value пара-
метра W) и L=3 mm. 
Нажмите OK. Такие же 
значения параметров 
введите для последнего 
четвёртого элемента 
MLIN. 

2. Аналогично введите 
W=WL mm, L=LL mm 
для второго и третьего 
элементов MLIN. 

3. Дважды щёлкните по 
первому элементу 
MLEF. Введите W=W1 
mm, L=L1 mm. Нажмите 
OK. Такие же значения 
параметров введите для 
последнего третьего 
элемента MLEF. 

Рис. 2.22 

4. Аналогично введите W=0.45 mm, L=3.5 mm для второго элемента MLEF. 
Полученная схема показана на рис. 2.23. 

Рис. 2.23 

 
Задание частот для моделирования. 

1. Нажмите панель Project в нижней части левого окна, чтобы открыть окно просмотра проек-
та. 

2. Дважды щёлкните по группе Project Options (Опции проекта). Откроется диалоговое окно 
Project Options. 

3. Щёлкните левой кнопкой мышки по Frequencies (Частоты), чтобы открыть эту вкладку, ес-
ли она не открыта. 

4. Наберите 4 в поле Start (Начальная частота), 12 в поле Stop (Конечная частота) и 0.25 поле 
Step (Шаг), отметьте Replace (Заменять), отметьте Linear (Линейная). Нажмите Apply 
(Применить). В окне Current Range (Текущий диапазон) отображается частотный диапазон 
и шаг по частоте. Нажмите OK. 

 
Создание графика и добавление измеряемых величин. 

1. Щёлкните по значку Add Graph  на панели инструментов. 
2. Введите имя графика, например, Graph 1 в поле Graph name (Имя графика), выберите Rec-

tangular (Прямоугольный) в области Graph Type (Тип графика) и нажмите OK. 
3. Щёлкните правой кнопкой мышки по подгруппе Graph 1 в окне просмотра проекта и выбе-

рите Add Measurement. 
4. Выберите Port Parameter в списке Meas. Type, S в списке Measurement, zfil в поле Data 

Source Name, 2 в поле To Port Index (Индекс входного порта), 1 в поле From Port Index 
(Индекс выходного порта), нажимая на стрелки справа от этих полей. В области Complex 
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Modifier (Модификатор комплексного числа) отметьте Mag и снимите “галочку” в dB, если 
она установлена, нажмите Apply и затем OK. 

 
Анализ схемы. 

1. Щёлкните левой кнопкой мышки по значку Analyze  на панели инструментов.  
2. Щёлкните правой кнопкой мышки по полученному графику и выберите Properties. Откро-

ется диалоговое окно свойств графика (рис. 2.24). 
3. На вкладке Axes этого окна в области Choose axis (Выбрать ось) отметьте ось x. В области 

Divisions (Деления) снимите “галочку” в Auto divs и в поле Step (Шаг) введите 0.5. Это бу-
дет шаг по оси частот. Нажмите Apply и OK. Результаты анализа отображаются на графике 
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рис. 2.25. 

Назна
особ назначения переменных и параметров, отличный от спосо-

ции переменную 

Рис. 2.25 Рис. 2.24 

 
чение переменных и параметров для оптимизации. 
Здесь мы рассмотрим другой сп

ба, описанного в предыдущем примере. 
1. Откройте окно схемы. 

Щёлкните правой кнопкой 
мышки по переменной 
LL=3.5 и выберите Proper-
ties. Откроется окно редак-
тирования переменной Edit 
Equation (рис. 2.26). В поле 
Variable Name отобража-
ется имя переменной, а в 
поле Variable Value ото-
бражается значение этой 
переменной. При желании 
здесь вы можете изменить 
имя переменной и её значе-
ние. В области Tun-
ing/Optimization Mode 
(режим настрой-
ки/оптимизации) отметьте 
Optimize. На вариации зна-
чений длины мы не будем 
накладывать ограничений, 
поэтому не отмечайте Con-
strain (Огран

Рис. 2.26 

ичить). На-
жмите OK. 

2. Аналогично с такими же 
параметрами назначьте для 
оптимиза
L1=3.5. 

3. Щёлкните правой кнопкой 
мышки по переменной 
WL=0.45 и выберите Prop-
erties. В открывшемся окне Рис. 2.27 
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-

мен-

 OK. 

(рис. 2.27) отметьте Optimize. Здесь мы ограничим ширину полоски, поэтому отметьте 
Constrain. В поле 
Upper bound 
(Верхняя граница) 
введите 1, а в поле 
Lower bound (Ниж-
няя граница) введи
те 0.1. Нажмите OK. 

4. Аналогично с таки-
ми же параметрами 
назначьте для опти-
мизации пере
ную W1=0.45. 

5. Дважды щёлкните 
по второму элемен-
ту MLEF, или 
щёлкните по нему 
правой кнопкой 
мышеи и выберите 
Properties. Откро-
ется диалоговое ок-
но свойств элемента 
(рис. 2.28). Для па-

раметра W отметьте столбцы Opt и Limit (Предел). В столбце Lower (Нижний) введите 0.1, 
а в столбце Upper (Верхний) введите 1. Значение длины мы ограничивать не будем, поэто-
му для параметра L отметьте только столбец 

Рис. 2.28 

Opt. Нажмите
Установка целей оптимизации. 

1. Откройте окно графика. 
Установите цель опти-
мизации в полосе за-
граждения. Щёлкните 
правой кнопкой мышки 
по Optimizer Goals в 
левом окне проекта и 
выберите Add Opt Goal. 
В открывшемся окне 
рис. 2.29 в области Goal 
Type отметьте 
Meas<Goal, в области 
Range (диапазон) сни-
мите “галочки” в полях 
Min и Max. В поле Start 
введите 7.5, в поле Stop 
введите 8.5. В поле Goal 
start в нижней части 
окна введите -50. На-
жмите OK. 

2. Установите цель опти-
мизации в нижней поло-
се пропускания. Снова 

щёлкните правой кнопкой мышки по Optimizer Goals в левом окне проекта и выберите Add 
Opt Goal. В открывшемся окне в области Goal Type отметьте Meas>Goal, в области Range 
(диапазон) снимите “галочку” в поле Max. и в поле Stop введите 5.5. В поле Goal start вве-
дите -1. Нажмите OK. 

Рис. 2.29 

3. Установите цель оптимизации в верхней полосе пропускания. Снова щёлкните правой 
кнопкой мышки по Optimizer Goals в левом окне проекта и выберите Add Opt Goal. В от-
крывшемся окне в области Goal Type отметьте Meas>Goal, в области Range (диапазон) 
снимите “галочку” в поле Min, в поле Start введите 10 и в поле Goal start введите -1. На-
жмите OK. 

Установленные цели будут отображены как подгруппы в группе Optimizer Goals в левом окне 
просмотра проекта и на графике. 
 
 
 
 



Выполнение оптимизации. 
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ы

ы т

story (Хронология значимости) отображается график изменения целевой функции 
в зависи

ции выводятся выполненное количество итераций 
анализа

 Show all iteration (Показывать все итерации), то на 
графике

ки по кнопке Start в окне. 
График, 

Чтобы выполнить 
оптимизацию в берите в ме-
ню Simulate>Optimize. От-
кроется диалоговое окно 
Optimizer (рис. 2.30). В этом 
окне в области Optimization 
Methods в берите ме од оп-
тимизации Pointer - Robust 
Optimization, щёлкая по 
кнопке в правом конце этого 
поля ввода. В поле ввода 
Maximum Iterations введите 
максимальное количество 
итераций 500. В окне Relative 
Goal Cost (Относительная 
стоимость цели) указывается 
в виде гистограммы относи-
тельная значимость цели, т.е. 
насколько далека поставлен-
ная цель от имеющегося зна-
чения характеристики. В на-
шем случае наибольшую зна-
чимость имеет вторая цель, 
т.е. наибольшее отклонение 
от заданной величины ослаб-

ления имеется в верхней полосе пропускания, а наименьшую значимость имеет третья цель, т.е. ближе 
всего к заданному значению ослабления характеристика имеет в нижней полосе пропускания. Это можно 
видеть и на графике фильтра. При желании значимость целей можно уровнять, щёлкнув левой кнопкой 
мышки по кнопке Equalize Goals (Выровнять цели) в окне, это приведёт к выравниванию столбцов гис-
тограммы и изменению веса каждой цели так, чтобы изменение параметров вносили одинаковый вклад в 
изменение целевой функции. В процессе оптимизации высота столбцов гистограммы будет изменяться. 

В окне Cost Hi

Рис. 2.30 

мости от выполненного количества итераций. 
Ниже указанных областей в процессе оптимиза

 (Simulator Iter) и оптимизации (Optimizer Iter), а так же значение целевой функции (Cost), 
которое при отимизации должно стремитья к нулю. 

Если поставить «галочку» в небольшом поле
 будут отображаться (мелькать) характеристики каждой итерации. 
Чтобы начать выполнение оптимизации, щёлкните левой кнопкой мыш
полученный после оптимизации показан на рис. 2.31, а новые значения переменных и 

параметров элемента MLEF на рис. 2.32. 

 

Рис. 2.32 Рис. 2.31 

 
 



 29

ывод результатов в файл. 
 мышки по 

рите Add Port Parameter File 

 Data 

татов будет 

. 

оздание топологии схемы. 
1. Откройте окно схемы. 

В
1. Щёлкните правой кнопкой

группе Output Files (Выходные фай-
лы). 

2. Выбе
(Добавить параметр порта), откроется 
окно (см. рис. 2.33) Output Data File 
(Выходной файл данных). 

3. Выберите S Parameter в области
Type (Тип данных). Выберите 
Mag/Ang в области Format. В поле Se-
lect Data Source (Выберите источник 
данных) отметьте имя схемы (если в 
проекте их несколько), график которой 
вы хотите вывести в файл. 

4. По умолчанию файл резуль
создан в папке, в которой находится 
файл моделируемого проекта. При же-
лании вы можете сохранить этот файл в 
любой другой папке или изменить имя 
файла, предлагаемое по умолчанию, 
щёлкнув левой кнопкой мышки по Set 
file name…(Установить имя файла…). 

5. Нажмите OK и затем щёлкните по 
значку Anal

Рис. 2.33 

yze на панели инструментов
 
С

2. Щёлкните левой кноп-
кой мышки по значку 
New Schematic Layout 
View (Показать новую 

топологию схемы)  
на панели инструмен-
тов, чтобы открыть 
окно топологии на ра-
бочем поле. В этом 
окне будут отображе-
ны все элементы топо-

 расположение топологических 
элементов может быть беспорядочным, как, например, показано на рис. 2.34. Как правильно 
должны соединяться элементы топологии на этом рисунке показывают красные линии. 

3. Установите курсор мышки левее и выше топологии, нажмите левую кнопку мышки и

Рис. 2.34 

логии, соответствующие каждому элементу схемы. Однако

, не 
отпуская кнопки, переместите курсор правее и ниже топологии, чтобы выделить все эле-

менты топологии, отпус-
тите кнопку. Или в меню 
выберите Edit>Select All. 

4. Щёлкните по значку 
Snap Together (Привя-

зать вместе)  на панели 

одном у

инструментов или выбе-
рите в меню Edit>Snap 
Together. Расположение 
элементов топологии бу-
дет упорядочено и топо-

логия будет иметь вид, показанный на рис. 2.35. 

Рис. 2.35 

 
Экспорт топологии в файл. 

В данном случае топология очень простая и состоит только из проводников, расположенных на 
ровне. Поэтому можно использовать все опции экспорта топологии по умолчанию. Выберите в 

меню Layout>Export. Откроется диалоговое окно Export Layout (рис. 2.36). В этом окне выберите пап-
ку, в которой вы хотите сохранить файл топологии, и введите имя файла или согласитесь с предлагае-
мыми по умолчанию. В поле Тип файла выберите тип файла, в котором вы сохраняете топологию, на-



пример, DXF[DXF Flat,*.dxf]. Щёлкните мыш-
кой по кнопке Сохранить. В AutoCAD сохра-
нённая топология будет иметь вид, показанный 
на рис. 2.37. 

Сохранённая топология состоит из от-
дельных соприкасающихся топологических 
элементов, в данном случае прямоугольников. В 
некоторых случаях удобнее соприкасающиеся 
топологические элементы объединить (напри-
мер, для некоторых типов координатографов). 
Это можно сделать при экспорте топологии, 
установив соответствующую опцию экспорта. 
Выберите в меню Options>Layout Options. На 
вкладке Export/LPF открывшегося окна от-
метьте Union layout shapes (Объединить формы 
топологии) и нажмите OK. Теперь в AutoCAD 
сохранённая топология будет иметь вид, пока-
занный на рис. 2.38. Рис. 2.36 

При желании можно сохранить проект, выбрав в меню File>Save Project (Файл>Сохранить про-
ект) или щёлкнув левой кнопкой мышки по значку Save Project  на панели инструментов. 

Рис. 2.37 Рис. 2.38

 

2.3. Моделирование микрополоскового аттенюатора на рези-
сторах 

 
Создание нового проекта. 

Сначала нужно создать новый проект. Для его создания сделайте следующее: 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как) в. Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта At20 и нажмите Сохранить. 

 
Установка единиц измерения, используемых по умолчанию. 

Установите единицы измерения, которые будут использоваться по умолчанию, как описано в 
примере 2.1, но для частоты установите GHz, установите флажок в поле Metric units и mm в Length 
type. 
 
Создание схемы. 

1. Щёлкните по значку New Schematic  на панели инструментов. 
2. Наберите имя схемы atr20 и нажмите OK. 
3. Нажмите панель Elements в нижней части левого окна. 
4. Щёлкните по значку + слева от группы Microstrip в окне просмотра элементов. 
5. Щёлкните по подгруппе Lines в окне просмотра элементов. 
6. Найдите модель MLIN, пользуясь полосой скроллинга, переместите её в окно схемы и за-

фиксируйте, щёлкнув левой кнопкой мышки. 
7. Щёлкните по подгруппе Components (Компоненты) в окне просмотра элементов. 
8. Найдите модель TFR, переместите её в окно схемы, отпустите кнопку мышки, подключите 

модель к правому выводу элемента MLIN и зафиксируйте, щёлкнув левой кнопкой мышки. 
9. Нажмите клавишу Shift и, не отпуская её, щёлкните левой кнопкой мышки по элементам 

MLIN и TFR. 
10. Щелкните по значку Copy и затем по значку Paste на панели инструментов. 
11. Переместите курсор в окно схемы, подключите скопированные элементы к правому выводу 

элемента TFR и щёлкните левой кнопкой мышки, чтобы зафиксировать их. 
12. Щелкните по значку Paste на панели инструментов. 
13. Переместите курсор в окно схемы, подключите скопированные элементы к правому выводу 

элемента TFR и щёлкните левой кнопкой мышки, чтобы зафиксировать их. 

 30
14. Повторите п. 12 и 13, чтобы подключить ещё одну пару элементов. 
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ключите её к правому выводу 

ll на панели инструментов, чтобы видеть всю схему. 

азмещение портов. 
значку Port  на панели инструментов. 

IN. 

N, предварительно развернув 

 
едактирование параметров элементов. 

ки по первому проводнику ID=TL1. Откроется диа-

и нажмите OK. 
леднего проводника ID=TL9. 

рывшемся 

днего проводника ID=TL7. 
ывшем-

стору ID=TL2 и в открывшемся 

стора ID=TL8. 
метры W=0.4, 

 
пределение параметров подложки. 

одложки) в окне просмотра элементов. 
месте, например, 

ните по элементу MSUB в окне схемы. Откроется окно редактирования. Вве-

Er=10.55 – относительная диэлектрическая проницаемость; 

ка; 
 металла проводника, нормированное к золоту; 

рическая проницаемость; 

 
адание частот для моделирования. 

 части левого окна, чтобы открыть окно просмотра проек-

жды щёлкните по группе Project Options (Опции проекта). Откроется диалоговое окно 

ies (Частоты). 
ьная частота), 18 в поле Stop (Конечная частота) и 1 поле 

Step (Шаг), отметьте Replace (Заменять), отметьте Linear (Линейная). Нажмите Apply 

15. Щёлкните по подгруппе Lines в окне просмотра элементов. 
16. Найдите модель MLIN, переместите её в окно схемы и под

последнего элемента TFR. 
17. Щелкните по значку View A

 
Р

1. Щёлкните по 
2. Поместите порт на левом конце первого элемента ML
3. Снова щёлкните по значку Port на панели инструментов. 
4. Поместите порт на правом конце последнего элемента MLI

его на 180 градусов, щёлкая правой кнопкой мышки. 

Р
1. Дважды щёлкните левой кнопкой мыш

логовое окно Element Options. 
2. Введите W=0.456 mm, L=5 mm 
3. Аналогично такие же параметры введите для пос
4. Дважды щёлкните левой кнопкой мышки по второму проводнику ID=TL3 и в отк

окне введите W=1.009 mm, L=2.022 mm, нажмите OK. 
5. Аналогично такие же параметры введите для предпосле
6. Дважды щёлкните левой кнопкой мышки по среднему проводнику ID=TL5 и в откр

ся окне введите W=1.883 mm, L=1,953 mm, нажмите OK. 
7. Дважды щёлкните левой кнопкой мышки по первому рези

окне введите W=0.4 mm, L=0.545 mm, RS=50, нажмите OK. 
8. Аналогично такие же параметры введите для последнего рези
9. Аналогично для двух средних резисторов ID=TL4 и ID=TL6 введите пара

L=0.215, PS=50. 

О
1. Щёлкните по группе Substrates (П
2. Перетащите элемент MSUB в окно схемы, поместите его на свободном 

ниже схемы. 
3. Дважды щёлк

дите: 
 
 H=0.5 – толщина подложки; 
 T=0.005 – толщина проводни
 Rho=1 – удельное сопротивление
 Tang=0,0001 – тангенс угла потерь; 
 ErNom=10.55 – номинальная диэлект
 Name=SUB1 – имя подложки. 

Полученная схема показана на рис. 2.39. 

Рис. 2.39 

З
1. Нажмите панель Project в нижней

та. 
2. Два

Project Options. 
3. Нажмите Freqenc
4. Наберите 4 в поле Start (Начал
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Создание яемых величин и анализ схемы. 

фика), выберите 
а) и нажмите OK. 

екта и выберите Add 

Parameter в 

та), и From Port In-

(Применить). В окне Current Range (Текущий диапазон) отображается частотный диапазон 
и шаг по частоте. Нажмите OK. 

 графика, добавление измер
1. Щёлкните по значку New Graph на панели инструментов. 
2. Введите имя графика, например, Graph 1 в поле Graph name (Имя гра

Rectangular (Прямоугольный) в области Graph Type (Тип график
3. Нажмите панель Project в нижней части левого окна. 

4. Щёлкните правой кнопкой 
мышки по подгруппе Graph 1 в окне 
просмотра про
Measurement. 

5. Выберите Port 
списке Meas. Type, S в списке Meas-
urement, atr20 в поле Data Source 
Name, 1 в полях To Port Index (Ин-
декс входного пор
dex (Индекс выходного порта), нажи-
мая на стрелки, справа от этих полей, 
отметьте dB и Mag в области Complex 
Modifier, нажмите Apply. 

6. Выберите 2 в поле To Port In-
dex и нажмите Apply. 

7. Нажмите OK. 
8. Щёлкните левой кнопкой мыш-

ки  

Рис. 2.40 

 по значку Analyze  на панели инструментов. Результаты анализа отображаются на гра-

гут быть определены при анализе схе-
surement (см. рис. 2.11). Для линейных схем 

ы схемы. Но часто бывает удобнее опре-
делить н

тров 
схемы, 

акая запись означает, что переменной S11 поставлен в соответствие модуль элемента S[1,1] 
матрицы ение элемента S[1,1]. При этом может быть присвоено 
комплексное значение, или только его действительная часть, или только мнимая, или модуль. Опреде-
лённую

S21= atr20:S[2,1] 

 
Заметим ременные являются комплексными числами. Затем необходимо опре-

делить коэффиц т нагрузки, т.е. присвоить значение коэффициента отражения некото-
рой пер й, например 

нение для определения коэффициента отражения по входу схемы: 
 

G=S11+S12*S21*Gn/(1-S22*Gn) 

, наконец, уравнение для определения KstU: 

фике рис. 2. 40. 
 
Создание выходных параметров и уравнений. 

Список выходных параметров по умолчанию, которые мо
мы, перечислены в области Measurement в окне Add Mea
обычно в качестве выходных параметров выбирают S-параметр

е элементы S-матрицы, а другие параметры, например, KstU и/или рабочее ослабление Ldb. 
В Microwave Office имеется возможность добавить к имеющимся по умолчанию выходным па-

раметрам другие параметры и уравнения для их определения. Делается это следующим образом. 
Определяется какая-либо переменная и ставится в соответствие одному из выходных параме
определяемому в процессе анализа, например, какому-либо элементу S-матрицы. Это делается 

вводом выражения типа: 
 
S11=atr20: |S[1,1]|, где atr20 – имя схемы. 
 
Т
, т.е. переменной S11 присваивается знач

 новую переменную S11 уже можно использовать в любом уравнении. Использовать непосредст-
венно значение S[1,1] в уравнениях нельзя, т.к. это значение не связано ни с какой переменной. Напри-
мер, чтобы определить и построить график KstU при работе схемы на несогласованную нагрузку, нужно 
определить следующие переменные: 

 
S11= atr20:S[1,1] 
S12= atr20:S[1,2] 

S22= atr20:S[2,2] 

, что здесь все пе
иент отражения о

еменно
Gn=0.01+j*0.05 

 
Затем записать урав

 
И
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KstU=(1+abs(G))/(1-abs(G)) 

еременную KstU можно использовать для построения графика, вывода в виде таблицы или в 
файл. 
 
Примеч

, которые можно использовать в уравнениях, см. Руководство пользователя Microwave 
ffice 2007. 

ную нагрузку. 
 

ходные уравнения) в окне 
просмотра проекта. На 

на рис. 2.41. В 

Это озн ной S11 поставлен в соответствие модуль элемента S-матрицы 
S[1,1]. Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами 

3. 
введите S21, в области Meas. Type отметьте Port Parameters, в об-

 

Щёлкни ки в любом месте окна уравнений за пределами выраже-
ния для S21. 

4. 
нели инструментов. 

щего уравнения и щёлкните левой кнопкой мышки, 

 

 
П

ание. Более подробно о переменных и уравнениях, а так же о синтаксисе уравнений, об операто-
рах и функциях
O

 
В этом примере мы рассмотрим определение KstU и Ldb для схемы аттенюатора atr20 при работе 

на согласован

1. Дважды щёлкните левой 
кнопкой мышки по груп-
пе Output Equations (Вы-

рабочем поле откроется 
окно уравнений Output 
Equations. 

2. Выберите в меню 
Draw>Add Output Equa-
tion. Откроется диалого-
вое окно Measurements, 
показанное 
текстовом поле Variable 
name (Имя переменной) 
введите S11, в области 
Meas. Type отметьте Port 
Parameters, в области 
Measurement отметьте S, 
в поле Data Source Name 
введите atr20, щёлкая по 

кнопке справа от этого поля, введите 1 в оба поля To Port Index и From Port Index, 
щёлкая по кнопкам справа от этих полей, установите “галочку” в Mag в области Com-
plex Modifier, снимите “галочки” в Complex и DB, если они установлены, щёлкните 
OK. В окне уравнений появится поле ввода. Двигая мышку, установите это поле в верх-
ней части окна уравнений и щёлкните левой кнопкой мышки. Появится выражение 

S11=atr20:|S[1,1]| 

Рис. 2.41 

 

 
ачает, что перемен

выражения для S11. 
Снова выберите в меню Draw>Add Output Equation. В открывшемся окне в текстовом 
поле Variable name 
ласти Measurement отметьте S, в поле Data Source Name введите atr20, щёлкая по 
кнопке справа от этого поля, введите 2 в поле To Port Index и 1 в поле From Port Index, 
щёлкая по кнопкам справа от этих полей, установите “галочку” в Mag в области Com-
plex Modifier, снимите “галочки” в Complex и DB, если они установлены, щёлкните 
OK. В окне уравнений появится поле ввода. Двигая мышку, установите это поле ниже 
предыдущего уравнения и щёлкните левой кнопкой мышки. Появится выражение 

S21=atr20: |S[2,1]| 
 

те левой кнопкой мыш

Выберите в меню Draw>Add Equation или щёлкните левой кнопкой мышки по значку 
Equation на па

5. Переместите курсор в окно уравнений. В этом окне появится поле ввода. Установите 
его, двигая мышкой, ниже предыду
чтобы зафиксировать. 

6. Введите в поле вода уравнение: 



KstU=(1+S11)/(1-S11) 
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и щёлкн ки вне этого поля или нажмите клавишу Enter. 
7. Снова щёлкните левой кнопкой мышки по значку 

поле ниже предыдущих уравнений. 

 
       

 
и щёлкните левой кнопкой мышки вне этого поля или нажмите 

кла

 
 измеряемых величин и анализ. 

 панели инструмен-

Graph 

 

 
7. Щёлкните левой кнопкой мышки 

 
44. 

 

File>Save Project As (Файл>Сохранить проект как). Откроется диалого-

3. Наберите имя проекта Atr и нажмите Сохранить. 

ты установите GHz, для ёмкости (Capacitance) установите pF и поставьте фла-

 
ите левой кнопкой мыш

Equation на панели инструментов и поместите новое 

8. Введите в поле вода уравнение: 

                        Ldb=20*log10(1/S21) 

вишу Enter. 
 Рис. 2.42 

Окончательный вид окна уравнений показан на рис. 2.42. 

Создание графика, добавление
1. Щёлкните по значку New 

Graph на
тов. 

2. Введите имя графика, напри-
мер, Graph 2 в поле 

г иname (Имя раф ка), выберите 
Rectangular (Прямоугольный) 
в области Graph Type (Тип
графика) и нажмите OK. 

3. Щёлкните правой кнопкой 
мышки по подгруппе Graph 2 
в окне просмотра проекта и 
выберите Add Measurement. 

4. В открывшемся окне (рис. 
2.43) выберите Output Equa-
tions в области Meas. Type. В 
поле ввода Equation Name вы-
берите KstU, щёлкнув по 

Рис. 2.43 

кнопке справа. Отметьте пере-
ключатель Mag в области Com-
plex Modifier. Уберите “галочку” 
в DB, если она установлена. На-
жмите Apply. 

5. В поле ввода Equation Name вы-
берите Ldb и нажмите Apply. 

6. Нажмите OK. 

по значку Analyze на панели ин-
струментов. Результаты анализа 
отображаются на графике рис. 2.

 
Рис. 2.44

2.4. Моделирование микрополоскового 2-х диодного аттенюа-
ора т

 
Создание нового проекта. 

1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню 

вое окно Save As. 

 
Установка единиц измерения, используемых по умолчанию. 

Установите единицы измерения, которые будут использоваться по умолчанию, как описано в 
примере 2.1, но для часто
жок в поле Metric units. 



 35

. 

редоточе ped Element), щёлкнув по значку + 

осмотра элементов. В нижней 

е на модель конден отпуская кнопки мышки, перетащите её в окно 

 просмотра элементов. В нижней части 

кая кнопки мышки, перетащите её в окно 

а, пере-

стите порт справа от схемы и щёлкните левой кнопкой мышки, чтобы зафиксировать 

му конденсатор и резистор, и щёлкните левой кноп-

13.Аналогично подключите к схеме второй порт.  

Ре
P (конденсатор) в окне схемы. 

значения ёмкости (C), введите 0.025 pF и нажмите OK. Измене-

мышки по 

ите 0.6 Ohm и нажмите OK. 
на 

а рис. 2.45. 
 для диода 2А553В-3. 

 
Создание нюатора. 

н л  

уппы Microstrip  

роллинга, переместите её в окно схемы и за-

и щёлкните по элементу 

у Paste на панели инструментов, чтобы скопиро-

тите курсор  и подсоедините   узлу 

 значку Paste на панели 

Создание эквивалентной схемы диода. 
1. Щёлкните по значку New Schematic на панели инструментов
2. Наберите имя схемы Diode и нажмите OK. 
3. Нажмите панель Elements в нижней части левого окна. 
4. Разверните группу сос нных элементов (Lum

слева от этой группы. 
5. Щёлкните по подгруппе Конденсаторы (Capacitor) в окне пр

части окна появятся изображения доступных конденсаторов. 
6. Нажмит сатора CAP и, не 

схемы. 
7. Щёлкните по подгруппе Резисторы (Resistor) в окне

окна появятся изображения доступных резисторов. 
8. Нажмите на модель резистора RES и, не отпус

схемы, поместите резистор ниже конденсатора. 
9. Поместите курсор возле левой клеммы конденсатора так, чтобы курсор отображался в виде 

соленоида. Щёлкните левой кнопкой мышки, чтобы зафиксировать начало провод
тащите курсор к левой клемме резистора, и снова щёлкните левой кнопкой мышки. 

10. Аналогично соедините проводом правые клеммы конденсатора и резистора. Щёлкните ле-
вой кнопкой мышки по значку Port на панели инструментов. Переместите курсор в окно 
схемы, поместите порт слева от схемы и щёлкните левой кнопкой мышки, чтобы зафикси-
ровать его. 

11. Снова щёлкните левой кнопкой мышки по значку Port на панели инструментов. Перемести-
те курсор в окно схемы, два раза щёлкните правой кнопкой мышки, чтобы развернуть порт, 
поме
его. 

12. Поместите курсор возле первого порта PORT P=1 так, чтобы курсор отображался в виде 
соленоида. Щёлкните левой кнопкой мышки, чтобы зафиксировать начало провода, пере-
тащите курсор к проводу, соединяюще
кой мышки, чтобы зафиксировать его. 
 

 
дактирование параметров элементов в эквивалентной схеме диода. 

1. Дважды щёлкните левой кнопкой мышки по элементу CA
Откроется диалоговое окно Element Options (Опции элемента). 

2. В текстовое поле Value 
ние будет отражено на схеме. 

3. Дважды щёлкните левой кнопкой 
элементу RES (резистор) в окне схемы. Откроется диа-
логовое окно Element Options. 

4. В текстовое поле Value значения резистора (R), 
введ

Отредактированная эквивалентная схема диода показа
н

Примечание. Параметры взяты
 

 схемы атте
Рис. 2.45 

1. Щёлкните по значку New Schematic на па е и инструментов. 
2. Наберите имя схемы At и нажмите OK. 
3. В окне просмотра элементов щёлкните по значку + слева от гр
4. Щёлкните по подгруппе Lines в окне просмотра элементов. 
5. Найдите модель MLIN, пользуясь полосой ск

фиксируйте, щёлкнув левой кнопкой мышки. 
6. Щёлкните по группе Subcircuits (Подсхемы) в окне просмотра элементов. 
7. Переместите подсхему Diode в окно схемы и соедините её с правым узлом отрезка линии. 
8. Щёлкните по элементу MLIN, затем нажмите клавишу Shift 

SUBCKT (т.е. по подсхеме), чтобы выделить оба этих элемента. 
9. Щёлкните по значку Copy и затем по значк

вать и вставить оба выделенных элемента. 
10. Перемес  в окно схемы  скопированные элементы к правому

схемы. 
11. Щёлкните по элементу MLIN, затем щёлкните по значку Copy и по

инструментов, чтобы скопировать и вставить выделенный элемент. 



12. Переместите курсор в окно схемы и подсоедините скопированный элемент к правому узлу 
схемы. 

13. Щёлкните левой кнопкой мышки по значку Port на панели инструментов. Переместите кур-
сор в окно схемы, поместите порт на левый узел схемы и щёлкните левой кнопкой мышки, 
чтобы зафиксировать его. 

14. Снова щёлкните левой кнопкой мышки по значку Port на панели инструментов. Перемести-
те курсор в окно схемы, два раза щёлкните правой кнопкой мышки, чтобы развернуть порт, 
поместите порт на правый узел схемы и щёлкните левой кнопкой мышки, чтобы зафикси-
ровать его. 

15. Щёлкните по группе Substrates (Подложки) в окне просмотра элементов. 
16. Перетащите элемент MSUB в окно схемы, поместите его на свободном месте, например, 

ниже схемы. Полученная схема аттенюатора показана на рис. 2.46. 
 
Редактирование параметров элементов в схеме аттенюатора. 

1. Дважды щёлкните левой кнопкой мышки по первому элементу MLIN. В открывшемся окне 
введите W=0.46 mm (т.е. введите 0.46 в поле Value параметра W), L=3 и нажмите OK. 

2. Аналогично отредактируйте параметры всех элементов MLIN и подложки MSUB так, что-
бы значения их параметров соответствовали значениям, указанным на схеме рис. 2.46. 

Рис. 2.46 

Задание частот для моделирования. 
 

1. Щёлкните левой кнопкой мышки по панели Project в нижней части левого окна, чтобы от-
крыть окно просмотра проекта. 

2. Дважды щёлкните по группе Project Options (Опции проекта). Откроется диалоговое окно 
Project Options. 

3. На вкладке Frequencies (Частоты). Введите 8 в поле Start (Начальная частота), 12 в поле 
Stop (Конечная частота) и 0.5 поле Step (Шаг), отметьте Replace (Заменять), отметьте Lin-
ear (Линейная). Нажмите Apply (Применить). В области Current Range (Текущий диапа-
зон) отображается частотный диапазон и шаг по частоте. Нажмите OK. 

 
Создание выходных параметров и уравнений. 

1. Дважды щёлкните левой кнопкой мышки по группе Output Equations (Выходные урав-
нения) в окне просмотра проекта. На рабочем поле откроется окно уравнений Output Equa-
tions. 

2. Выберите в меню Draw>Add Output Equation. Откроется диалоговое окно Measure-
ments Equation, показанное на рис. 2.42. В текстовом поле Variable name (Имя переменной) 
введите S11, в списке Meas. Type отметьте Port Parameters, в списке Measurement отметьте 
S, в поле Data Source Name введите At, щёлкая по кнопке справа от этого поля, введите 1 в оба 
поля To Port Index и From Port Index, щёлкая по кнопкам справа от этих полей, отметьте Mag 
в области Complex Modifier, снимите “галочки” в Complex и dB, если они установлены, на-
жмите OK. В окне уравнений появится поле ввода. Двигая мышку, установите это поле в верх-
ней части окна уравнений и щёлкните левой кнопкой мышки. Появится выражение 

 
S11=At: |S[1,1]| 

 
Это означает, что переменной S11 поставлен в соответствие модуль элемента S-матрицы S[1,1]. 
Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для 
S11. 

3. Снова выберите в меню Draw>Add Output Equation. В открывшемся окне в текстовом 
поле Variable name введите S21, в списке Meas. Type отметьте Port Parameters, в списке 
Measurement  отметьте  S,  в поле  Data Source Name  введите  At, щёлкая по кнопке справа от 
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о поле ниже предыдущего уравнения и щёлкните левой кнопкой мышки. 
Появится выражение 

 
S21=At: |S[2,1]| 

 
ните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для 

 Equation или щёлкните левой кнопкой мышки по значку 

кой, ниже предыдущего уравнения и щёлкните левой кнопкой мышки, чтобы 

6. Введите в поле вода уравнение: 
 

Ldb=20*log10(1/S21) 

ите левой кнопкой мышки вне этого поля или нажмите клавишу 
Enter

ментов и поместите новое поле ниже пре-

8. Введите в поле вода уравнение: 

                                   KstU=(1+S11)/(1-S11) 
 

 щёлкните левой кнопкой мышки вне этого поля или нажмите клавишу Enter. 

Окончательный вид окна уравнений показан на рис. 2.47. 

мого ослабления и KstU, добавление измеряемых величин 
 выполнение анализа. 

афика Loss в поле Graph name (

Тип графика) и нажмите 

 и выберите Add 

она установлена. 

вы-
ажмите Apply. 

Analyze на панели инструментов. Результаты 
анализа отображаются на графике рис. 2. 48. 

мени этой схемы в окне просмотра проекта, чтобы сделать активным окно схемы 
диода. 

этого поля, введите 2 в поле To Port Index и 1 в поле From Port Index, щёлкая по кнопкам 
справа от этих полей, отметьте Mag в области Complex Modifier, снимите “галочки” в Com-
plex и dB, если они установлены, щёлкните OK. В окне уравнений появится поле ввода. Двигая 
мышку, установите эт

Щёлк
S21. 

4. Выберите в меню Draw>Add
Equation на панели инструментов. 

5. Переместите курсор в окно уравнений. В этом окне появится поле ввода. Установите 
его, двигая мыш
зафиксировать. 

 
и щёлкн

. 
7. Снова щёлкните левой кнопкой мышки по значку Equa-

tion на панели инстру
дыдущих уравнений. 

 Рис. 2.47 
  

и
 

 
Создание графика вноси
и
 

1. Щёлкните по значку New Graph на панели инструментов. 
Имя графика), выберите Rectangular (Пря-

моугольный) в области Graph 
Type (

2. Введите имя гр

OK. 
3. Щёлкните правой кнопкой мышки 

по подгруппе Loss в окне про-
смотра проекта
Measurement. 

4. Выберите Output Equations в 
списке Meas. Type. В окне списка 
Measurement отметьте Eqn. В 
поле ввода Equation Name выбе-
рите KstU, щёлкнув по кнопке 
справа от этого поля. Отметьте 
переключатель Mag в области 
Complex Modifier. Уберите га-
лочку в DB, если 
Нажмите Apply. 

5. В поле ввода Equation Name 
Рис. 2.48 

берите Ldb и н
6. Нажмите OK. 
7. Щёлкните левой кнопкой мышки по значку 

 
Настройка аттенюатора. 

1. Щёлкните левой кнопкой мышки по окну эквивалентной схемы диода или дважды щёлкни-
те по и



2. Щёлкните по значку Tune Tool  (Инструмент настройки) на панели инструментов. 
3. Поместите курсор на параметр R резистора. Курсор должен отображаться в виде белого пе-

рекрестия в чёрном кружке. 
4. Щёлкните левой кнопкой мышки, чтобы активизировать параметр R для настройки. Этот 

параметр будет отображаться синим цветом. 
5. Щёлкните по окну схемы аттенюатора, чтобы сделать его активным. 
6. Щёлкните по  значку Tune Tool на панели инструментов. 
7. Поместите курсор на параметр L (длина отрезка) среднего отрезка линии MLIN ID=TL2 и 

щёлкните левой кнопкой мышки. Выделенные для настройки параметры должны отобра-
жаться синим 
цветом. 
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8. Щёлкните левой 
кнопкой мышки 
по окну графика 
Loss, чтобы сде-
лать его актив-
ным. 

9. Щёлкните по 
значку Tune 

на панели 
инструментов. 

Откроется Vari-
able Tuner (Блок 
настройки пере-

менных), показанный на рис. 2.49. В полях ввода Max и Min введите допустимые пределы 
регулировки резистора и длины отрезка, как показано на рис. 2.49. 

Рис. 2.49 

10. Нажмите левой кнопкой мышки на бегунок настройки и, не отпуская кнопки, двигайте его 
вверх и вниз. Результаты настройки переменных наблюдайте на графике. Одновременно все 
изменения отображаются на обеих схемах. 

 
Примечание. Если при регулировке кривые на графике выходят за пределы графика, 

щёлкните левой кнопкой мышки по значку Analyze на панели инструментов, чтобы повторить 
анализ. 
 

Черчение элемента топологии. 
Чтобы получить топологию аттенюатора, необходимо элементу эквивалентной схемы диода 

присвоить элемент топологии, представляющий собой зазор для пайки диода. Такого топологического 
элемента в Microwave Office нет. Поэтому его необходимо начертить и присвоить элементу схемы 
SUBCKT. Microwave Office поддерживает формат черчения GDSII и DXF. Начерченные элементы топо-
логии хранятся соответственно в библиотеках ячеек (Cell Libraries) GDSII или DXF. Библиотеки GDSII 
сохраняются в файлах с расширением gds, а библиотеки DXF сохраняются в файлах с расширением dxf. 
Причём в библиотеке GDSII может храниться несколько разных ячеек, а в библиотеке DXF только одна. 
Чтобы создать (начертить) новую ячейку топологии, можно воспользоваться имеющейся библиотекой 

или создать новую. В Microwave Office имеется библиотека packages (пакет) в 
формате GDSII, которая находится по адресу 
AWR\AWR2007\Examples\Microwave Office\Getting Started\Layout\ packages.gds. 
Чтобы импортировать эту библиотеку в проект, сделайте следующее: 

1. Сделайте активным окно схемы и нажмите левой кнопкой мышки 
на панель Layout в нижней части левого окна, чтобы открыть окно 
менеджера топологии. 

2. Правой кнопкой мышки щёлкните по Cell Libraries (Библиотеки 
элементов) в менеджере топологии и выберите Import GDSII Li-
brary (Импортировать библиотеку GDSII) во всплывающем меню. 

3. В открывшемся окне найдите файл packages.gds по указанному 
выше адресу и дважды щёлкните по нему левой кнопкой мышки. 
Откроется окно Warning: Different Database Unit (Предупрежде-
ние: Различная база данных единиц измерения). В этом окне сооб-
щается, что эта библиотека использует базу данных единиц изме-
рения, отличную от текущего проекта. Нажмите OK. 

Импортированная библиотека будет отображена в окне менеджера то-
пологии как подгруппа в группе Cell Libraries, как показано на рис. 2.50. 

Рис. 2.50 

Теперь, чтобы создать новый элемент топологии, нужно щёлкнуть по имени импортированной 
библиотеки правой кнопкой мышки и выбрать New Layout Cell (Новая ячейка топологии). 



Если вместо импортирования библиотеки хотите создать свою, щёлкните 
правой кнопкой мышки по Cell Libraries и выберите New GDSII Library или New 
DXF Library. Откроется окно, в котором нужно ввести имя создаваемой библиотеки и 
нажать OK. Имя вновь создаваемой библиотеки появится в окне менеджера топологии 
(рис. 2.51). В нижней части окна менеджера топологии появится список слоёв, в 
которых можно чертить элемент топологии (рис. 2.52). 

Чтобы начертить элемент топологии: 
1. Щёлкните правой кнопкой мышки по подгруппе библиотеки ячеек 

(импортированной или вновь создаваемой) в группе Cell Libraries и 
выберите New Layout Cell (Новая ячейка топологии) во всплывающем 
меню. Откроется диалоговое окно Create New Layout Cell (Создание 
нового элемента топологии). 

Рис. 2.51 

2. Наберите D553 (диод 553) в поле Enter the name of the cell (Ввод имени 
элемента) и нажмите OK. На рабочем поле откроется окно для 
рисования. 

3. Щёлкните левой кнопкой мышки по квадрату 1_0->Copper (Медь) в 
нижней части окна менеджера, чтобы назначить медь для активного слоя, 
как показано на рис. 2.52 (не щёлкайте по лампочке, т.к. такой щелчок 
определяет слой для показа или скрытия). 

4. Щёлкните левой кнопкой мышки по окну рисования на рабочем поле, 
чтобы сделать его активным. 

Рис. 2.52 

5. По умолчанию размер сетки для черчения равен 0.1 мм. Щёлкните левой кнопкой 
мышки по кнопке справа от значка Grid Spacing (Интервал сетки) на панели 
инструментов и в выпавшем списке выберите множитель 0.1x (рис. 2.53), чтобы 
сделать размер сетки 0.01 мм. 

6. Щёлкните левой кнопкой мышки по значку View Area и в окне топологии 
выделите участок окна так, чтобы была видна сетка. Возможно это придётся 
сделать несколько раз. 

Рис. 2.53 
7. Щёлкните левой кнопкой мышки по значку Polygon  на панели инструментов. 

8. Переместите курсор в окно рисования и щёлкните левой кнопкой мышки, чтобы зафиксировать 
начало топологии. 

9. Переместите курсор вправо, пока будет отображено dx:0.16 и щёлкните левой кнопкой мышки. 
Переместите курсор вниз, пока будет отображено dy:-0.1 и щёлкните левой кнопкой мышки. 
Переместите курсор влево, пока будет отображено dx:-0,15 и щёлкните левой кнопкой мышки. 

Переместите курсор вниз, пока будет отображено dy:0.36 
и щёлкните левой кнопкой мышки. Переместите курсор 
влево, пока будет отображено dx:-0.01 и щёлкните два раза 
левой кнопкой мышки, чтобы завершить черчение. 

10. Щёлкните левой кнопкой мышки по значку Copy, и затем 
по значку Paste, чтобы скопировать и вставить элемент. 
Переместите курсор в окно топологии и два раза щёлкните 
правой кнопкой мышки, чтобы развернуть скопированный 
элемент. Поместите скопированный элемент напротив 1-го 
так, чтобы величина зазора была равна 0.4. Величину этого 
зазора можно измерить, щёлкнув левой кнопкой мышки по 

значку Measure  (Измерение величины) на панели 
инструментов. Полученный элемент топологии зазора 
показан на рис.2.54. Величину зазора можно также 

измерить, щёлкнув мышкой по значку Ruler  на панели инструментов. В этом случае 
линейка будет отображаться на топологии, как показано на рис. 2.54. Однако в этом случае 
предварительно нужно выбрать в меню Options>Layout Options и на вкладке Ruler 
открывшегося окна в поле Ruler spacing ввести расстояния меду делениями линейки 0.1 mm. 
Чтобы удалить линейку из топологии, нужно щёлкнуть по ней левой кнопкой мышки, чтобы 
выделить линейку, и затем нажать клавишу Delete. 

Рис. 2.54 

 
Добавление портов к начерченному элементу. 

К начерченному элементу топологии необходимо добавить входной и выходной порты. Чтобы 
сделать это: 

1. Выберите в меню Draw>Cell Port (Чертить>Порт элемента) или щёлкните мышкой по  

значку Cell Port  на панели инструментов. 
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2. Переместите курсор в окно черчения. Нажав и удерживая клавишу Ctrl, поместите кур-
сор на нижний левый угол  левого проводника так, чтобы небольшой квадратик появился на 

этом углу.  
3. Не отпуская клавишу Ctrl, нажмите левую 

кнопку мышки и, не отпуская её, двигайте курсор 
к верхнему левому углу проводника, пока другой 
квадрат появится на этом углу. Отпустите кнопку 
мышки и клавишу Ctrl. 

4. Повторите шаги с 1-го по 3-ий, чтобы по-
местить порт на противоположной стороне рисун-
ка, но начните с верхнего правого угла и двигайте 
курсор к правому нижнему углу. 

5. Закройте окно черчения. Будет выведен за-
прос, хотите ли вы сохранить нарисованный эле-
мент. Нажмите Yes, чтобы сохранить. Полученная 
топология показана на рис. 2.55. Рис. 2.55 

 
Примечание. Созданная библиотека по умолчанию не сохраняется, она действует только в том 
проекте, в котором создана. Но при желании библиотеку с созданным элементом топологии 
можно сохранить, чтобы его использовать в других проектах. Для этого щёлкните правой кноп-
кой мышки по имени библиотеки в левом окне просмотра топологии и выберите Export Cell Li-
brary (Экспортировать библиотеку элементов). Аналогично можно сохранить не всю библиоте-
ку, а только созданный элемент топологии. 

 
Редактирование схемы и назначение элемента топологии D553 элементам схемы 
SUBCKT (т.е. диодам). 

Чтобы отредактировать схему и ввести элемент топологии D553: 
1. Щёлкните левой кнопкой мышки по окну схемы аттенюатора, чтобы сделать его активным. 

2. Дважды щёлкните левой кноп-
кой мышки по первому элемен-
ту схемы SUBCKT в окне схе-
мы. Откроется окно Element 
Options (Опции элемента). 

3. Нажмите на панель Layout в 
верхней части этого окна (рис. 
2.56). 

4. В поле ввода Library Name 
введите имя вашей библиотеки, 
щёлкнув по кнопке в правом 
конце этого поля. Выберите 
имя созданного элемента топо-
логии D553 в правой области 
окна и нажмите OK (рис. 2.56). 

5. Аналогично назначьте элемент 
топологии второму элементу 
схемы SUBCKT. Рис. 2.56 

Создание топологии схемы и экспортирование топологии. 
1. Выберите в меню View>New Layout View (Показать>Показать новую топологию) или 

щёлкните левой кнопкой мышки по 
значку New Schematic Layout View 

 на панели инструментов. Тополо-
гия схемы будет отображена на рабо-
чем поле, но расположение элементов 
топологии может быть беспорядочным 
(рис. 2.57). Правильное соединение 
элементов топологии на этом отобра-
жении указывается красными линиями. 

2. Чтобы упорядочить полученную то-
пологию, выделите всю топологию. 
Для этого поместите курсор мышки ле-
вее и выше топологии, нажмите левую 
кнопку мышки и переместите курсор 
правее и ниже топологии так, чтобы вся 

топология попала  в  образовавшийся  прямоугольник.  Или выберите в меню  Edit>Select  
Рис. 2.57
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All (Редактировать>Выделить всё). Затем выберите в меню Edit>Snap Together 

(Редактировать>Привязать вместе) или щёлкните по значку Snap Together  на панели 
инструментов. Полученная топология показана на рис. 2.58. 

2. Выберите в меню Options>Layout Options. На вкладке Export/LPF открывшегося окна 
отметьте Union layout shapes (Объединить формы топологии) и нажмите OK. 

Рис. 2.58

3. Сделайте активным окно топологии схемы и выберите в меню Layout>Export. 
Выберите тип файла DXF(DXF Flat, *.dxf) и нажмите Сохранить. В AutoCAD 
сохранённая топология будет иметь вид, показанный на рис. 2.59. 

 41

Рис. 2.60 

Здесь создана и экспортирована топология только проводников аттенюатора. При 
необходимости вы можете создать топологию всей платы. 

Рис. 2.59 

1. В поле ввода на панели инструментов Grid Spacing (Интервал сетки) введите 
множитель 0.1х, чтобы сделать интервал сетки 0.01 мм (рис. 2.60). 

2. Щёлкните левой кнопкой мышки по значку Measure (Измерение), установите 
курсор на левый верхний угол первого проводника топологии, нажмите левую 
кнопку мышки и, не отпуская кнопки, переместите курсор на верхний правый угол 

последнего проводника топологии. Измеренная длина 
топологии получилась 9.46 мм. Исходя из полученной длины 
топологии, выберем размер платы 10х4 мм. Рис. 2.61 
3. По умолчанию топология схемы создаётся так, что 

координаты её левого нижнего угла равны (0,0). Это 
можно проверить, установив курсор на левый нижний 
угол платы. В нижней части окна проекта отображаются 
координаты этого угла (рис. 2.61). Исходя из этого, 
можно определить требуемые координаты платы так, 
т о

Рис. 2.62 
ч обы топол гия располагалась по центру платы. 

4. Щёлкните по значку Rectangle на панели управления, 
поместите курсор в окно топологии и нажмите клавишу 
Tab. В открывшемся окне Enter Coordinates (Ввод 
координат) введите -0.2 в поле x и -1.77 в поле y (рис. 

2.62). Нажмите OK и затем клавишу 
Tab. Во вновь открывшемся окне 
введите 10 в поле dx и 4 в поле dy 
(рис.2.63). Нажмите OK. На поле 
схемы появится прямоугольник 

ый ет 

Рис. 2.63 

платы, котор  буд выделен (рис. 
2.64). 

5. Щёлкните по выделенному 
прямоугольнику правой кнопкой 
мышки и выберите Shape 
Properties. В открывшемся окне 

свойств в поле Draw Layers введите Board 
(Плата), щёлкнув мышкой по кнопке в 
р

Рис. 2.64 

п авом конце этого поля (рис. 2.65.) 
Нажмите OK. 

6. На созданной плате вы можете теперь 
создать дополнительные топологические 
объекты, не связанные с электрической 
схемой, например реперные знаки и 
надписи. Щёлкните левой кнопкой мышки 
по значку Polygon на панели 
инструментов, поместите курсор на левый 
верхний угол платы и щёлкните левой 
кнопкой мышки. Затем перемещайте 
курсор, щёлкая мышкой после каждого 
перемещения:  на 0.5 вправо,  на  0.2  вниз, Рис. 2.65 



на 0.3 влево, на 0.3 вниз, на 0.2 влево и здесь дважды щёлкните левой кнопкой мышки, чтобы 
замкнуть многоугольник. Щёлкните по многоугольнику правой кнопкой (многоугольник должен 
быть выделен) и выберите Shape properties. В открывшемся окне свойств в поле Draw Layers 
введите Copper (Медь), щёлкнув мышкой по кнопке в правом конце этого поля. Нажмите OK. 

Щёлкните по значку Copy на панели 
инструментов. Щёлкая по значку Paste на 
панели инструментов и правой кнопкой 
мышки, чтобы развернуть скопированный 
многоугольник, установите реперные знаки 
на остальные углы платы. 
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7. Выберите в меню Options>Layout 
Options. В открывшемся окне 
опций топологии на вкладке Layout 
Font отметьте Draw as polygons 
(Чертить как полигоны) и выберите 
имя и высоту шрифта, например, 
как показано на рис. 2.66. Нажмите 
OK. 

8. Выберите в меню Draw>Text. 
Поместите курсор на плату и 
щёлкните левой кнопкой мышки. В 

образовавшемся поле ввода наберите Аттенюатор и щёлкните мышкой вне этого поля. 
Установив курсор на надпись и нажав левую кнопку мышки, можно переместить надпись в любое 
свободное место на плате. Отредактированная плата показана на рис. 2.67. Заметим, что по 
умолчанию топологические элементы чертятся на слое Error. Поскольку в DXF файл не 
записывается никаких свойств слоя, кроме его координат, то этот слой можно и оставить. Этот же 
слой можно оставить и для реперных знаков и других вспомогательных элементов топологии при 
условии, что они малы и расположены достаточно далеко от проводников, чтобы не влиять на 
характеристики. 

Рис. 2.66 

9. Щёлкните по значку New Schematic 3D View на панели инструментов, чтобы просмотреть 3-х 
мерное изображение платы (рис. 2.68). 

10. Сделайте активным окно топологии схемы и выберите в меню Layout>Export. Выберите тип 
файла DXF(DXF Flat, *.dxf) и нажмите Сохранить. Топология в AutoCAD будет выглядеть, как 
показано на рис. 2.69. 

В сохранённом dxf файле 
записались только элементы топологии, 
размещённые на плате. Это объясняется 
тем, что в таблице соответствия слоёв 
черчения и слоёв, записываемых в DXF 
файл, слой топологии Board по 
умолчанию не установлен для записи в 
файл. Если вы хотите записать в файл и 
контур платы, сделайте следующее: 

Рис. 2.68 Рис. 2.67 

1. Выберите в меню 
Options>Drawing Layers. 
В левой части 

открывшегося окна (рис. 2.70) щёлкните мышкой по File Export Mappings и затем по 
DXF(DXF). В правой части окна отметьте столбец Write Layer (Записать слой) для слоя 
Board. Нажмите OK. 

Рис. 2.69 
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2. Выберите в меню Lay-
out>Export. В открыв-
шемся окне выберите тип 
файла DXF(DXF Flat, 
*.dxf) и нажмите Сохра-
нить. В AutoCAD тополо-
гия будет выглядеть, как 
показано на рис. 2.71. 

 
 

 
 
 

 
 

Рис. 2.70 

Рис. 2.71 
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3. Нелинейное моделирование 
В нелинейном моделировании используется гармонический баланс или ряды Вольтера, как 

источник для возбуждения электрической схемы. Анализ с использованием гармонического баланса и 
рядов Вольтера – не взаимозаменяемые решения нелинейного устройства. Гармонический баланс лучше 
использовать для нелинейных устройств типа усилителей мощности, смесителей и умножителей. Анализ 
с помощью рядов Вольтера, который является линейным возмущающим методом, лучше использовать 
для устройств со слабо выраженной нелинейностью, подобных усилителям, на 1 дБ ниже точки компрес-
сии. 

В Microwave Office моделирование с помощью гармонического баланса проводится просто. Ввод 
схемы, измеряемые величины и анализ выполняются аналогично линейному моделированию. Основное 
отличие в возбуждении портов. Здесь требуется добавлять порты, для которых необходимо определять 
мощность и частоту, а также опцию для изменения любого одного из этих параметров или обоих вместе. 
Имитатор гармонического баланса позволяет определять одночастотное и многочастотное возбуждение 
портов, чтобы выполнить одно- и многосигнальный анализ. Всякий раз, когда источник гармонического 
баланса определён в схеме, имитатор гармонического баланса вызывается автоматически при модели-
ровании. 

Одночастотный анализ с использованием гармонического баланса включает в себя моделирова-
ние на одной основной частоте из множества частот и с постоянной составляющей тока. Этот анализ 
требует, чтобы вы определили основную частоту и общее количество гармоник. 

Двух- и трёхчастотный анализ с помощью гармонического баланса используется, чтобы опреде-
лить реакцию на выходе схемы при возбуждении её портов разными частотами. Двухчастотный анализ 
используется для схем типа смесителей, на которые подаётся частота гетеродина и частота радиосигнала. 
Трёхчастотный анализ используется, чтобы определить искажения взаимной модуляции в смесителе при 
подаче сигнала гетеродина и двух частот радиосигналов. 

Microwave Office позволяет создавать нелинейные измеряемые величины и во временной облас-
ти, и по частоте. Здесь предлагается полная система нелинейных измеряемых величин, которая включает 
в себя S-параметры при большом сигнале, мощность, напряжение и ток. Поскольку анализ с помощью 
гармонического баланса даёт решение для мощности и частоты в каждой гармонике, используются ин-
дексы, чтобы отличать различные параметры. 

Следующие примеры иллюстрируют некоторые из основных особенностей нелинейного моде-
лирования в Microwave Office. 

3.1. Моделирование усилителя мощности. 
Этот пример показывает, как использовать Microwave Office, чтобы моделировать схему усили-

теля мощности, используя нелинейный гармонический баланс. Для этого необходимы следующие шаги: 
 

o Использование нелинейных моделей из библиотеки элементов; 
o Создание измеряемых величин вольтамперной характеристики; 
o Создание цепи смещения транзистора и измеряемых величин напряжения и тока; 
o Добавление к схеме портов гармонического баланса; 
o Создание схемы с иерархической структурой, содержащей подсхемы; 
o Создание измеряемых величин выходной мощности; 
o Создание измеряемых величин характеристики динамической нагрузки; 
o Добавление двухчастотного порта гармонического баланса. 

 
Создание нового проекта. 

Чтобы создать новый проект: 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта (например, Amplifier) и нажмите Сохранить. 

 
Установка единиц измерения, используемых по умолчанию. 

Чтобы установить единицы измерения, которые будут использоваться в проекте по умолчанию: 
1. Выберите Options>Project Options (Опции>Опции проекта) в выпадающем меню. Откро-

ется диалоговое окно Project Options (рис. 3.1). 
2. Нажмите панель Global Options (Глобальные опции) в верхней части диалогового окна. 



3. Установите нужные единицы из-
мерения, щёлкая по стрелкам, 
справа от поля ввода соответст-
вующей единицы так, чтобы они 
соответствовали показанным на 
рис. 3.1, снимите флажок в поле 
Metric units (Метрические едини-
цы), установите mil в поле Length 
type и нажмите OK. 
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Создание схемы. 

Чтобы создать схему: 
1. Выберите в меню Project>Add 

Schematic>New Schematic (Про-
ект>Добавить схему>Новая схе-
ма) или щёлкните мышкой по 

значку New Schematic  на па-
нели инструментов. Откроется 

диалоговое окно Create New Schematic (Создать новую схему). 

Рис. 3.1 

2. Наберите имя схемы IV Curve (Вольтамперная характеристика) и нажмите OK. Откроется 
окно схемы на рабочем поле и имя схемы появится, как подгруппа в группе Circuit Sche-
matics (Схемы цепи) в окне просмотра проекта. 

 
Размещение нелинейной модели из библиотеки. 

Чтобы поместить нелинейную модель: 
1. Нажмите панель Elements (Элементы) в нижней части левого окна, чтобы открыть окно 

просмотра элементов. 
2. В окне просмотра элементов найдите группу Nonlinear (Нелинейные) и дважды щёлкните 

по ней левой кнопкой мышки, чтобы развернуть эту группу. 
3. Щёлкните левой кнопкой мышки по подгруппе BJT (Биполярный плоскостной транзистор). 
4. Здесь можно выбрать модель GBJT и перетащить её в окно схемы (рис. 3.2). Дважды щёлк-

нув левой кнопкой по модели GBJT можно редактировать её параметры в открывшемся ок-
не Element Options, щёлкнув левой кнопкой мышки по 
кнопке Show Secondary. 

5. В этом примере мы будем использовать модель из примера 
Microwave Office, в которой параметры уже отредактирова-
ны. 

6. Сохраните проект, щёлкнув по значку Save Project на пане-
ли инструментов. Затем выберите в меню File>Open Exam-
ple. Загрузите файл Microwave Of-
fice\Getting_Started\Nonlinear\nonlinear_example.emp. 

7. В открывшемся проекте сделайте активным окно схемы IV 
Curve. Щёлкните левой кнопкой по элементу GBJT и затем 
щёлкните левой кнопкой мышки по значку Copy на панели 
инструментов. Рис. 3.2 

8. Выберите в меню File и загрузите свой сохранённый проект Amplifier, выбрав его имя в 
списке загружаемых проектов в нижней части открывшегося окна подменю. 

9. Сделайте активным окно созданной схемы IV Curve, если оно не активно. Щёлкните по 
значку Paste на панели инструментов и поместите скопированную модель транзистора в 
окно схемы, как показано на рис. 3.2. 

 
Размещение измерителя вольтамперной характеристики в нелинейном элементе. 

Чтобы поместить измеритель вольтамперной характеристики в 
нелинейном элементе: 

1. Найдите в окне просмотра элементов группу Meas De-
vices (Средства измерения) и дважды щёлкните по ней ле-
вой кнопкой мышки, чтобы развернуть группу. Щёлкните 
левой кнопкой мышки по подгруппе IV. Модели измери-
телей отображаются в нижней части левого окна. 

2. Нажмите левой кнопкой мышки на модель IVCURVEI и, 
не отпуская кнопки мышки, перетащите её в окно схемы, 
отпустите кнопку мышки, позиционируйте элемент как 
показано на рис. 3.3 и щёлкните левой кнопкой мышки, 
чтобы зафиксировать его. Рис. 3.3 



3. Поместите курсор возле узла Step (Шаг) элемента IVCURVEI так, чтобы курсор отобра-
жался в виде соленоида. Щёлкните левой кнопкой мышки, чтобы зафиксировать начало 
провода, затем перетащите курсор к узлу 1 транзистора GBJT и щёлкните левой кнопкой 
мышки, чтобы зафиксировать провод. 

4. Повторите шаг 3, чтобы подключить узел Sweep (Смещение) элемента IVCURVEI к узлу 2 
транзистора GBJT. 

5. Щёлкните левой кнопкой мышки по значку Ground на панели инструментов и подключите 
землю к узлу 3 транзистора GBJT и щёлкните левой кнопкой мышки, чтобы её зафиксиро-
вать. 

 
Редактирование параметров измерителя вольтамперной характеристики. 

Чтобы определить параметры 
IV CURVEI: 

1. Дважды щёлкните левой 
кнопкой мышки по эле-
менту IVCURVEI в окне 
схемы. Откроется диало-
говое окно Свойства: 
Element Options (Опции 
элемента). 

2. Измените значения полей 
Value (Значение), как по-
казано на рис. 3.4 и на-
жмите OK. 

 
 
 
 
 Рис. 3.4 
 

Добавление измеряемых величин к измерителю вольтамперной характеристики. 
Чтобы создать график и добавить измеряемые величины к измерителю вольтамперной характе-

ристики: 
1. Щёлкните левой кнопкой мышки по панели Project в нижней части левого окна, чтобы от-

крыть окно просмотра проекта. 
2. Правой кнопкой мышки щёлкните по группе Graphs (Графики) и выберите Add Graph 

(Добавить график). Или щёлкните левой кнопкой мышки по значку New Graph  на па-
нели инструментов. Откроется окно Create Graph (Создать график). 

3. Наберите IV BJT в поле Graph Name (Имя графика), выберите Rectangular (Прямоуголь-
ный) и нажмите OK. График отобразится на рабочем поле. 

4. Щёлкните правой кнопкой мышки по подгруппе IV BJT в группе Graphs в окне просмотра 
проекта и выберите Add Measurement (Добавить измеряемую величину) во всплывающем 
меню. Откроется диалоговое окно Add Measurement. 

5. Выберите Nonlin-
ear>Current (Не-
линейный>ток) в 
окне списка Meas 
Type (Тип изме-
ряемой величины), 
выберите IV 
Curve в окне спи-
ска Measurement, 
выберите IVCurve 
в поле Data Source 
Name (Имя источ-
ника данных) и 
нажмите OK. 

6. Выберите в меню 
Simulate>Analyze 

(Моделирова-
ние>Анализ) или 

щёлкните по значку Analyze на панели инструментов . Результат моделирования отобра-
жается на графике рис. 3.5. 

Рис. 3.5 
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Замечание. На правой стороне графика отображаются маркеры. Вы можете изменить их вид 
отображения или совсем убрать. Для этого щёлкните правой кнопкой по графику и выберите Properties 
(Свойства). В открывшемся окне на вкладке Markers снимите “галочку” в Param markers in legend, 
чтобы изменить вид маркеров, или снимите “галочку” в Param markers enabled, чтобы убрать маркеры, 
нажмите Apply и OK. 

 
Создание электрической цепи смещения. 

Чтобы создать цепь смещения: 
1. В окне схемы IV Curve щёлкните левой кнопкой мышки по элементу транзистора GBJT и 

затем щёлкните по значку Copy на панели инсьрументов. 
2. Выберите Project>Add Schematic>New Schematic в выпадающем меню. Откроется диало-

говое окно New Schematic. Наберите DC Bias (Постоянный ток смещения) и нажмите OK. 
Окно схемы откроется на рабочем поле. 

3. Щёлкните по значку Paste на панели инструментов и поместите скопированный элемент в 
окно схемы. 

4. Дважды щёлкните левой кнопкой мышки по группе Lumped Element (Сосредоточенные 
элементы), чтобы развернуть её. Щёлкните левой кнопкой мышки по подгруппе Inductor 
(Индуктивности) в группе Lumped Element. Доступные модели катушек индуктивности 

будут отображены в нижней части левого окна. Нажмите левой 
кнопкой мышки на модель IND и, не отпуская кнопки мышки, 
перетащите её в окно схемы, отпустите кнопку мышки, пози-
ционируйте элемент выше и левее транзистора GBJT, как по-
казано на рис. 3.6, и щёлкните левой кнопкой мышки, чтобы 
зафиксировать элемент. 
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5. Поместите курсор на узле 1 транзистора GBJT так, чтобы кур-
сор отображался в виде соленоида. Щёлкните левой кнопкой 
мышки, чтобы зафиксировать начало провода, перетащите кур-
сор к правому узлу элемента IND, щёлкните левой кнопкой 
мышки, чтобы зафиксировать конец провода. 

6. Дважды щёлкните левой кнопкой мышки по элементу IND в 
окне схемы. Откроется диалоговое окно Element Options. Вве-
дите 1 в поле Value для индуктивности (L) и нажмите OK. 

7. Щёлкните левой кнопкой мышки по подгруппе Resistor в 
группе Lumped Element. Доступные модели резисторов будут 

отображены в нижней части левого окна. Нажмите левой кнопкой мышки на модель RES и, 
не отпуская кнопки мышки, перетащите её в окно схемы, отпустите кнопку мышки, щёлк-
ните правой кнопкой мышки, чтобы повернуть элемент, позиционируйте его на узле 3 тран-
зистора GBJT, как показано на рис. 3.6, и щёлкните левой кнопкой мышки, чтобы зафикси-
ровать элемент. 

Рис. 3.6 

8. Дважды щёлкните левой кнопкой мышки по элементу RES в окне схемы. Откроется диало-
говое окно Element Options. Введите 0.5 в поле Value для резистора (R) и нажмите OK. 

9. Щёлкните левой кнопкой мышки по значку Ground  на панели инструментов, двигайте 
курсор в окно схемы, позиционируйте землю к нижнему узлу резистора RES, как показано 
на рис. 3.6, и щёлкните левой кнопкой мышки, чтобы зафиксировать землю. 

10. Повторите п.9 и подключите землю к узлу 4 транзистора GBJT, как показано на рис. 3.6. 
11. Найдите в окне просмотра элементов группу Sources (Источники) и дважды щёлкните по 

ней, чтобы развернуть. Щёлкните левой кнопкой мышки по подгруппе DC (Постоянный 
ток). Модели доступных источников ото-
бражаются в нижней части окна. Нажми-
те левой кнопкой мышки на модель 
DCVS и, не отпуская кнопки мышки, пе-
ретащите её в окно схемы, отпустите 
кнопку мышки, позиционируйте элемент 
на левом узле индуктивности IND ID=L1, 
как показано на рис. 3.7, и щёлкните ле-
вой кнопкой мышки, чтобы зафиксиро-
вать элемент. 

12. Щёлкните левой кнопкой мышки по 
значку Ground на панели инструментов, 
двигайте курсор в окно схемы, позицио-
нируйте землю на нижнем узле элемента 
DCVS, как показано на рис. 3.7, и щёлк-
ните левой кнопкой мышки, чтобы за-
фиксировать. Рис. 3.7 



13. Дважды щёлкните левой кнопкой мышки по элементу DCVC в окне схемы. Откроется диа-
логовое окно Element Options. Введите 1 в поле Value для и нажмите OK. 

14. Щёлкните левой кнопкой мышки по элементу Ind, чтобы выделить его. Щёлкните левой 

кнопкой по значку Copy  и затем по значку Paste  на панели инструментов, чтобы 
скопировать его. Поместите скопированный элемент правее и выше элемента CBJT и со-
едините с узлом 2 элемента CBJT, как показано на рис. 3.7. 

15. Нажмите клавишу Shift, щёлкните левой кнопкой мышки по элементу DCVS и подключён-
ной к нему земле. Скопируйте эти элементы и подключите их к последнему элементу Ind, 
как показано на рис. 3.7. 

16. Дважды щёлкните левой кнопкой мышки по второму элементу DCVS в окне схемы. Откро-
ется диалоговое окно Element Options. Введите 6 в поле Value и нажмите OK. 

 
Примечание. Возле каждого элемента располагается поле с его параметрами. Чтобы перемес-

тить параметры элемента в другое место, если это необходимо, нажмите на поле параметров левой кноп-
кой мышки и, не отпуская кнопки мышки, перетащите параметры в другое место. 
 
Добавление в схему отображения рассчитанных напряжений и токов. 

В схему можно добавить отображение рассчитанных при анализе напряжений и токов, которые 
будут показаны в каждой точке разветвления (Back Annotation – Обратное аннотирование). Чтобы сде-
лать это: 

1. Щёлкните левой кнопкой мышки по панели Project в нижней части левого окна, чтобы от-
крыть окно просмотра проекта. 

2. Щёлкните правой кнопкой мышки по имени схемы DC Bias в левом окне просмотра проек-
та и выберите Add Annotation. Откроется окно рис. 3.8. В области Measurement этого окна 
отметьте напряжение постоянного тока DCVA_N и нажмите Apply. 

3. Затем отметьте в этой же области постоянный ток DCIA и нажмите Apply. 
4. Нажмите OK. 
5. Выберите в меню Simulate>Analyze или щёлкните по значку Analyze на панели инструмен-

тов. 
После выполнения анализа схема будет выглядеть, как показано на рис. 3.9. Если поместить кур-

сор на отображаемые напряжение или ток и нажать левую кнопку мышки, то эти отображения можно 
переместить в другое место схемы. 
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Рис. 3.9 Рис. 3.8 

Добавление блокировочных конденсаторов. 
Добавьте в схему конденсаторы на входе и выходе транзистора, а также параллельно резистору. 

Для этого: 
1. Щёлкните левой кнопкой мышки по панели Elements в нижней части левого окна, чтобы 

открыть окно просмотра элементов. 
2. Дважды щёлкните левой кнопкой мышки по группе Lumped Element (Сосредоточенные 

элементы), чтобы развернуть её. Щёлкните левой кнопкой мышки по подгруппе Capacitor 
(Конденсаторы) в группе Lumped Element. Доступные модели конденсаторов отображают-
ся в нижней части левого окна. Нажмите левой кнопкой мышки на модель CAP и, не отпус-
кая кнопки мышки, перетащите её в окно схемы.  Отпустите кнопку мышки, позиционируй- 

 



те элемент на клемме 1 транзистора GBJT, как показано на рис. 3.10, и щёлкните левой 
кнопкой мышки, чтобы зафиксировать элемент. 

3. Дважды щёлкните левой кнопкой мышки по элементу CAP в окне схемы. Откроется диало-
говое окно Element Options. Введите 100 в поле Value для ёмкости (C) и нажмите OK. 

4. Щёлкните левой кнопкой мышки по элементу CAP в окне схемы. Нажмите клавиши Ctrl+C 
и затем Ctrl+V, чтобы скопировать и вставить элемент. Подключите скопированный эле-

мент к узлу 2 транзистора 
GBJT, как показано на рис. 
3.10, и щёлкните левой кнопкой 
мышки, чтобы зафиксировать 
элемент. 

5. Снова нажмите клавиши 
Ctrl+V, щёлкните правой кноп-
кой мышки, чтобы развернуть 
скопированный элемент и уста-
новите его слева от резистора 
Res, как показано на рис. 3.10. 

6. Поместите курсор на верхней 
клемме элемента CAP ID=C3. 
Курсор должен отображаться в 
виде соленоида. Щёлкните ле-
вой кнопкой мышки и затем пе-
ретащите курсор к клемме 3 
транзистора GBJT и щёлкните 
левой кнопкой мышки, чтобы 
зафиксировать провод. Анало-
гично соедините проводом 
нижнюю клемму элемента CAP 
ID=C3 с землёй. 

7. Щёлкните левой кнопкой мыш-
ки по значку Analyze, чтобы 
отобразить значения токов и на-
пряжений в новых узлах. 

Рис. 3.10 

Добавление порта гармонического баланса. 
Чтобы добавить порт гармоническо-

го баланса: 
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1. Дважды щёлкните левой кноп-
кой мышки по группе Ports в 
окне просмотра элементов, что-
бы развернуть её. Щёлкните ле-
вой кнопкой мышки по под-
группе Harmonic Balance в 
группе Ports. Доступные моде-
ли портов отображаются в ниж-
ней части левого окна. Нажмите 
левой кнопкой мышки на мо-
дель PORT1 и, не отпуская 
кнопки мышки, перетащите её в 
окно схемы. Отпустите кнопку 
мышки, подключите элемент к 
левой клемме элемента CAP 
ID=C1, как показано на рис. 
3.11, и щёлкните левой кнопкой 
мышки, чтобы зафиксировать 
порт. 

2. Дважды щёлкните левой кноп-
кой мышки по порту PORT1 в 
окне схемы. Откроется диалого-
вое окно Element Options. Вве-

дите 23 в строку Pwr в поле Value и нажмите OK. 

Рис. 3.11 

3. Щёлкните левой кнопкой мышки по значку PORT на панели инструментов. Двигайте кур-
сор в окно схемы, щёлкните правой кнопкой мышки два раза, чтобы повернуть порт, под-
ключите его к правой клемме выходного конденсатора CAP ID=C2, как показано на рис. 
3.11, и щёлкните левой кнопкой мышки, чтобы зафиксировать порт. 

 



Определение частот нелинейного моделирования. 
Определить частоты для анализа можно несколькими способами: 

• Как глобальные частоты проекта, выбрав в меню Options>Project Options и в от-
крывшемся окне опций проекта ввести нужные частоты на вкладке Frequencies. 

• Как локальные частоты, определённые только для данной схемы, щёлкнув правой 
мышкой по имени схемы в левом окне просмотра документа и выбрав Options. 

• Из левого окна просмотра элементов поместить в схему элемент SWPFRQ, который 
находится в группе Simulation Control. 

Мы воспользуемся вторым способом. 
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1. В окне просмотра проекта 
щёлкните левой кнопкой мыш-
ки по значку + слева от группы 
Circuit Schematics, чтобы раз-
вернуть её. 

2. Щёлкните правой кнопкой 
мышки по подгруппе DC BIAS 
и выберите Options. Откроется 
диалоговое окно Options (рис. 
3.12). 

3. На вкладке Frequencies сними-
те галочку в переключателе Use 
Project Frequencies (Использо-
вать частоты проекта). 

4. Установите GHz в поле Data 
Entry Unit, щёлкая левой кноп-
кой мышки по стрелке справа 
от этого поля, введите 1.5 в по-
ле Start, введите 2.5 в поле 
Stop, введите 0.2 в поле Step, 
выберите Replace (Заменить) и 

нажмите Apply (Применить). Диапазон частот отображается в окне списка Current 
Range (см. рис. 3.12). Нажмите OK. 

Рис. 3.12 

 
Создание диаграммы Смита и добавление измеряемой величины коэффициента 
отражения большого сигнала. 

Microwave Office позволяет вычислить коэффициент отражения большого сигнала и отобразить 
его га диаграмме Смита. 

Чтобы создать диаграмму Смита: 
1. Щёлкните правой кнопкой мышки по группе Graphs (Графики) и выберите Add Graph 

(Добавить график). Откроется диалоговое окно Create Graph (Создать график). 
2. Введите Input reflection (Коэффициент отражения по входу) в поле Graph Name (Имя гра-

фика), выберите Smith 
Chart (Диаграмма Смита) 
в области Graph Type 
(Тип графика) и нажмите 
OK. Диаграмма будет 
отображена на рабочем 
поле. 

Чтобы добавить измеряемую 
величину коэффициента отражения 
большого сигнала: 

1. Щёлкните правой кноп-
кой мышки по подгруппе 
Input reflection в группе 
Graphs в окне просмотра 
проекта и выберите Add 
measurement (Добавить 
измеряемую величину) во 
всплывающем меню. От-
кроется диалоговое окно 
Add measurement (Рис. 
3.13). 

Рис. 3.13  



2. Раскройте группу Nonlinear (Нелинейные) в окне 
списка Meas Type (Тип измеряемых величин) и 
отметьте Parameter. Выберите Gcomp (Компо-
нент отражённого сигнала) в окне списка Meas-
urement (Измеряемая величина). Выберите DC 
Bias в поле Data Source Name (Имя источника 
данных), выберите PORT_1 в поле Measurement 
Component (Компонент измеряемой величины), 
выберите 1 в поле Harmonic Index (Индекс гармо-
ники) щёлкая по стрелке справа от этого поля. От-
метьте Complex и нажмите Apply и OK. 
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3. Выберите в меню Simulate>Analyze или щёлкните 
по значку Analyze на панели инструментов. Ре-
зультаты анализа отображаются на диаграмме 
Смита рис. 3.14. 

 
 

Рис. 3.14 

Импортирование согласующих входной и выходной схем. 
Входную и выходную согласующие схемы импортируем из схемы, созданной ранее. Чтобы им-

портировать входную согласующую схе-
му: 

1. Щёлкните правой кноп-
кой мышки по группе Circuit 
Schematics в окне просмотра 
проекта и выберите Import 
Schematic (Импорт схем) во 
всплывающем меню. Откроет-
ся диалоговое окно Browse 
For File (Рис. 3.15). 

2. Щёлкните левой кноп-
кой мышки по кнопке справа 
от поля Папка и установите в 
этом поле папку C:\Program 
Files\AWR\MWO2007\Exampl
es\Microwave Office\Getting 
Started\Nonlintar. 

3. Щёлкните левой кноп-
кой мышки по файлу input 
math и нажмите кнопку От-
крыть. На рабочем поле будет 

отображена схема, показанная на рис. 3.16. 

Рис. 3.15 

4. Чтобы импортировать выходную согласующую схему, повторите пункты с 1-го по 3-ий, 
но выберите файл output math. На рабочем поле будет отображена схема, показанная на рис. 
3.17. 

Рис. 3.16 Рис. 3.17 



Добавление подсхем к схеме. 
Всякий раз, когда к n – ному порту схемы подключается другая созданная или импортированная 

схема, то подключённая схема автоматически становится n – подсхемой. Такие подсхемы могут подклю-
чаться к другим подсхемам, создавая, таким образом, иерархическую структуру электрической цепи. 
Чтобы добавить согласующие схемы на входе и выходе усилителя: 

 
1. В левом окне просмотра проекта в 

группе Circuit Schematics дважды 
щёлкните левой кнопкой мышки по 
подгруппе DC Bias, чтобы отобра-
зить эту схему. 

2. Щёлкните левой кнопкой мышки по 
элементу PORT1 в окне схемы. На-
жмите клавишу Shift и, удерживая 
её, щёлкните левой кнопкой мышки 
по элементу CAP ID=C1. При этом 
и PORT1 и CAP ID=C1 будут вы-
делены. 

3. Нажмите и удерживайте клавишу 
Ctrl. Нажмите левой кнопкой мыш-
ки на выбранные элементы и, не от-
пуская кнопки мышки, перетащите 
их влево от электрической цепи, 
чтобы разорвать связь между CAP 
ID=C1 и транзистором, как показа-
но на рис. 3.18. 

Рис. 3.18 

4. Нажмите на панель Elements в 
нижней части левого окна, чтобы 
открыть окно просмотра элементов. 

5. Щёлкните левой кнопкой мышки по 
группе Subcircuit (Подсхемы) в ок-
не просмотра элементов. Доступные 
подсхемы будут отображены в ниж-
ней части левого окна. 

6. Нажмите левой кнопкой мышки 
подсхему input match и, не отпус-
кая кнопки, перетащите её в окно 
схемы, отпустите кнопку мышки и 
подключите к узлу 1 транзистора, 
щёлкните левой кнопкой мышки, 
чтобы зафиксировать её.  

7. Нажмите клавишу Shift и, удержи-
вая её, щёлкните левой кнопкой 
мышки по элементам PORT1 и 
CAP ID=C1, чтобы выделить их. 
Установите курсор на один из вы-
деленных элементов, нажмите ле-
вую кнопку мышки и подключите 
эти элементы к узлу 1 подсхемы 
input match, как показано на рис. 
3.19. 

Рис. 3.19 
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8. Щёлкните левой кнопкой мышки 
по элементу PORT2. Нажмите и, 
удерживая клавишу Shift, щёлкни-
те левой кнопкой мышки по эле-
менту CAP ID=C2. При этом 
PORT2 и CAP ID=C2 будут выде-
лены. 

9. Нажмите клавишу Ctrl. Нажмите 
выделенные элементы левой кноп-
кой мышки и, не отпуская кнопки 
мышки, перетащите их вправо от 
схемы, чтобы разорвать связь меж-

ду CAP ID=C2 и проводом, как показано на рис. 3.20. 

Рис. 3.20 



10. Нажмите левой кнопкой мышки на подсхему output match и, не отпуская кнопки, перета-
щите её в окно 
схемы, отпус-
тите кнопку 
мышки, щёлк-
ните два раза 
правой кноп-
кой мышки, 
чтобы развер-
нуть подсхему 
на 180 граду-
сов, подклю-
чите подсхему 
узлом 2 к узлу 
2 транзистора 
GBJT и щёлк-
ните левой 
кнопкой мыш-
ки, чтобы за-
фиксировать. 

11. Нажмите кла-
вишу Shift и, 
удерживая её, 
щёлкните ле-

вой кнопкой мышки по элементам PORT2 и 
CAP ID=C1, чтобы выделить их. Установи-
те курсор на один из выделенных элемен-
тов, нажмите левую кнопку мышки и под-
ключите эти элементы к узлу 1 подсхемы 
output match, как показано на рис. 3.21. 

Рис. 3.21 

12. Дважды щёлкните левой кнопкой мышки по 
значению параметра Pwr=23 dBm элемента 
PORT1. Откроется окно редактирования 
значения. Наберите 18, чтобы изменить зна-
чение 23 на 18 dBm. Полученная схема по-
казана на рис. 3.21. 

13. В левом окне просмотра проекта дважды 
щёлкните по имени графика диаграммы 
Смита, чтобы сделать это окно активным. 

14. Щёлкните левой кнопкой мышки по значку 
Analyze на панели инструментов. Получен-
ный график показан на рис. 3.22. Рис. 3.22 

 
Создание графика и добавление измеряемой величины выходной мощности. 
 

Чтобы создать график зависимости выходной мощности (в дБ/Мвт) в зависимости от частоты и 
добавить измеряемую величину выходной мощности: 
 

1. В левом окне просмотра проекта щёлкните правой кнопкой мышки по группе Graphs и 
выберите Add Graph. Откроется диалоговое окно Create Graph. 

2. Наберите Pout (Выходная мощность) в поле Graph Name, выберите Rectangular в об-
ласти Graph Type и нажмите OK. График будет отображён на рабочем поле. 

3. Правой кнопкой мышки щёлкните по подгруппе Pout в группе Graphs в окне просмотра 
проекта и выберите Add Measurement во всплывающем меню. Откроется диалоговое окно 
Add Measurement (рис. 3.23). 

4. В области Meas Type раскройте группу Nonlinear и отметьте Power. Выберите Pcomp в 
области Measurement. Введите DC Bias в поле Data Source Name, введите PORT_2 в поле 
Measurement Component, введите 1 в поле Harmonic Index, в поле Sweep Freq(FDOC) введи-
те Use for x-axis, отметьте dBm в области Complex Modifier и нажмите Apply и OK (Рис3.23). 

5. Выберите в меню Simulate>Analyze, или щёлкните по значку Analyze на панели инст-
рументов. Результаты анализа отображаются на графике рис 3.24. 
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Рис. 3.24 Рис. 3.23 
 
Создание графика и измеряемых величин динамической нагрузки. 

График динамической нагрузки наносится на график вольтамперной характеристики устройства. 
Чтобы создать измеряемые величины динамической нагрузки: 

1. В левом окне просмотра 
проекта дважды щёлкните левой 
кнопкой мышки по имени графи-
ка IV BJT в группе Graph, чтобы 
открыть график вольтамперной 
характеристики на рабочем поле. 

2. Щёлкните правой кнопкой 
мышки по графику и выберите 
Properties. В открывшемся окне 
на вкладке Markers снимите “га-
лочку” в Param markers enabled, 
чтобы убрать маркеры, нажмите 
Apply и OK. 
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3. Щёлкните правой кнопкой 
мышки по имени графика IV BJT 
в группе Graphs и выберите Add 
Measurement. Откроется диало-
говое окно Add Measurement 
(рис. 3.25). 

4. Выберите Nonlin-
ear>Current в области Meas 
Type. В области Measurement 

отметьте IVDLL. Щёлкните 
мышкой по кнопке “…” 
справа от поля Voltage 
Measure Component (на рис. 
3.25 показана стрелкой). От-
кроется окно со схемой DC 
Bias (рис. 3.26). В списке в 
левом нижнем углу этого 
окна отметьте GBJT.GP1@2 
и нажмите OK в левом верх-
нем углу окна. 

Рис. 3.25 

5. Аналогично введите 
GBJT.GP1@2 в поле Cur-
rent Measure Component. 

6. В поле Sweep Freq 
(FDOC) введите Freq=1.5 
GHz (рис. 3.25). 

7. Нажмите Apply и OK. 
Рис. 3.26 
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Выберите в меню 

опирование схемы в окне про-

нить двухчастотный 
анализ, 

 

е курсор на имя 

8. 
Simulate>Analyze или щёлкните 
по значку Analyze на панели ин-
струментов. Результаты анализа 
отображаются на графике рис 
3.27. 

 
К
смотра проекта. 

Чтобы выпол
требуется та же самая схема, но с 

двухчастотным портом гармонического 
баланса. Мы не будем изменять порт в 
имеющейся схеме, а создадим новую, ис-
пользуя возможность в Microwave Office 
создавать копии схем. 

1. Установит
Рис. 3.27 

схемы DC Bias в группе Circuit Schematics в левом окне проекта, нажмите левую кнопку 
мышки и, не отпуская кнопки, переместите курсор на имя группы Circuit Schematics. Будет 
создана копия схемы с именем Copy of DC Bias. 

2. Щёлкните правой кнопкой мышки по имени скопированной схемы Copy of DC Bias в левом 
окне проекта и выберите Rename Schematic (Переименовать схему). 

3. В открывшемся окне введите новое имя для скопированной схемы Two Tone Amp и на-
жмите OK. 

 
4. Добавление двухчастотного порта гармонического баланса. 

Обычно измеряемые величины, 
используемые для характеристики усили-
теля мощности, являются тремя последо-
вательностями составляющих интермоду-
ляции относительно передаваемой мощно-
сти. Чтобы создать эти измеряемые вели-
чины, на вход необходимо подать две, 
близко расположенные частоты. Для до-
бавления двухчастотного порта гармони-
ческого баланса: 

1. В активном окне схемы  
Two Tone Amp дважды щёлкни-
те левой кнопкой мышки по 
элементу PORT1. Откроется 
диалоговое окно Element Op-
tions (Рис. 3.28). 

2. Откройте вкладку Port 
диалогового окна, щёлкнув 
мышкой по закладке Port в 
верхней части этого окна. 

Рис. 3.28 

3. В области Port Type от-
метьте Source (Источник) и 
Swept Power (Вариация часто-
ты), в поле Simulator type (Ре-
шающее устройство) введите 
Harmonic Balance. В поле  Tone 
Type введите Tone 1&2. В об-
ласти Source excitation  (Источ-
ник возбуждения) выберите Ex-
cite fundamental frequency 
(Возбуждение фундаментальной 
частоты). 

4. Откройте вкладку Pa-
rameters. В поле Fdelt введите 
0.2, в поле Pstart введите -10, в 
поле Pstop введите 25, в поле 
Pstep введите 5, как показано на 
рис. 3.29. Затем нажмите OK. Рис. 3.29 



Добавление измеряемой величины третьей составляющей интермодуляции. 
Чтобы добавить измеряемую величину третьей составляющей интермодуляции: 

1. Сначала создайте 
график. Для этого в левом 
окне просмотра проекта 
щёлкните правой кнопкой 
мышки по группе Graphs и 
выберите Add Graph, или 
щёлкните левой кнопкой 
мышки по значку New 
Graph на панели инстру-
ментов. Откроется диало-
говое окно Create Graph. 

 56

Правой кнопкой 

r>Power в 

но в поля 

меню Simu-

2. Наберите IM3 (Ин-
термодуляция 3) в поле 
ввода Graph Name, от-
метьте Rectangular в об-
ласти Graph Type и на-
жмите OK. На рабочем по-
ле будет отображён график. 

3. 
мышки щёлкните по под-
группе IM3 в группе 
Graphs в окне просмотра 
проекта и выберите Add 

Measurement во всплывающем ме-
ню. Откроется диалоговое окно Add 
Measurement (Рис 3.30). 

4. Выберите Nonlinea

Рис. 3.30 

области Meas Type, выберите 
Pcomp в области Measurement, 
введите Two Tone Amp в поле Data 
Source Name, введите PORT_2 в 
поле Measurement Component, 
введите 2 и -1 в поля Harmonic In-
dex, введите Freq=1.5 GHz в поле 
Sweep Freq (FDOC), введите Use 
for x-axis в поле PORT_1, отметьте 
dBm, нажмите Apply. 

5. Повторите п.4, 
Harmonic Index введите 0 и 1. На-
жмите Apply и OK. 

6. Выберите в 
late>Analyze или щёлкните по 
значку Analyze на панели инстру-

ментов. Результаты отображаются на графике рис. 3.31. 

Рис. 3.31 

 

3.2. Моделирование балансного смесителя на диодах. 
Выполнить моделирование балансного смесителя с частотой сигнала 4.25 ГГц, частотой гетеро-

дина 3.75 ГГц, промежуточная частота 0.5 ГГц. 
 

Создание нового проекта. 
Чтобы создать новый проект: 

1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта BDMixer и нажмите Сохранить. 

 
Определение единиц измерения и частот проекта. 

1. Выберите в меню Options>Project Options (Опции>Опции проекта) или дважды щёлкните 
мышкой по Project Options в левом окне проекта. Откроется диалоговое окно Project Op-
tions. 



2. В открывшемся окне опций проекта откройте вкладку Global Options и определите гло-
бальные единицы измерения, как показано на рис. 3.32. 

3. Откройте вкладку Frequencies. Введите 2 в поле Start, 5 в поле Stop, 0.03 в поле Step. От-
метьте Replace и нажмите Apply. Диапазон частот отображается в окне списка Current 
Range, как показано на рис.3.33. 

4. Нажмите OK. 

Рис. 3.33 Рис. 3.32 
 
Создание схемы и анализ ответвителя Ланге. 

В проекте будут несколько схем, использующие одну и ту же подложку. Поэтому поместим эле-
мент подложки в глобальные определения, откуда он будет доступен для всех схем. 

1. В окне просмотра проекта дважды щёлкните по Global Definitions, откроется окно глобаль-
ных определений. 

2. В левом оке откройте окно просмотра элементов, щёлкнув мышкой по кнопке Elements в 
нижней части левого окна. 

3. Щёлкните мышкой по группе Substrates, чтобы отобразить элементы подложек. 
4. Перетащите элемент MSUB в окно глобальных определений и щёлкните левой кнопкой 

мышки, чтобы закрепить его. 
5. Дважды щёлкните мышкой по элементу MSUB и 

в открывшемся окне свойств элемента введите: 
Er=6, H=1.25 mm, T=0.025 mm, Tand=0.001 и 
ErNom=6. Нажмите OK. 
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Теперь создадим схему ответвителя Ланге. Эта схема 
будет состоять только из одного элемента, и её будем исполь-
зовать, чтобы правильно подобрать значения параметров этого 
элемента. 

1. Щёлкните мышкой по значку New Schematic на 
панели инструментов и создайте схему с име-
нем Lange Coupler. 

2. В окне просмотра элементов раскройте группу 
Microstrip и щёлкните мышкой по подгруппе PwrDivider. 

Рис. 3.34 

3. Перетащите в окно схемы элемент MLANGE в окно схемы и щёлкните левой кнопкой 
мышки, чтобы закрепить его. 

4. Щёлкните мышкой по значку Port на панели инструментов и подключите порт к плечу 1 
элемента MLANGE. Аналогично подключите порт к плечу 2. Затем подключите порты к 
плечам 3 и 4, два раза щёлкая мышкой, чтобы развернуть эти порты на 180 градусов. По-
лученная схема показана на рис. 3.34. 

5. Щёлкните мышкой по значку Tune Tool на панели инструментов и, щёлкая мышкой, на-
значьте параметры W, S и L элемента MLANGE для настройки. 

6. Щёлкните мышкой по значку New Graph на панели инструментов и создайте график с 
именем Lange Coupler S Parameters. 

7. Откройте окно просмотра проекта, щёлкнув мышкой по панели Project в левой нижней 
части окна. 

8. Щёлкните правой кнопкой мышки по имени созданного графика в окне просмотра проек-
та и выберите Add Measurement. 

9. В открывшемся окне в области Meas type отметьте Linear>Port Parameters, в области 
Measurement отметьте S, в поле Data Source Name введите Lange Coupler, в поля To 



Port Index и From Port Index введите 1, отметьте dB и нажмите Apply. Затем в поле To 
Port Index поочерёдно введите 2, 3 и 4, нажимая после каждого ввода Apply. 

10. Нажмите OK. 
11. Щёлкните по значку Analyze на панели инструментов. 
12. Чтобы прямоугольник с обозначениями измеряемых величин на графике не затемнял ха-

рактеристики, установите курсор на этот прямоугольник, нажмите левую кнопку мышки 
и переместите этот прямоугольник выше схемы. Затем установите курсор на ромбик по-
середине левой стороны прямоугольника и сдвиньте эту сторону до левого края графика. 
Аналогично сдвиньте правую сторону прямоугольника до правого края графика. Помес-
тите полученный новый прямоугольник над графиком и щёлкните по значку View All на 
панели инструментов. 

13. Щёлкните по значку Tune на панели инструментов и, двигая движки переменных на бло-
ке настройки, добейтесь нужной характеристики (рис. 3.35). Закройте блок настройки и, 
щёлкнув мышкой по значку Tune Tool на панели инструментов, отмените настройку для 
переменных W, S и L элемента MLANGE. 

Создание эквивалентной схемы диода. 
Рис. 3.35

Создадим эквивалентную схему диода, учитывающую “паразитные” параметры корпуса диода в 
дополнение к SPICE модели диода. 

1. Щёлкните по значку New Schematic на панели инструментов и создайте схему с именем 
Diode. 

2. Откройте окно просмотра элементов, раскройте группу Lumped Element и щёлкните мыш-
кой по подгруппе Inductor. 

3. Перетащите элемент IND в окно схемы и щёлкните левой кнопкой мышки, чтобы закрепить 
его. 

4. Два раза повторите п. 3, подключая элементы последовательно. 
5. Раскройте группу Nonlinear и щёлкните мышкой по подгруппе Diode. 
6. Перетащите элемент SDIODE в окно схемы, щёлкните правой кнопкой мышки, чтобы раз-

вернуть его, и подключите диод к точке между второй и третьей индуктивностями. Если 
дважды щёлкнуть мышкой по элементу SDIODE и затем в открывшемся окне щёлкнуть по 
кнопке Show Secondary, можно отредактировать параметры диода. Мы будем использовать 
параметры по умолчанию. 

7. Щёлкните мышкой по любому элементу IND, чтобы выделить его. Щёлкните по значку 
Copy и затем по значку Paste на панели инструментов, переместите курсор в окно схемы, 
щёлкните правой кнопкой мышки, чтобы развернуть скопированный элемент, и подключи-
те его к нижнему выводу диода. 

8. Раскройте группу Lumped Element и щёлкните мышкой по подгруппе Capacitor. 
9. Перетащите элемент Cap в окно схемы и поместите его над второй и третьей индуктивно-

стями. 
10. Снова перетащите элемент Cap в окно схемы, щёлкните правой кнопкой мышки, и подклю-

чите элемент к точке между первой и второй индуктивностями. 
11. Повторите п. 10 и подключите элемент Cap к свободному выводу последней индуктивно-

сти. 
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12. Установите курсор на левый вывод первого элемента Cap так, чтобы курсор отображался в 
виде соленоида, щёлкните левой кнопкой мышки и соедините этот вывод конденсатора с 
точкой между первой и второй индуктивностями. Аналогично соедините второй вывод это-

го конденсатора с правым выводом послед-
ней индуктивности. 

 59

13. Таким же образом соедините проводом ниж-
ние выводы двух параллельных конденсато-
ров и диода. 

14. Щёлкните мышкой по значку Port на панели 
инструментов и подключите вход к левому 
выводу первой индуктивности. Затем под-
ключите порт к свободному нижнему выво-
ду последней индуктивности, предваритель-
но развернув его на 90 градусов. Должна по-
лучиться схема, показанная на рис. 3.36. 

15. Дважды щёлкая по элементам индуктивно-
стей и емкостей, отредактируйте их пара-
метры, как показано на рис. 3.36. 

 
Рис. 3.36 

Создание схемы фильтра нижних частот. 
1. Щёлкните по значку New Schematic на панели инструментов и создайте схему с именем 

LPF. 
2. Откройте окно просмотра элементов, раскройте группу Microstrip и щёлкните мышкой по 

подгруппе Lines. 
3. Перетащите элемент MLIN в окно схемы и щёлкните левой кнопкой мышки, чтобы закре-

пит его. 
4. Раскройте группу Lumped Element и щёлкните мышкой по подгруппе Inductor. 
5. Перетащите элемент IND в окно схемы и подключите его к правому выводу элемента 

MLIN. 
6. Повторите п. 5 и подключите второй элемент IND к правому выводу первого элемента. 
7. Щёлкните мышкой по подгруппе Capacitor, перетащите элемент CAP в окно схемы и под-

ключите этот элемент к правому выводу второго элемента IND. 
8. Перетащите второй элемент CAP в окно схемы, разверните его на 90 градусов, щёлкнув 

правой кнопкой мышки, и подключите к точке между элементами MLIN и IND. 
9. Щёлкните мышкой по значку Copy и затем по значку Paste на панели инструментов (по-

следний вставленный элемент CAP должен быть выделен). Подключите скопированный 
элемент к точке соединения между двумя элементами IND. 

10. Поместите курсор на нижний узел ёмкости C2 так, чтобы он отображался в виде соленоида, 
и щёлкните левой кнопкой мышки, чтобы зафиксировать начало провода. Переместите кур-
сор к нижнему узлу ёмкости C3 и щёлкните левой кнопкой мышки, чтобы зафиксировать 
провод. 

11. Щёлкните по значку Ground на панели инструментов, переместите курсор в окно схемы и 
подключите к проводу, соединяющему ёмкости C2 и C3. 

12. Щёлкните по значку Port на панели инструментов, переместите курсор в окно схемы, под-
ключите порт ко входу схемы и щёлкните левой кнопкой мышки, чтобы зафиксировать. 

13. Снова щёлкните по значку Port на панели инструментов, переместите курсор в окно схемы, 
щёлкните два раза правой кнопкой мышки, чтобы повернуть порт и подключите его к вы-
ходу схемы. 

14. Дважды щёлкая по элементам схемы, отредактируйте их параметры, как показано на рис. 
3.37. 

Рис. 3.37 



Создание графика и анализ фильтра нижних частот. 
 

1. Откройте окно просмотра проекта, щёлкнув мышкой по кнопке Project в левой нижней час-
ти окна. 

2. Щёлкните левой кнопкой мышки по значку New Graphs на панели инструментов и в от-
крывшемся окне введите имя графика LPF S Parameters. Нажмите OK.  

3. Щёлкните левой кнопкой мышки по значку Add Measurement на панели инструментов. 
Откроется диалоговое окно Add Measurement. 

4. В окне списка Meas. Type отметьте Linear>Port Parameters, в окне списка Measurement 
отметьте S. в поле ввода Data Source Name введите LPF, в поле ввода To Port Index введи-
те 2, в поле ввода From Port Index введите 1, щёлкните левой кнопкой мышки по переклю-

чателям dB и Mag, нажмите Ap-
ply. 

5. Введите 1 в поля ввода To Port 
Index и From Port Index, нажми-
те Apply. 

6. Нажмите OK. 
7. Щёлкните правой кнопкой мыш-

ки по имени схемы LPF в группе 
Circuit Schematics в левом окне 
просмотра проекта и выберите 
Options. 

8. В открывшемся окне опций на 
вкладке Frequencies снимите 
“галочку” в Use project defaults, 
в поле Start (GHz) введите 0.5, в 
поле Stop (GHz) введите 5, в по-
ле Step (GHz) введите 0.05, от-
метьте Replace, нажмите Apply и 
OK. 

Рис. 3.38 

9. Щёлкните левой кнопкой мышки по значку Analyze на панели инструментов. Полученный 
график показан на рис. 3. 38. 

 
Создание схемы смесителя. 

При создании схемы 
смесителя, созданные ранее 
схемы будем использовать в 
качестве подсхем. 
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1. Щёлкните по 
значку New 
Schematic на 
панели инстру-
ментов и соз-
дайте схему с 
именем Diode 
Mixer. 

2. Откройте окно 
просмотра эле-
ментов и щёлк-
ните мышкой 
по Subcircuits 
(Подсхемы). 

3. Перетащите в 
окно схемы 
элемент Lange 
Coupler. По 
умолчанию все 
подсхемы ото-
бражаются в 
виде прямо-

угольника. 
Можно изменить вид подсхемы, чтобы он был более наглядным. Для этого дважды щёлк-
ните по элементу Lange Coupler в окне схемы и в открывшемся окне свойств элемента от-
кройте вкладку Symbol. В правой верхней строке ввода отметьте all или system.syf. В пра-
вом окне списка символов отметьте MLANG@system.syf (рис. 3.39) и нажмите OK. 

Рис. 3.39 



4. Щёлкните по элементу ответвителя Ланге правой кнопкой мышки, выберите Rotate и по-
верните элемент на 90 градусов против часовой стрелке. 

5. Снова щёлкните по элементу ответвителя Ланге правой кнопкой 
мышки, выберите Flip и, вращая мышкой против часовой стрелки, 
создайте зеркальное отображение элемента. Элемент должен выгля-
деть, как показано на рис. 3.40. 

6. Раскройте группу Lumped Element и отметьте Capacitor. Перетащите 
элемент CAP в окно схемы и подключите его к плечу 3 ответвителя 
Ланге. 

7. Дважды щёлкните мышкой по элементу CAP и введите C=1.85 pF. 
Нажмите OK. 

Рис. 3.40 

8. Щёлкните по значку Copy и затем по значку Paste на панели инструментов (элемент CAP 
должен быть выделен). Подключите скопированный элемент к плечу 2 ответвителя Ланге.  

9. Перетащите в окно схемы элемент Diode из группы Subcircuits в окне просмотра элементов 
и поместите его на свободном месте. 

10. Дважды щёлкните по элементу Diode и в открывшемся окне свойств элементов откройте 
вкладку Symbol. В правой верхней строке ввода отметьте all или system.syf. В правом окне 
списка символов отметьте Diode@system.syf и нажмите OK. Подключите диод к свободно-
му правому выводу верхнего конденсатора CAP. 

11. Щёлкните по значку Copy и затем по значку Paste на панели инструментов (элемент диода 
должен быть выделен). Два раза щёлкните правой кнопкой мышки, чтобы развернуть ско-
пированный элемент на 180 градусов, и подключите его к свободному правому выводу ниж-
него конденсатора CAP. 

12. В окне просмотра элементов раскройте группу Lumped Element и отметьте Inductor. Пере-
тащите элемент Ind в окно схемы и, щёлкнув правой кнопкой мышки, чтобы развернуть 
элемент, подключите его к точке между конденсатором и диодом в нижней цепи смесителя. 

13. Дважды щёлкните мышкой по элементу Ind и в окне свойств элемента введите 1.66 nH. 
14. Скопируйте элемент Ind и подключите его к точке между конденсатором и диодом в верх-

ней цепи смесителя, предварительно развернув на 180 градусов. 
15. Щёлкните по значку Ground на панели инструментов и подключите землю к свободному 

нижнему выводу нижней индуктивности. Аналогично подключите землю к свободному 
верхнему выводу верхней индуктивности, предварительно два раза щёлкнув правой кноп-
кой мышки. 

16. Установите курсор на свободный правый вывод диода так, чтобы курсор отображался в ви-
де соленоида, щёлкните левой кнопкой мышки, переместите курсор к правому выводу ниж-
него диода и снова щёлкните мышкой. 

17. Щёлкните мышкой по группе Subcircuits в окне просмотра элементов. Перетащите элемент 
LPF в окно схемы и подключите его к середине провода, соединяющего диоды. 

18. В окне просмотра элементов раскройте группу Ports и отметьте Harmonic Balance. Пере-
тащите порт PORTF в окно схемы и подключите его к плечу 1 ответвителя Ланге. 

19. Перетащите порт PORT_PS1 в окно схемы и подключите его к плечу 4 ответвителя Ланге. 
20. Щёлкните по значку PORT на панели инструментов, разверните его на 180 градусов и под-

ключите его к выходу схемы. 
21. При желании вы можете дополнить схему поясняющим текстом. Выберите в меню 

Draw>Text, переместите курсор в окно схемы, где вы собираетесь поместить текст, и щёлк-
ните мышкой. В образовавшемся поле ввода введите нужный текст и затем щёлкните мыш-

кой вне поля ввода. Щёлкнув пра-
вой копкой по введённому тексту 
и выбрав Prjperties, вы можете 
изменить тип шрифта и его высо-
ту. Обратите внимание, здесь 
можно использовать русские бук-
вы. 
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22. Дважды щёлкните по порту 
PORTF и в открывшемся окне 
свойств введите Freq=4.25 GHz 
(частота сигнала), Pwr=-10 dBm. 
Нажмите OK. 

23. Дважды щёлкните по порту 
PORT_PS1 и в открывшемся окне 
свойств введите PStart=6 dBm, 
PStop=18 dBm, PStep=3 dB (мощ-
ность гетеродина). Нажмите OK. 

Должна получиться схема, показанная 
на рис. 3.41. 

Рис. 3.41 



Откройте окно просмотра проекта, щёлкните правой кнопкой мышки по имени созданной схемы 
Diode Mixer и выберите Options. В открывшемся окне опций схемы на вкладке Frequencies снимите 
“галочку” в Use project defaults, отметьте Replace (Заменить) и Single point (Одна точка). В поле Point 
(GHz) введите 3.75 (частота гетеродина), нажмите Apply и OK. 

 
Создание графика потерь преобразования. 

1. Откройте окно просмотра 
проекта, щёлкнув мышкой по 
кнопке Project в нижнем углу 
левого окна. 
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ите левой кнопкой мышки 

, в 

alyze на панели 

 
 

оздание графика изменения выходного напряжения промежуточной частоты во 

график с именем Mixer IF Output Voltage. 

те Vtime, в поле ввода 

оказан на рис. 3.44. 

2. Щёлкните левой кнопкой мышки 
по значку New Graph на панели 
инструментов и создайте график 
с именем Conversion Loss. 

3. Щёлкн
по значку Add Measurement на 
панели инструментов. Откроется 
диалоговое окно Add 
Measurement (Рис.3.42). 

4. В окне списка Meas. Type 
отметьте Nonlinear>Power
окне списка Measurement 
отметьте LSSnm, в поле ввода 
Data Source Name введите Diode 
Mixer, в поле ввода Port (To) 
введите PORT_3, в поле ввода 
Port (From) введите PORT_1, в 
верхних полях Harmonic Index 
введите –1 и 1, в нижних полях 

Harmonic Index введите 0 и 1, щёлкая 
по стрелкам справа от этих полей, в 
поле ввода Sweep Freq (FDOC) 
введите Freq=3.75 GHz, в поле 
PORT_2 введите Use for x-axis, 
щёлкните левой кнопкой мышки по 
переключателям dB и Mag, нажмите 
Apply и OK. 

5. Щёлкните левой кнопкой мышки по 
значку An

Рис. 3.42 

инструментов. Рассчитанный график 
показан на рис. 3.43. 

 
С

Рис. 3.43 

времени. 
1. Щёлкните левой кнопкой мышки по значку New Graph на панели инструментов и создайте 

2. Щёлкните левой кнопкой мышки по значку Add Measurement на панели инструментов. 
Откроется диалоговое окно Add 
Measurement. 

3. В окне списка Meas. Type отметьте 
Nonlinear>Voltage, в окне списка 
Measurement отметь
Data Source Name введите Diode Mixer, в 
поле ввода Measurement Component 
введите PORT_3, в поле ввода Offset 
введите None, в поле ввода Sweep Freq 
(FDOC) введите Freq=3.75 GHz, в поле 
PORT_2 введите Select with tuner, 
нажмите Apply и OK. 

4. Щёлкните левой кнопкой мышки по значку 
Analyze на панели инструментов. 
Рассчитанный график пРис. 3.44 
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блюдать изменение выходного напряжения в зависимости от 

 
Сп

кноп-
начку 

nlin-

5. Щёлкнув по значку Tune на панели инструментов и двигая движок переменной Pwr на бло-
ке настройки, вы можете на
мощности входного сигнала Pwr. 

ектральный анализ. 
1. Щёлкните левой 

кой мышки по з
New Graph на панели 
инструментов и соз-
дайте прямоугольный 
график с именем 
Mixer IF Output 
Power Spectrum. 

2. В окне списка Meas. 
Type отметьте No
ear>Power, в окне 
списка Measurement 
отметьте Pharm, в по-
ле ввода Data Source 
Name введите Diode 
Mixer, в поле ввода 
Measurement Compo-
nent введите PORT_3, 
в поле ввода Sweep 
Freq (FDOC) введите 

Freq=3.75 GHz, в поле PORT_2 введите Select with tuner, отметьте Mag и dBm, нажмите 
Apply и OK. 

Рис. 3.45 

3. Щёлкните левой кнопкой мышки по значку Analyze на панели инструментов. Рассчитанный 
график показан на рис. 3.45. 

4. Щёлкнув по значку Tune на панели инструментов и двигая движок переменной Pwr на бло-
ке настройки, вы можете наблюдать изменение спектра в зависимости от мощности входно-
го сигнала Pwr. 

 
 



4. Создание топологии схемы 
 

В Microwave Office для создания топологии схемы используется эффективный объектно-
ориентированный метод программирования. При этом топология тесно связана со схемой и электромаг-
нитными структурами. Топология – это фактически другое представление схемного решения и любые 
модификации, которые делаются в схеме, автоматически и немедленно отображаются и в соответствую-
щей её топологии и наоборот. Это исключает необходимость в сложной синхронизации соответствия 
схемы и её топологии перед моделированием. 

В Microwave Office имеется много возможностей, которые позволяют создавать сложные топо-
логии, типа монолитных СВЧ микросхем (MMIC) и различных типов многослойных структур. Приводи-
мый здесь пример показывает некоторые основные возможности создания топологии. 

Создание топологии в Microwave Office включает следующие основные шаги: 
 

o Импортирование файла обработки слоя (*.lpf); 
o Редактирование базовой единицы измерения и размера сетки по умолчанию; 
o Импортирование библиотеки элементов топологии; 
o Импортирование и размещение файла данных в схемном решении; 
o Замена изображения схемного элемента в схеме; 
o Размещение микрополосковых проводников в топологии; 
o Назначение элемента топологии элементу схемы; 
o Просмотр топологии; 
o Закрепление элемента топологии; 
o Создание элемента топологии; 
o Управление элементом MTRACE2 (элемент, которым можно чертить изогнутые про-
водники, например, меандровую линию) в топологии; 

o Экспортирование топологии. 
 
Создание нового проекта. 

Чтобы создать новый проект: 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диало-

говое окно Save As. 
3. Наберите имя проекта (например, Layout) и нажмите Сохранить. 

 
Определение глобальных единиц измерения в проекте. 

Выберите в меню Options>Project Options и в открывшемся окне для частоты введите единицу 
измерения GHz, снимите отметку в Metric units и в поле Length type введите mil. Нажмите OK. 

 
Импортирование файла слоя. 

Файл слоя (LPF) определяет установки по умолчанию для представления топологии, включая 
рисунок слоёв, отображение , 3-х мерное изображение и отображение электромагнитных структур. Что-
бы импортировать файл *.lpf: 

1. Щёлкните левой кнопкой мышки по панели Layout (Топология) в нижней части левого 
окна, чтобы открыть менеджер топологии 
(Layout Manager). Менеджер 2. Правой кнопкой мышки щёлкните по 
Layer Setup (Установка слоя) в менеджере 
топологии и выберите Import Process Defi-
nition (Импорт процесса определения). От-
кроется диалоговое окно Import Process 
Definition. 

топологии 

3. Найдите папку …\AWR\AWR2007 и 
дважды щёлкните по ней левой кнопкой 
мышки, чтобы открыть папку. 

4. Выделите файл MIC_english.lpf и 
нажмите Открыть. Окно менеджера топо-
логии будет выглядеть, как показано на рис. 
4.1. Слои в нижней части окна менеджера 
топологии отображаются в том случае, если 
на рабочем поле открыто окно схемы. 

Рис. 4.1 
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Редактирование базовой единицы измерения и размера сетки по умолчанию. 
Базовые единицы измерения являются минимальными единицами измерения, определяющими 

точность топологии. Установленное значение базовых единиц измерения в дальнейшем не должно изме-
няться в процессе работы над проектом. Их изменение может вызвать погрешности округления, что мо-
жет вызвать проблемы в файле топологии. 

Размер сетки важен потому, что размеры многих элементов топологии должны быть кратны раз-
мерам сетки. Размер сетки должен быть равен или больше базовых единиц измерения. При создании то-
пологии схемы вы можете изменять размер сетки, увеличивая или уменьшая его до 10 раз, вводя соот-
ветствующий множитель на панели инструментов при открытом окне топологии схемы. Поэтому размер 

сетки нужно устанавливать в 10 раз больше 
базовых единиц измерения, чтобы не допус-
тить наличие более мелкой сетки, чем базо-
вые единицы измерения. 

Чтобы установить базовые единицы 
измерения и размер сетки: 

1. Выберите в меню Op-
tions>Layout Options или два-
жды щёлкните левой кнопкой 
мышки по Layout Options в 
окне менеджера топологии. 

2. В открывшемся окне опций то-
пологии на вкладке Layout 
(рис. 4.2) в поле Grid spacing 
(Интервал сетки) введите 0.1 
mil, в поле Database unit size 
(Размер базовой единицы изме-
рения) введите 0.01 mil. На-
жмите OK. Рис. 4.2 

 
Импортирование библиотеки элементов GDSII. 

Библиотеки элементов исполь-
зуются в Microwave Office, чтобы обес-
печивать создание, как многослойных 
физических структур, так и полосков 
печатных плат или обработки гибрид-
ных устройств, а так же для стандарт-
ных графических работ, используемых 
при обработке монолитных СВЧ микро-
схем (MMIC) и высокочастотных инте-
гральных схемах (RFIC). Microwave 
Office поддерживает формат файлов 
GDSII для чертежей. 
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Чтобы импортировать библио-
теку элементов GDSII: 

1. Правой кнопкой мыш-
ки щёлкните по Cell Libraries 
(Библиотеки элементов) в ме-
неджере топологии и выбери-
те Import GDSII Library 

(Импортировать библиотеку GDSII). Откроется диалоговое 
окно Import GDSII Library (Рис. 4.3). 

Рис. 4.3 

2. Откройте папку …\AWR\MWO2007\Examples \Micro-
wave Office \Getting_Started\Layout и дважды щёлкните левой 
кнопкой мышки по файлу packages.gds, чтобы импортировать 
этот файл. 

3. Откроется окно Warning: Different Database Unit 
(Предупреждение: Модуль различной базы данных). В этом 
окне сообщается, что некоторые пункты в этой библиотеке 
будут сокращены в текущем модуле базы данных при выпол-
нении чертежа или сохранении в файле и перечисляются эле-
менты из базы данных. Нажмите OK. Импортированная биб-
лиотека будет отображена в окне менеджера топологии, как 
показано на рис. 4.4. Рис. 4.4 

 
 



Импортирование файла данных. 
Чтобы импортировать файл данных: 

1. Щелкните мышкой по п 
Project в нижней части левого ок-
на. 

2. Правой кнопкой мышки 
щёлкните по группе Data Files в 
окне просмотра проекта и выбери-
те Import Data File. Откроется 
диалоговое окно Browse For File 
(Рис. 4.5). 

3. Откройте папку 
…\AWR\MWO2007\Examples\ Mi-
crowave Office\Getting_Started\ 
Layout и дважды щёлкните по 
файлу N76038a.s2p, чтобы импор-
тировать его. 

 
 Рис. 4.5 
 

Создание схемы. 
Чтобы создать схему: 

1. Правой кнопкой мышки щёлкните по группе Circuit Schematics  в окне просмотра про-
екта и выберите New Schematic или щёлкните по значку New Schematic на панели инструмен-
тов. Откроется диалоговое окно Create New Schematic (Создать новую схему). 

2. Введите qs layout и нажмите OK. 
 
Размещение файла данных в схеме и добавление точки заземления. 

Как только вы импортировали файл данных, он появляется как элемент подсхемы в группе Sub-
circuits в окне просмотра элементов, как показано на рис. 4.6. Теперь вы можете файл данных вставить в 
качестве подсхемы в любую схему, создаваемую в проекте. 

 66

Чтобы поместить файл данных в схеме: 

б, возможно, более удобный, за-
ключает

вой кнопкой мышки по значку 

По умолчанию подсхемам присваивается символ прямоугольника, который имеет столько узлов, 
сколько имеется портов в исходной схеме. В нашем случае подсхема файла данных, который представ-
ляет собой S-параметры транзистора, имеет только два узла, хотя для транзистора их должно быть три. 
Для подобных случаев Microwave Office предоставляет возможность добавить третий узел, который на-
зван Explicit ground node (Явный узел земли). Т.е. нам нужно вставить в схему элемент подсхемы 
N76038a с добавленным третьим узлом. Сделать это можно двумя способами. 

1. Щёлкните мышкой по панели Elements в ниж-
ней части левого окна, чтобы отрыть окно 
просмотра элементов. 

2. Щёлкните левой кнопкой мышки по группе 
Subcircuit (Подсхемы). Модели подсхем ото-
бражаются в нижней части левого окна. 

3. Нажмите левой кнопкой мышки на модель 
N76038a и, не отпуская кнопки мышки, пере-
тащите её в окно схемы, отпустите кнопку 
мышки, поместите элемент в окне схемы и 
щёлкните левой кнопкой мышки, чтобы его 
зафиксировать. Рис. 4.6 

4. В окне схемы дважды щёлкните мышкой по 
вставленному элементу N76038a. 

5. В открывшемся окне свойств элемента от-
кройте вкладку Ground (рис. 4.7). В области 
Grounding Type отметьте Explicit ground 
node и нажмите OK. Элемент подсхемы бу-
дет выглядеть, как показано на рис. 4.6. 

Второй спосо
ся в следующем: 

1. Щёлкните ле

SUB  на панели инструментов. 

Рис. 4.7 



2. Откроется окно Add Subcircuit Element со списком всех 
имеющихся в проекте подсхем (рис. 4.8). 

3. Отметьте N76038a в списке подсхем, затем отметьте Ex-
plicit ground node и нажмите OK. Результат будет таким 
же, как показано на рис. 4.6. 

 
Замена символа элемента. 

Символ подсхемы может быть изменён на 
FET, чтобы можно было видеть, какие узлы соответ-
ствуют затвору, стоку и истоку. Чтобы изменить 
символ: 

1. Дважды щёлкните левой кнопкой 
мышки по элементу подсхемы в окне 
схемы. Откроется диалоговое окно 
Element Options. 

2. В открывшемся окне опций элемента 
откройте вкладку Symbol. 

Рис. 4.9 Рис. 4.8 

3. В верхнее строке ввода типов символов введите all (все) или system.syf, щёлкнув по кнопке 
в правом конце этой строки. В расположенном ниже списке символов выделите 
FET@system.syf и нажмите OK. Результат показан на рис. 4.9. 

 
Размещение микрополосковых элементов в схеме для топологии. 

Микрополосковые элементы имеют по умолчанию соответствующие им элементы топологии. 
Элементам топологии автоматически присваиваются параметры и размеры в соответствии со значения-
ми, определёнными для каждого параметра. 

Чтобы разместить микрополосковые элементы: 
1. Дважды щёлкните левой кнопкой мышки по под-

группе Microstrip в окне просмотра элементов. 
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 кнопкой мышки по под-

ки, чтобы зафиксировать 

те его на 

2. Щёлкните левой кнопкой мышки по подгруппе 
Lines. Модели линий отображаются в нижней час-
ти левого окна. 

3. Нажмите левой кнопкой мышки на модель MLIN 
и, не отпуская кнопки мышки, перетащите элемент 
в окно схемы, отпустите кнопку, поместите эле-
мент на узле 1 подсхемы N76038a и щёлкните ле-

вой кнопкой мышки, чтобы зафиксировать его (Рис.4.10). 

Рис. 4.10 

4. Теперь щёлкните левой кнопкой мышки по подгруппе Junction (Сочленения) в группе Mi-
croscrip в окне просмотра элементов. Модели сочленений отображаются в нижней части 
левого окна. 

 
Примечание. Элементы, имеющие на конце имени $, наследуют параметры от других эле-
ментов, с которыми они соединяются. Элементы, имеющие на конце имени X, созданы элек-
тромагнитным моделированием с параметрами, сведёнными в таблицу. Например, MTEEX$ 
– это Т – сочленение в микрополосковой линии, созданное электромагнитным моделирова-
нием, которое наследует ширину полосок от линий, с которыми оно соединяется. 

 
5. Нажмите левой кнопкой мышки на модель 

MTEE$ и, не отпуская кнопки мышки, пе-
ретащите элемент в окно схемы, отпустите 
кнопку, поместите элемент так, чтобы со-
единить его с левым узлом элемента MLIN, 
как показано на рис. 4.11 и щёлкните левой 
кнопкой мышки, чтобы зафиксировать его. 

6. Щёлкните левой
Рис. 4.11 

группе Lines, перетащите элемент 
MTRACE2 в окно схемы и соедините его с 
узлом 1 элемента MTEE$ и щёлкните ле-
вой кнопкой мыш
элемент. 

7. Перетащите элемент MLEF в окно схемы, 
щёлкните три раза правой кнопкой мышки, 
чтобы повернуть элемент, помести
узел 3 элемента MTEES и щёлкните левой 
кнопкой мышки, чтобы зафиксировать 
(рис. 4.12). Рис. 4.12 
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енту MTRACE2 в окне схемы, чтобы от-

затем по элементу MLEF, и отредактируйте 

 кнопкой мыш-

ащите 

B в окне 

в окно схемы, поместите порт на левом 

о схемы, щёлкните три раза правой кнопкой мышки, чтобы развернуть порт, 

 панели ин-
струментов, переместите курсор в окно схемы, поместите землю на узле 3 элемента 

Рис. 4.14). 

е топологического чертежа ячейки элементу схемы. 
Элементу схемы может быть поставлен в соответствие топологический чертёж ячейки. Чтобы 

 

 открыть диало-

тметьте Al-

8. Дважды щёлкните левой кнопкой мышки по элем
крыть диалоговое окно Element Options. Введите следующие параметры: W=10 mil, L=200 
mil, BType=2 и M=0.6. Нажмите OK. 

9. Дважды щёлкните мышкой по элементу MLIN, 
их параметры следующим обра-
зом. Для элемента MLIN введи-
те W=10 mil, L=100 mil. Для 
элемента MLEF введите W=20 
mil, L=150 mil. 

10. Щёлкните левой
ки по подгруппе Substrates 
(Подложки) в окне просмотра 
элементов. Модели подложек 
отображаются в нижней части 
левого окна. 

11. Нажмите левой кнопкой мышки 
на модель MSUB и, не отпуская 
кнопки мышки, перет
элемент в окно схемы, отпусти-
те кнопку, поместите элемент, 
как показано на рис. 4.13 и 

щёлкните левой кноп-
кой мышки, чтобы за-
фиксировать. 

12. Дважды щёлкните ле-
вой кнопкой мышки по 
элементу MSU

Рис. 4.13 

схемы, чтобы открыть 
диалоговое окно Ele-
ment Options. Введите 
Er=9.8, H=10 mil, 
T=0.1 mil, Rho=1, 
Tand=0 и ErNom=9.8. 
Нажмите OK. 

13. Щёлкните левой кноп-
кой мышки по значку 

Port на панели инструментов, переместите курсор 

Рис. 4.14 

узле элемента MTRACE, как показано на рис. 4.14 и щёлкните левой кнопкой мышки, что-
бы зафиксировать. 

14. Снова щёлкните левой кнопкой мышки по значку Port на панели инструментов, перемести-
те курсор в окн
поместите его на узле 2 элемента SUBCKT и щёлкните левой кнопкой мышки, чтобы за-
фиксировать. 

15. Чтобы закончить схему, щёлкните левой кнопкой мышки по значку Ground на

SUBCKT и щёлкните левой кнопкой мышки, чтобы зафиксировать (
 

Назначени

сделать это: 

1. Дважды щёлкните по эле-
менту N76038a в окне схе-
мы, чтобы
говое окно Element Op-
tions. 

2. Откройте вкладку Layout 
этого окна. 

3. В поле ввода Library 
Name введите packages, 
щёлкнув мышкой по кноп-
ке в правом конце этого 
поля, и в списке топологи-
ческих ячеек о
pha_212_3. Нажмите OK. 

Рис. 4.15 



Просмотр топологии. 
Чтобы просмотреть топологию: 

1. При активном окне схемы выберите в меню View>New Layout View или щёлкните левой 

кнопкой мышки по значку New Schematic View Layout  на панели инструментов. 
Топология будет показана в окне топологии на рабочем поле. Она может отображаться в 

беспорядочном виде, где 
правильные соединения отдельных 
топологических элементов показаны 
красными линиями. 

2. Установите курсор мышки левее и 
выше топологии, нажмите левую 
кнопку мышки и, не отпуская 
кнопки, переместите курсор правее 
и ниже топологии так, чтобы вся 
топология попала в образовавшийся 
прямоугольник. Или выберите в 
меню Edit>Select All. Вся топология 

должна быть выделена. 
Рис. 4.16 

3. Выберите в меню Edit>Snap Together (Редактировать>Связать вместе) или щёлкните по 

значку Snap Together , чтобы связать вместе все элементы топологии и тем самым 
упорядочить топологию. Созданная топология показана на рис. 4.16. 

 
Закрепление элемента топологии. 

Элементы топологии обладают определёнными свойствами, которые определяют, каким образом 
каждый элемент топологии соединяется с другими элементами при упорядочении топологии. Одним из 
таких свойств является возможность закрепить элемент топологии на установленном месте. Причём 
возможны два варианта такого закрепления: Anchor (Прикрепить) и Freeze (Зафиксировать). Если 

изменениях в расположении элементов в схеме или 
изменении их параметров с последующим 
редактированием топологии командой Snap 
Together, чтобы снова соединит вместе изменённое 
расположение соответствующих элементов 
топологии, то акреплённые эле ы будут 
оставаться а режнем месте Все остальные 
элементы опо огии будут “подгоняться” под 
закреплённые элементы Однако закреплённый тим 
способом элемент топологии можно перемещать 
мышкой или координатным вводом. Если же элемент 
топологии закрепить командой Freeze, то такой 
элемент нельзя переместить никаким способом. 

Чтобы закрепить элемент топологии: 

использовать закрепление Anchor, то при любых 

ь 

 з мент
н п . 
т л

. э

лкните 

окна 

 теперь закреплён и 
отображ

1. В окне топологии схемы щёРис. 4.17 левой кнопкой мышки по 
топологическому элементу 
Alpha_212_3, чтобы выделить его. 
Затем щёлкните по этому элементу 
правой кнопкой мышки и выберите 
Shape Properties (Свойства 
формы). Откроется диалоговое 
окно Cell Options (рис. 4.17). 

2. На вкладке Layout этого 
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отметьте Use for Anchor и нажмите 
OK. 

Элемент топологии
ается в топологии с символом 

закрепления, как показано на рис. 4.18. 

Рис. 4.18 

 
Черчение топологического чертежа элемента топологии. 

Чтобы создать топологический чертёж элемента топологии: 
1. Щёлкните левой кнопкой мышки по панели Layout в нижней части левого окна, чтобы 

активизировать менеджер топологии. 
2. Щёлкните правой кнопкой мышки по подгруппе packages (многослойные структуры) в 

группе Cell Libraries (Библиотеки элементов) и выберите New Layout Cell  (Новый элемент 



топологии) во всплывающем меню. Откроется диалоговое окно Create New Layout Cell 
(Создание нового элемента топологии). 

3. Введите chip cap (чип конденсатора) в поле Enter the name of the cell (Ввод имени 
элемента) и нажмите OK. На рабочем поле откроется окно 
для черчения. 

4. Щёлкните мышкой по кнопке в правом конце поля ввода 
Grid Spacing на панели инструментов и введите в это поле 
множитель 10х (рис. 4.19). Этот множитель определяет 
размер клеток сетки. По умолчанию при выбранной системе 
единиц измерения длины он равен 0.1 mil. Множитель 10х 
увеличивает размер клеток сетки в 10 раз, т.е. он будет равен 
1 mil. Если этого поля на панели инструментов нет, 
щёлкните правой кнопкой мышки по панели инструментов и 

отметьте Cell Edit. 

Рис. 4.19

5. Щёлкните левой кнопкой мышки по квадрату 0->Copper (Медь) в 
нижней части окна менеджера, чтобы назначить медь для активного 
слоя, как показано на рис. 4.20 (не щёлкайте по лампочке, т.к. такой 
щелчок определяет слой для показа или скрытия). 

6. Щёлкните левой кнопкой мышки по окну черчения на рабочем поле, 
чтобы сделать его активным. 

7. Выберите в меню Draw>Rectangle (Чертить>Прямоугольник) или 
щёлкните по значку Rectangle на панели инструментов. Рис. 4.20 

8. Переместите курсор в окно черчения, затем нажмите 
клавишу Tab на клавиатуре. Откроется диалоговое окно 
Enter Coordinates (Ввод координат, рис. 4.21). 

9. Введите значения 0 и 10 в поля x и y соответственно и 
нажмите OK. 

10. Нажмите клавишу Tab снова, чтобы открыть диалоговое 
окно Enter Coordinates (рис. 4.22). Рис. 4.21 

11. Введите значения 10 и -10 в поля dx и dy соответственно и 
нажмите OK. Полученный рисунок показан на рис. 4.23. 

12. Щёлкните левой кнопкой мышки по квадрату 0->Footprint 
(Контур) в нижней части окна менеджера, чтобы создать 
пустой прямоугольник на плате. Рис. 4.22 

13. Выберите в меню 
Draw>Rectangle или 
щёлкните по значку 
Rectangle на панели 
инструментов. 
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14. Переместите курсор в окно 
черченя, затем нажмите 
клавишу Tab на 
клавиатуре. Откроется 
диалоговое окно Enter 

Coordinates. 

Рис. 4.23 Рис. 4.24 

15. Введите значения 10 и 10 в поля x и y 
соответственно и нажмите OK. 

16. Нажмите клавишу Tab снова, чтобы 
открыть диалоговое окно Enter 
Coordinates. 

17. Введите значения 20 и -10 в поля dx и dy 
соответственно и нажмите OK. 
Полученный чертёж показан на рис. 4.24. 

18. Щёлкните левой кнопкой мышки по 
левому медному квадрату в окне рисунка и нажмите клавиши Ctrl+C и затем Ctrl+V или 
щёлкните левой кнопкой мышки по значку Copy и затем по значку Paste на панели 
инструментов, чтобы скопировать и вставить прямоугольный проводник. Нажмите левой 
кнопкой мышки на скопированный проводник и, не отпуская кнопки мышки, переместите 
его к правому краю последнего прямоугольника топологии и щёлкните левой кнопкой 
мышки, чтобы зафиксировать. Полученная топология показана на рис. 4.25. 

Рис. 4.25 

 
Добавление портов к созданному элементу топологии. 

Порты в элементе топологии определяют грани, по которым данный элемент соединяется с 
другими топологическими элементам. Направление стрелки порта показывает направление, по которому 
происходит соединение топологического элемента с соседними топологическими элементами. 



Чтобы добавить порты к созданному элементу топологии: 
1. Выберите в меню Draw>Cell Port (Чертить>Порт элемента) или щёлкните левой кнопкой 

мышки по значку Cell Port на панели инструментов. 
2. Переместите 

курсор в окно 
черчения. Нажав 
и удерживая 
клавишу Ctrl, 
поместите кур-
сор на нижний 
левый угол  ле-
вого квадратного 
проводника так, 
чтобы неболь-

шой квадратик появился на этом углу. Не отпускайте клавишу Ctrl. 

Рис. 4.26 Рис. 4.28Рис. 4.27 

3. Не отпуская клавишу Ctrl, нажмите левую кнопку мышки (соответствующее изображение 
показано на рис. 4.26) и, не отпуская её, двигайте курсор к верхнему левому углу проводни-
ка, пока другой квадрат появится на этом углу (рис. 4.27). Отпустите кнопку мышки и кла-

вишу Ctrl. Добавленный порт показан на рис. 
4.28. 
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4. Повторите шаги с 1-го по 3-ий, чтобы помес-
тить порт на противоположной стороне ри-
сунка, но начните с верхнего правого угла и 
двигайте курсор к правому нижнему углу. 

5. Закройте окно черчения. Будет выведен за-
прос, хотите ли вы сохранить нарисованный 

элемент. Нажмите Yes, чтобы сохранить. Полученная топология показана на рис. 4.29. 

Рис. 4.29 

 
Добавление в схему конденсатора и назначение ему элемента топологии chip cap. 

Чтобы добавить в схему конденсатор и назначить ему элемент топологии chip cap: 
1. В окне схемы установите курсор на входной порт, нажмите и удерживайте клавишу 

Ctrl, нажмите левую кнопку мышки и, не отпуская её, переместите порт на свободное место в 
схеме, прервав его связь со схемой. 

2. Нажмите панель Elements в нижней части левого окна, чтобы открыть окно просмотра 
элементов. 

Рис. 4.30 

3. Дважды щёлкните левой кнопкой 
мышки по группе Lumped Element (Со-
средоточенные элементы), чтобы рас-
крыть её, затем щёлкните левой кноп-
кой мышки по подгруппе Capacitor 
(Конденсаторы), чтобы отобразить эле-
менты конденсаторов в нижней части 
левого окна. 

4. Нажмите левой кнопкой мышки 
на элемент CAP и, не отпуская кнопки 
мышки, перетащите его в окно схемы, 
отпустите кнопку мышки, подключите 

элемент CAP к левому узлу элемента 
MTRACE и щёлкните левой кнопкой 
мышки, чтобы зафиксировать. 

5. Установите курсор на входной 
порт, нажмите левую кнопку мышки 
и подключите порт ко входу схемы. 
Должна получиться схема, показан-
ная на рис. 4.30. 

6. Дважды щёлкните левой кноп-
кой мышки по элементу CAP в окне 
схемы. Откроется окно Element Op-
tions (Опции элемента). 

7. Нажмите на кнопку Layout в 
верхней части этого окна. 

8. В поле Library Name введите 
packages и в списке элементов от-
метьте chip cap (рис. 4.31). Нажмите 
OK. Рис. 4.31 



9. Выберите в меню View>View 
Layout (Показать>Показать топологию) 
или щёлкните по кнопке New Schematic 
Layout View на панели инструментов. 
Новая топология будет отображена на 
рабочем поле (рис. 4.32). 

10. Если топологические элементы 
не соединены должным образом, о чём 
говорит наличие красных линий на то-
пологии, выберите в меню Edit>Select 
All и затем щёлкните по значку Snap 

Together на панели инструментов. 
Рис. 4.32 

 
Трассировка элемента MTRACE2 в окне топологии. 

Элемент MLIN – это прямоугольный элемент, чья ширина задаётся и может изменяться в топо-
логии, но редактировать форму этого элемента (например, делать изгибы) нельзя. Элемент MTRACE2 – 
это элемент, топология которого может быть отредактирована, чтобы иметь изгибы со скошенными 
краями. Элемент MCTRACE – это элемент, топология которого может быть отредактирована, чтобы 

иметь изгибы со скруглёнными краями. 
Чтобы выполнить трассировку топологии элемента 

MTRACE2: 
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естите курсор на крайний правый 

рсор, не нажимая 

ассиров-

е элементы не соединены 

пции привязки элементов топологии. 

ементов топологии в различных 

 

 

1. Дважды щёлкните левой кнопкой мышки по 
элементу топологии MTRACE2. На проводнике 
появятся синие ромбики, как показано на рис. 4.33. 

2. Пом

Рис. 4.33 

ромбик так, чтобы он отображался в виде 
двойной стрелки. Дважды щёлкните левой 
кнопкой мышки, чтобы активизировать ин-
струмент трассировки. 

3. Переместите ку
кнопки мышки, в желательную точку и 
щёлкните левой кнопкой мышки, чтобы за-

фиксировать (рис 4.34). (Щелчок правой кнопкой 
мышки удалит последнюю точку трассировки, на-
жатие клавиши Esc отменяет процесс трассировки). 

4. Продолжайте двигать инструмент тр

Рис. 4.34 

ки к точкам нужного маршрута, щёлкая левой кноп-
кой мышки, чтобы фиксировать точки изгиба, затем 
дважды щёлкните левой кнопкой мышки, чтобы за-
кончить трассировку. Пример полученной тополо-
гии показан на рис. 4.35. 

5. Если топологическиРис. 4.35 
должным образом, о чём говорит наличие красных линий на топологии, выберите в меню 
Edit>Select All и затем щёлкните по значку Snap Together на панели инструментов. 

 
О

Опции привязки определяют соеди-
нения эл
конфигурациях. Эти опции вы можете уста-
новить в диалоговом окне Layout Options. 

1. Выберите в меню Options> 
Layout Options. Откроется
диалоговое окно Layout Op-
tions (рис. 4.36). 

2. На вкладке Layout этого окна 
в области Layout Cell Snap
Options (Опции привязки эле-
ментов топологии) в поле Snap 
together (Привязать вместе) 
введите Manual snap for se-
lected objects only (Привязка 
вручную только для выделен-
ных объектов), щёлкнув по 
кнопке в конце этого поля. 
Нажмите OK. Рис. 4.36 



3. Чтобы просмотреть действие этой установленной опции, изменим положение некоторых 
элементов топологии. Установите курсор на элемент топологии, соответствующий элементу 
схемы MLEF, нажмите левую кнопку мышки и переместите этот элемент, как показано на 
рис. 4.37. 

4. Повторите п. 3 для элементов MTRACE2 и конденсатора chip cap, как показано на рис 
4.38. Красные линии показывают, что грани этих элементов не соединены. 
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5. Чтобы соединит элементы, нажмите клавишу Shift и щёлкните мышкой по элементам 
MLEF, MTRACE2 и MTEE$ в окне топологии. 

Рис. 4.37 
Рис. 4.38 

6. Щёлкните мышкой по значку Snap Together на панели инструментов. Результат показан на 
рис. 4.39. Заметьте, что не все элементы топологии соединены вместе. 

7. Нажмите клавиши Ctrl+A, чтобы выделить всю топологию. 
8. Щёлкните мышкой по значку Snap Together на панели инструментов. Вся топология будет 

соединена (рис. 4.40). 

Если элемент конденсатора не соединён с элементом MTRACE2, их можно соединить и другим 
способом, используя команду snap tu fit (подогнать привязку). При выполнении этой команды 
изменяется маршрут элемента MTRACE2, чтобы обеспечить соединение, вместо того, чтобы 
переместить элемент конденсатора, как в предыдущем случае. Это может выглядеть следующим 
образом. 

Рис. 4.40 Рис. 4.39 

1. Установите курсор на элемент конденсатора, нажмите левую кнопку мышки и переместите 
этот элемент, как показано на рис. 4.41. 

2. Щёлкните мышкой по элементу топологии MTRACE2, чтобы выделить его. 

3. Щёлкните мышкой по значку Snap to fit  на панели инструментов. Результат показан на 
рис. 4.42. 

 

Рис. 4.41 Рис. 4.42 

 
 



Экспорт топологии. 
Чтобы экспортировать топологию: 

1. Выберите в 
меню Op-
tions>Drawing Lay-
ers (Опции>Слои 
черчения), чтобы оп-
ределить слои, кото-
рые надо экспорти-
ровать в файл. От-
кроется диалоговое 
окно Drawing Layer 
Options (Опции слоя 
черчения). 

2. В левой части 
окна щёлкните 
мышкой по File Ex-
port Mappings (Со-
ответствие файла 
экспорта) и отметьте 
DXF. В столбце 
Write Layer (Запи-
сать слой) отметьте 
Copper (Медь) и 
снимите все осталь-
ные “галочки” (рис. 

4.43). Нажмите OK. 
Рис. 4.43 
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 В поле Имя 

На этом пример моде-
лирован

3. Выберите в 
меню Layout>Export 

(Тополо-
гия>Экспорт). От-
кроется диалоговое 
окно Export Layout 
(рис.4.44). 

4. В поле Тип 
файла введите DXF 
(Flat*.dxf), щёлкнув 
левой кнопкой мыш-
ки по кнопке в пра-
вом конце этого поля. 

5.
файла введите qs 
Layer и нажмите Со-
хранить, чтобы экс-
портировать слой ме-
ди в файл DXF. 

 

ия топологии закончен. 
При желании вы можете сохра-
нить свою работу, выбрав в 
меню File>Save Project . 

 

Рис. 4.44 
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5. Электромагнитное моделирование 
Электромагнитное моделирование (EM) использует уравнения Максвелла для определения ха-

рактеристик устройства по его заданной физической геометрии. С помощью электромагнитного модели-
рования можно анализировать произвольные структуры и обеспечивать очень точные результаты. Кроме 
того, электромагнитное моделирование свободно от ограничений, имеющихся в моделях электрических 
цепей, т.к. использует фундаментальные уравнения для вычисления характеристик. Недостатком такого 
моделирования является то, что, в зависимости от сложности структуры, увеличивается необходимый 
объём оперативной памяти и увеличивается время моделирования по экспоненте. Поэтому важно мини-
мизировать сложность структуры, чтобы время моделирования было приемлемым, а требуемый объём 
оперативной памяти не превышал имеющийся на компьютере. 

Электромагнитное и схемотехническое моделирования – это дополняющие друг друга методы 
для проектирования интегральных схем. Используя комбинации этих методов, можно решить многие 
проблемы проекта. 

Microwave Office поддерживает интеграцию многих решающих устройств электромагнитного 
моделирования других программных продуктов через интерфейс “EM Socked” (“Канал электромагнитно-
го моделирования”). Для этого соответствующее программное обеспечение должно поддерживать этот 
интерфейс. Например, одним из таких решающих устройств является  последняя версия Sonnet. Приве-
дённые здесь примеры используют только собственное решающее устройство EMSight. 

Блок электромагнитного моделирования EMSight в Microwave Office, способен моделировать 
планарные трёхмерные структуры, содержащие множество металлических и диэлектрических слоёв. 
Структуры могут иметь межслойные переходы или заземления. EMSight использует метод моментов 
Галёркина в спектральной области, который является чрезвычайно точным для анализа полосковых, 
микрополосковых, компланарных, а также других произвольных структур. Используемая должным обра-
зом, эта методика может обеспечивать точные результаты моделирования до 100 ГГц и выше. 

В 7-ой версии AWR Design Environment (AWRDE) интерфейс пользователя для электромагнит-
ных структур значительно изменился. Прежний редактор EM Layer Editor удалён и вместо него исполь-
зуется редактор для топологии схем Layout Editor. В новый редактор внесены существенные изменения: 

o Метод выбора слоя при редактировании проводников и/или перемычек изменился. 
o Просмотр ячеек сетки, токов и Е-полей для электромагнитной структуры изменился и выполня-

ется через добавление аннотации к электромагнитной структуре. 
o Все проекты из более ранних версий, которые содержат электромагнитные структуры, преобра-

зуются к новой электромагнитной структуре. 
Следующие примеры показывают некоторые из основных особенностей электромагнитного мо-

делирования в Microwave Office. 

5.1. Моделирование встречноштыревого микрополоскового 
фильтра 

Этот пример показывает, как использовать электромагнитное моделирование в Microwave Office 
для проектирования встречноштыревого микрополоскового фильтра. Такое моделирование включает 
следующие основные шаги: 

o Создание электромагнитной структуры; 
o Определение корпуса; 
o Создание топологии; 
o Моделирование межслойных переходов; 
o Просмотр структуры в трёхмерном изображении; 
o Определение портов и установка референсных плоскостей; 
o Конфигурирование структуры сетки; 
o Просмотр плотности тока и электрических полей; 
o Выполнение усовершенствованной развёртки частоты (AFS – Advanced Frequency Sweep). 
o Добавление электромагнитной структуры в схему и анализ. 

 
Создание нового проекта. 

Чтобы создать новый проект: 
1. Выберите в меню File>New Project (Файл > Новый проект). 
2. Выберите в меню File>Save Project As (Файл > Сохранить проект как. Откроется диалого-

вое окно Save As. 
3. Наберите имя проекта (например, EM-example) и нажмите Сохранить. 

 
Импорт файла обработки слоя LPF (Layer Process File). 

1. Выберите в меню Project>Process Library>Import LPF. Откроется окно Import Process 
Definition. 

2. Откройте корневой каталог программы (по умолчанию C:\Program Files\AWR\AWR2007). 



3. Выберите Blank.lpf и нажмите Открыть, затем в следующем открывшемся окне нажмите 
Да, чтобы заменить существующий LPF. 

 
Создание электромагнитной структуры. 

Чтобы создать новую электромагнитную структуру: 
1. Выберите в меню Project>Add EM Structure>New EM Structure или щёлкните левой 

кнопкой мышки 
по значку New 
EM Structure 

 на панели 
инструментов. 

2. Наберите Inter-
digital Filter 

(Встречношты-
ревой фильтр) в 
поле Enter a 
name for the 
EM Structure 
(Ввод имени для 
электромагнит-

ной структуры), 
отметьте AWR 
EMSight Simu-
lator и нажмите 
Create. На ра-
бочем поле от-
кроется окно 
электромагнит-

ной структуры 
(рис. 5.1). 

 

Рис. 5.1 

Примечание. EMSight использует прямоугольную сетку для представления структуры. Для про-

Определение корпуса. 
пуса задаются все диэлектрические материалы для каждого из слоёв в элек-

тромагн

ить корпус: 
Options>Project Options или дважды щёлкните мышкой по Project 

gth type 

ons>Layout Options. Откроется диалоговое окно Layout Options. 

sure 

екта лучше использовать по возможности более грубую сетку, поскольку это уменьшает время 
моделирования. Здесь нужно искать компромисс между временем моделирования и точностью. 
 

При определении кор
итной структуре, краевые условия, все физические размеры структуры и размер сетки, который 

будет использоваться. 
Чтобы определ

1. Выберите в меню 
Options в левом окне просмотра проекта. Откроется диалоговое окно Project Options. 

2. На вкладке Global Units этого окна в поле Frequency введите GHz, в поле Len
введите mm и нажмите OK. 

3. Выберите в меню Opti
На вкладке Layout этого окна в области Grid Options (Опции сетки) в поле Grid Spacing (Ин-

тервалы сетки) введите 1 mm, в поле 
Database unit size введите 0.01 mm и 
нажмите OK. 

4. Дважды щёлкните левой кноп-
кой мышки по подгруппе Enclo
(Корпус) в дереве стержневого фильтра 
Interdigital Filter (в группе EM Struc-
tures) в окне просмотра проекта (см. 
рис. 5.1) или щёлкните левой кнопкой 
мышки по значку Substrate Informa-

tion (Информация о подложке)  на 
панели инструментов. Откроется диа-
логовое окно свойств электромагнит-
ной структуры. 

5. На вкладке Enclosure открывше-
гося окна (рис. 
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5.2) в поля X_Dim и 
Y_Dim введите 12, в поля Grid_X и 
Grid_Y введите 0.2. Рис. 5.2 



6. На вкладке Material 
Defs щёлкните мышкой по 
кнопке Add для Dielectric 
Definitions, чтобы доба-
вить материал диэлектри-
ка. Откроется дополни-
тельное диалоговое окно 
Add Dielectric (рис. 5.3). В 
поле Preset (Предвари-
тельная установка) введите 
Alumina, щёлкнув мыш-
кой по кнопке в правом 

конце этого поля. В поле Er введите 9.8, в поле TanD введите 0.001, нажмите OK. 
Рис. 5.3 Рис. 5.4 

7. Щёлкните мышкой по кнопке Add для Conductor Definitions, чтобы добавить материал 
проводника. Откроется дополнительное диалоговое окно Add Conductor (рис. 54). В поле Pre-
sets введите Gold, остальные поля этого окна заполнятся автоматически. Нажмите OK. Вклад-
ка Material окна свойств электромагнитной структуры должна выглядеть, как показано на рис. 
5.5. 
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8. На вкладке Dielectric Layers (Диэлектрические слои) для слоя 1 в колонке Thickness 
(Толщина) введите 5, в колонке Material Definition введите Air (Воздух), щёлкнув левой кноп-
кой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 1. Для слоя 2 в 
колонке Thickness введите 0.636, в колонке Material Definition введите Alumina, щёлкнув ле-
вой кнопкой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 4, что-
бы удобнее было просматривать трёхмерное отображение электромагнитной структуры. 
Вкладка Dielectric Layers должна выглядеть, как показано на рис. 5.6. 

Рис. 5.5 

 
Примечание. Граничные условия для боковых стенок корпуса в электромагнитной структуре 
всегда идеальные и не могут быть изменены. Верхняя и нижняя стенки корпуса также являются 
идеальными проводниками по умолчанию, но они могут быть изменены на вкладке Dielectric 
Layers выбором материала в полях Top Boundary (Верхняя граница) и Bottom Boundary (Ниж-
няя граница). В этом примере используются значения по умолчанию. 

 
9. На вкладке Materials определяются материалы для проводников и межслойных перемы-

чек. Щёлкните мышкой по кнопке Insert на этой вкладке. В столбце Name замените появив-



шееся имя Trace1 на Gold Line, в столбце Material Definition введите Gold, щёлкнув мышкой 
по этому полю, в столбце Thickness введите 0.001 (рис. 5.7). 

10. Нажмите OK. 

Рис. 5.6 

Рис. 5.7 
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Создание топологии. 
Чтобы создать топологию для моделирования, можно использовать редактор топологии, имею-

щийся в Microwave Office. Можно так же импортировать структуры непосредственно из топологии схе-
мы, созданной в проекте, или импортировать структуры из файлов формата AutoCAD DXF или GDSII. В 
этом примере мы создадим топологию микрополоскового встречноштыревого фильтра, используя редак-
тор топологии. 

Microwave Office поддерживает абсолютные координаты и относительные. Абсолютные коорди-
наты относятся ко всему корпусу (подложке) электромагнитной структуры, а относительные только к 
отдельному элементу структуры, например, к прямоугольному проводнику. Абсолютная координата x=0 
соответствует левому краю корпуса электромагнитной структуры, а координата y=0 – нижнему краю 
корпуса. Относительная координата x=0 соответствует левому краю элемента, например, прямоугольно-
го проводника, а y=0 – нижнему краю элемента. 

Чтобы создать топологию: 
1. Щёлкните мышкой по панели Layout в нижней части левого ок-

на, чтобы открыть в этом окне менеджер топологии и отметьте Con-
ductor. В поле EM Layer введите 2, щёлкнув по кнопке в правом конце 
этого поля. В поле Material введите Gold Line, щёлкнув по кнопке в 

правом конце этого поля (рис. 5.8). 
2. Выберите в меню Draw>Rectangle 

(Чертить>Прямоугольник) или щёлкните 
левой кнопкой мышки по значку Rectan-
gle  на панели инструментов. 

3. Поместите курсор в окно электро-
магнитной структуры и нажмите клавишу 
Tab на клавиатуре. Откроется диалоговое 
окно Enter Coordinates (Ввод координат), 
показанное на рис. 5.9. 

4. Введите в

Рис. 5.9 

  0  поле x, введите 7.8 в 
поле y и нажмите OK. Рис. 5.10 

 Рис. 5.8 
Примечание. Переход между полями 
ввода можно делать, щёлкая левой кноп-
кой мышки по нужному полю ввода или 
нажимая клавишу Tab на клавиатуре. 
 

5. Нажмите клавишу Tab 
снова, чтобы снова открыть 
диалоговое окно Enter Coordi-
nates (рис. 5.10). Установите 
флажок в переключателе Rel, 
чтобы активизировать относи-
тельные координаты. Введите 
2.2 в поле dx, и 0.6 в поле dy, 
нажмите OK. Проводник пря-
моугольного сечения отобража-
ется в окне электромагнитной 
структуры (Рис. 5.11). 

Примечание. Чтобы удалить неверно 
вставленный проводник, щёлкните по 
нему левой кнопкой мышки и нажмите Рис. 5.11 
клавишу Delete. 

Создайте второй проводник прямоугольного сечения: 
6. Выберите в меню Draw>Rectangle или щёлкните левой кнопкой 

мышки по значку Rectangle на панели инструментов. 
7. Поместите курсор в окно электромагнитной структуры и нажми-

те клавишу Tab. Откроется диалоговое окно Enter Coordinates. Введи-
те 4 в поле x, введите 1.4 в поле y и нажмите OK. 

8. Нажмите клавишу Tab, чтобы снова открыть диалоговое окно 
Enter Coordinates. Установите флажок в переключателе Rel, чтобы ак-
тивизировать относительные координаты. Введите 1.2 в поле dx, 7.2 в 
поле dy и нажмите OK. Второй проводник прямоугольного сечения 
отображается в окне электромагнитной структуры (рис. 5.12). 

Рис. 5.12 
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9. Установите курсор на второй проводник, нажмите левую кнопку мышки и, не отпуская 
кнопки, переместите второй проводник так, чтобы появившиеся от-
носительные координаты смещения были равны dx:-1.8 и dy:1. Оба 
проводника должны соединиться, как показано на рис. 5.13. 

Примечание. Щёлкните по значку Measure (Измерить)  на панели инст-
рументов, чтобы измерить размеры проводников, смещения или зазоры в топо-
логии электромагнитной структуры. 
 
 
 
 
 
 Рис. 5.13 
 

Добавление межслойных перемычек (металлизированных отверстий). 
Межслойные перемычки осуществляют связь между слоями структуры. Мы должны добавить 

заземление одной стороны вертикального проводника на основание корпуса. Чтобы сделать это: 
1. Откройте в левом окне менеджер топологии, отметьте Via и щёлкните по вертикальному 

проводнику, чтобы выделить его. 
2. Выберите в меню Draw>Add Via Port (Чертить>Добавить порт-перемычку) или щёлк-

ните левой кнопкой мышки по значку Via Port  на панели инструментов. 
3. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab. Откро-

ется диалоговое окно Enter Coordinates. Введите 2.6 в поле x, введите 9.4 в поле y и 
нажмите OK. 

4. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter Coordinates. Уста-
новите флажок в переключателе Rel, чтобы активизировать относительные координаты. 

Введите 0.4 в поле dx, -0.8 в поле dy и нажмите OK.  
5. Выберите в меню Edit>Copy (Редактор>Копировать) и затем вы-

берите Edit>Paste (Редактор>Вставить) или щёлкните мышкой 

мышки по значку Copy  и затем по значку Paste  на па-
нели инструментов. 

6. Поместите курсор мышки в окно электромагнитной структуры. 
Контур скопированного межслойного перехода будет отобра-
жаться в окне. 

7. Щёлкните правой кнопкой мышки, чтобы его развернуть. 
8. Нажмите клавишу Tab, чтобы отобразить диалоговое окно Enter 

Coordinates. Снимите галочку в переключателе Rel, чтобы уста-
новить абсолютные координаты. Введите 2.8 в поле x, введите 9 
в поле y и нажмите OK. Новая электромагнитная структура пока-
зана на рис. 5.14. Рис. 5.14 

9. Установите курсор левее и выше вертикального проводника, на-
 кнопку мышки и, не отпуская кнопки, переместите курсор правее и ниже 

созданных перемычек так, чтобы обе перемычки попали в образовав-
шийся прямоугольник. Отпустите кнопку мышки. Обе перемычки бу-
дут выделены. 

жмите левую
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10. Выберите в меню Draw>Modify Shapes>Union (Чер-
тить>Модифицировать формы>Объединить), чтобы объединить обе 
перемычки. Созданная перемычка будет выглядеть, как показано на 
рис. 5.15. 

 
Рис. 5.15 

Примечания. 1. Не обязательно использовать мелкую 
сетку (рис. 5.15), чтобы аппроксимировать круглое от-
верстие межслойного перехода. Точность моделирова-
ния будет достаточной, если цилиндрическое отверстие 
межслойного перехода аппроксимировать призмой в 
виде двух пересекающихся прямоугольников (рис. 
5,16). Центр призмы должен совпадать с центром от-
верстия. Длину и ширину прямоугольников, видимо, 
желательно брать кратными размерам сетки, заданным 
для структуры. 
2. Межслойную перемычку можно сделать и круглой, 

используя инструмент Ellipse. Такой вариант перемычки используется в примере 5.4. 

Рис. 5.15 Рис. 5.16 

 



Просмотр 3-х мерной структуры. 
В Microwave Office поддерживается 2-х мерное и 3-х мерное представления электромагнитных 

структур. Чтобы создать 3-х мерное представление: 
1. Выберите в меню View>New 3D View 

или щёлкните мышкой по значку New 

Schematic 3D View  на панели 
инструментов. На рабочем поле 
появится трёхмерное изображение, как 
показано на рис. 5.16. 
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2. Выберите в меню Window>Tile Vertical 
(Окно>Не перекрывающееся 
вертикальное расположение) или 
Window>Tile Horizontal. Окна с 3-х 
мерным и 2-х мерным изображениями 
отображаются рядом. Затем выберите 
Window>Cascade. 

 
Примечание. Изменить вид отображения 3-х мерной 
структуры можно, щёлкнув правой кнопкой мышки в 
окне 3-х мерной структуры, и затем выбрать Zoom Area 
(Увеличить область), Zoom Out (Уменьшить область) и 

Auto View (Показать всё) во всплывающем меню. Или можно щёлкнуть по соответствующему 
значку на панели инструментов. Чтобы вращать 3-х мерную структуру, нажмите её левой 
кнопкой мышки и, не отпуская кнопки, перемещайте мышку. 

Рис. 5.16 

 
Добавление портов и установка референсных плоскостей. 
 

При электромагнитном моделировании можно определять электрические порты на краю платы 
(т.е. внешние порты) или как зонд, проходящий через нижнюю или верхнюю крышки (т.е. Via Port). 

Чтобы определить внешний порт: 
1. Щёлкните левой кнопкой мышки по горизонтальному проводнику в окне 

электромагнитной структуры. Обратите внимание, что этот проводник 
должен быть позиционирован точно на левом краю подложки (X=0) 
прежде, чем добавлять внешний порт. 

2. Выберите в меню Draw>Add Edge Port (Чертить>Добавить 
внешний порт) или щёлкните левой кнопкой мышки по значку Edge 

Port  на панели инструментов. 
3. Поместите курсор на левый край горизонтального проводника, 

пока не отобразится квадрат, и щёлкните левой кнопкой мышки, 
чтобы зафиксировать порт. Маленькая площадка с номером 1 появится 
на левом краю проводника (рис. 5.17). 

Рис. 5.17 

 
Чтобы установить референсную плоскость для порта 1: 

 
4. Щёлкните правой кнопкой мышки в окне электромагнитной структуры и выберите 

Zoom Area (Увеличить размер 
области) во всплывающем меню 
или нажмите значок Zoom Area 

 на панели инструментов. 
Курсор будет отображаться в 
виде лупы. 

5. Поместите курсор чуть 
выше и левее верхнего левого 
угла входного проводника, 
нажмите левую кнопку мышки 
и, не отпуская кнопки, 
переместите курсор к правому 

нижнему углу этого проводника так, чтобы выделить весь проводник с портом и отпустите 
кнопку мышки. 

Рис. 5.18 

6. Щёлкните левой кнопкой мышки по порту 1. По углам отобразятся четыре небольших 
квадрата. 

 



7. Установите курсор мышки на правый край 
порта так, чтобы курсор отображался в виде двойной 
стрелки. 

8. Нажмите левую кнопку мышки и не отпуская 
кнопки мышки, перетащите курсор вправо, пока не 
будет отображено dx:1.6, dy:0 (рис. 5,18). Отпустите 
кнопку мышки, чтобы зафиксировать площадку. 
Порт с установленной референсной плоскостью бу-
дет выглядеть, как показано на рис. 5.19.. 

 
Рис. 5.19  

Определение частот для моделирования. 
Чтобы определить частоты: 

1. Нажмите панель Project в нижней части левого окна, чтобы открыть окно просмотра 
проекта. 

2. Правой кнопкой мышки щёлкните по объекту Interdigital Filter в группе EM Structures 
и выберите Options во всплывающем меню. Откроется диалоговое окно Options. 

3. Щёлкните панель Frequencies (Частоты) в верхней части окна. 
4. Снимите галочку (если она 

стоит) на переключателе Use Pro-
ject Frequency (Использовать час-
тоты проекта), чтобы локальные 
частоты имели преимущество пе-
ред глобальными частотами проек-
та (рис. 5.20). 

5. Установите GHz в поле Unit, 
щёлкая стрелки справа от этого по-
ля. 

6. Введите 1 в поле Start (На-
чало), ведите 5 в поле Stop (Конец) 
и введите 1 в поле Step (Шаг). 

7. Щёлкните Apply (Приме-
нить). В окне списка Current 
Range (Текущий диапазон) ото-
бражается частотный диапазон и 
частотные точки с шагом, которые 
вы только что определили. Рис. 5.20 

8. Нажмите OK. 
 

Примечание. Microwave Office позволяет определять частоты моделирования глобально (через 
Project Options в окне просмотра проекта) или локально для каждой схемы и электромагнитной 
структуры. Для электромагнитной структуры часто лучше использовать локальные частоты с 
количеством частотных точек меньшим, чем для линейных схем. 

 
Просмотр ячеек сетки. 

Структура сетки очень важна для 
моделирования, т.к. она влияет на время и 
точность моделирования. Рекомендуется 
начинать с грубой сетки и затем делать её 
более мелкой до тех пор, пока результаты 
анализа не будут заметно изменяться при 
дальнейшем уменьшении ячеек сетки. 

Чтобы просмотреть ячейки сетки: 
1. Щёлкните правой кнопкой 

мышки по имени электромаг-
нитной структуры Interdigital 
Filter в окне просмотра про-
екта и выберите Add Annota-
tion. 

2. В открывшемся окне (рис. 
5.21) в списке Measurement 
отметьте EM_MESH, осталь-
ные параметры установите, 
как показано на рис. 5.21 и 
нажмите OK. 
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Рис. 5.21 



3. Структуру сетки можно просмотреть в 3-х мерном отображении 
электромагнитной структуры при виде сверху. Щёлкните мышкой по 

значку New Schematic 3D View  и затем по значку Top (Верх)  
на панели инструментов. Сетка будет отображена, как показано на рис. 
5.22. 

4. Щёлкнув правой кнопкой мышки по имени аннотации Interdigital 
Filter:EM_MESH в группе Annotations в окне просмотра проекта и 
выбрав Toggle Enable, можно отменить показ структуры сетки. 
Повторный вызов этой команды возобновляет показ структуры сетки. 

Рис. 5.22  
Выполнение электромагнитного моделирования. 

Электромагнитное моделирование  выполняется очень быстро для небольших электрических 
структур. Чтобы найти резонансную частоту первого резонатора фильтра, можно выполнить 
электромагнитное моделирование для одного резонатора стержневого фильтра. 

Чтобы выполнить моделирование структуры: 
1. Дважды щёлкните левой кнопкой 

мышки по подгруппе Information 
(Информация) стержневого 
фильтра (Interdigital Filter) в 
группе EM Structures. Откроется 
диалоговое окно Solver 
Information (Информация 
решающего устройства). В этом 
окне (рис. 5.23) на вкладке 
Summary отображается 
доступное (Available) и 
необходимое (Required) 
количество памяти на компьютере 
для моделирования и оценочное 
время анализа. Ознакомившись с 
этими данными, закройте окно, 
нажав OK. 

2. Выберите в меню 
Simulate>Analyze 

(Моделирование>Анализ) или 

щёлкните левой кнопкой мышки по значку Analyze  на панели инструментов. Откроется 
окно, в котором отображается процесс анализа. Когда это окно исчезает, анализ закончен. 

Рис. 5.23 

 
Отображение результатов на графике. 

Для определения резонансной частоты необходимо построить график коэффициента отражения 
в электромагнитной структуре. Чтобы сделать это: 

1. Выберите в меню Project>Add 
Graph (Добавить график), или щёлкните 
правой кнопкой мышки по группе Graphs 
в окне просмотра проекта и выберите Add 
Graph, или щёлкните левой кнопкой 

мышки по значку New Graph  на 
панели инструментов. Откроется 
диалоговое окно Create Graph (Создать 
график). 
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2. В поле Graph Name введите имя 
графика Filter Response, отметьте 
Rectangular (Прямоугольный) в области 
Graph Type (Тип графика) и нажмите OK. 
Окно графика откроется на рабочем поле. 

3. Выберите в меню Project>Add 
Measurement (Добавить измеряемую 
величину), или щёлкните правой кнопкой 
мышки по имени графика Filter Response 
в окне просмотра проекта и выберите Add 

Measurement, или щёлкните левой кнопкой мышки по значку Add Measurement  на 
панели инструментов. Откроется диалоговое окно Add Measurement (рис. 5.24). 

Рис. 5.24 



4. В окне списка Meas. Type раскройте 
группу Linear и выберите Port 
Parameters, выберите S в окне списка 
Measurement (Измеряемая величина), 
выберите Interdigital Filter в поле Data 
Source Name (Имя источника данных), в 
поля To Port Index и From Port Index 
введите 1, отметьте Mag и dB в области 
Complex Modifier (Представление 
комплексной величины) и нажмите Apply 
(Применить). 

5. Нажмите OK. 
6. Выберите в меню Simulate>Analyze или 

щёлкните левой кнопкой мышки по 
значку Analyze на панели инструментов. 
Результаты анализа отображаются на 
графике, как показано на рисунке 5.25. 

Чтобы определить резонансную частоту более 
точно, необходимо изменить частотный диапазон и шаг 
по частоте. Чтобы сделать это: 

Рис. 5.25 

7. Щёлкните правой кнопкой мышки 
объект Interdigital Filter в группе EM 
Structures и выберите Options. 
Откроется диалоговое окно Options. 

8. Нажмите панель Frequencies в верхней 
части этого окна. 

9. Введите 3 в поле Start, введите 5 в поле 
Stop и 0.1 в поле Step. Нажмите Apply. В 
окне списка Current Range будет 
отображён новый частотный диапазон с 
шагом, которые вы только что 
определили. 

Рис. 5.26 

10. Нажмите OK. 
11. Выберите Simulate > Analyze в выпадающем меню или щёлкните левой кнопкой мышки 

по значку Analyze  на панели инструментов, чтобы выполнить новый анализ схемы. 
Результаты анализа отображаются на графике, как показано на рисунке рис. 5.26. 

 
Просмотр анимации токов и Е – поля. 

Просмотр токов и полей электромагнитной структуры может быть полезен при изучении её 
физических характеристик. Токи и 
электрические поля добавлены к аннотации 
электромагнитных структур и могут быть 
просмотрены в 3-х мерном отображении 
структур. 

Чтобы просмотреть токи на 
проводниках: 

1. Щёлкните правой кнопкой мышки 
по имени электромагнитной 
структуры Interdigital Filter в окне 
просмотра проекта и выберите Add 
Annotation. 

2. В открывшемся окне (рис. 5.27) в 
списке Measurement отметьте 
EM_CURRENT, остальные 
параметры установите, как 
показано на рис. 5.27 и нажмите 
OK. 

3. Сделайте активным окно 
электромагнитной структуры и 
щёлкните мышкой по значку New 

Schematic 3D View  на панели 
инструментов. Рис. 5.27 
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4. Щёлкните мышкой по значку Animate Play  на панели ин-
струментов. Анимация токов в трёхмерном представлении 
будет отображена на рабочем поле (рис. 5.28). 

5. Щёлкните левой кнопкой мышки по значку Animate Stop  
на панели инструментов, чтобы остановить анимацию. 

6. Щёлкнув правой кнопкой мышки по имени аннотации Inter-
digital Filter:EM_CURRENT в группе Annotations в окне 
просмотра проекта и выбрав Toggle Enable, можно отменить 
показ токов. Повторный вызов этой команды возобновляет 
показ токов. 

 
Чтобы просмотреть электрическое поле: 

1. Щёлкните правой кнопкой мышки по имени электромагнит-
ной структуры Interdigital Filter в окне просмотра проекта и 
выберите Add Annotation. 

Рис. 5.28 

2. В открывшемся окне в списке Measurement от-
метьте EM_E_Filed и нажмите OK. 
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3. В окне просмотра проекта щёлкните правой кноп-
кой мышки по имени аннотации Interdigital 
Filter:EM_CURRENT в группе Annotations и 
выберите Toggle Enable. 

4. Выберите в меню Simulate>Analyze или щёлкни-
те левой кнопкой мышки по значку Analyze на 
панели инструментов, чтобы вычислить электри-
ческие поля. 

5. Выберите Animate > Animate Play в выпадающем 
меню или щёлкните левой кнопкой мышки по 
значку Animate Play на панели инструментов, 
чтобы просмотреть анимацию поля (рис. 5.29). 
Этот вид зависит от конфигурации вашего ком-

пьютера. 

Рис. 5.29 

6. Щёлкните левой кнопкой мышки по значку Animate Stop на панели инструментов, чтобы 
остановить анимацию. 

7. Чтобы прекратить вычисление и показ электрического поля, щёлкните правой кнопкой 
мышки по имени аннотации Interdigital Filter:EM_E_Filed в группе Annotations в окне 
просмотра проекта и выберите Toggle Enable. 

 
Завершение топологии фильтра. 

Чтобы завершить топологию фильтра, мы будем использовать некоторые усовершенствованные 
особенности редактирования в окне электромагнитной структуры. 

Чтобы добавить небольшой проводник на конце входного резонатора: 
1. Щёлкните по окну электромагнитной структуры Interdigital Filter, 

чтобы сделать его активным. 
2. Выберите в меню Draw>Rectangle (Чертить>Прямоугольник) или 

щёлкните левой кнопкой мышки по значку Rectangle на панели инструмен-
тов. 

3. Поместите курсор в окно Interdigital Filter и нажмите клавишу Tab 
на клавиатуре. Откроется диалоговое окно Enter Coordinates (Ввод коорди-
нат). 

4. Введите 2.2 в поле x, введите 2.4 в поле y и нажмите OK. 
5. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter 

Coordinates. Отметьте переключатель Rel, чтобы установить относительные 
координаты. Введите -0.4 в поле dx, dведите 0.2 в поле dy и нажмите OK. 

Прямоугольный проводник будет отображён  в окне электромагнитной структуры (рис. 5.30). 

Рис. 5.30 

 
Чтобы начертить выходной резонатор: 
 

6. Выберите в меню Edit>Select All (Редактировать>Выделить всё). Или установите курсор 
левее и выше топологии, нажмите левую кнопку мышки и переместите курсор правее и ниже 
топологии так, чтобы вся топология попала в образовавшийся прямоугольник. Отпустите 
кнопку мышки. 

7. Выберите в меню Edit>Copy (Редактировать>Копировать) или щёлкните по значку 
Copy на панели инструментов. Затем выберите в меню Edit>Paste (Редактировать>Вставить) 
или щёлкните по значку Paste на панели инструментов. Появится контур топологии. 



8. Переместите курсор в окно 
электромагнитной структуры, нажмите клавишу 
Ctrl и щёлкните правой кнопкой мышки. Будет 
создано зеркальное отображение скопированной 
топологии. Переместите созданную копию 
резонатора вправо так, чтобы правый край 
горизонтального проводника совпал с правым 
краем корпуса электромагнитной структуры (рис. 
5.31) 

 

 86

е в меню Edit>Copy, затем выберите Edit>Paste. 

 электромагнитной 

обы открыть окно Enter 

 галочку (если она есть) на переключателе Rel, чтобы 

 
Для завершения электромагнитной структуры, необходимо добавить 

порт к в
нику в окне электромагнитной 

рите в меню Draw>Add Edge Port или щёлкните левой кнопкой мышки по значку 

Чтобы создать средний резонатор: 
 

9. Установите курсор несколько выше верхнего 
левого угла входного резонатора, нажмите левую 
кнопку мышки и, не отпуская кнопки, переместите 

курсор к правому нижнему углу резонатора так, чтобы выделение 
охватило весь резонатор, отпустите кнопку мышки. Вертикальный 
проводник с межслойным переходом будет выбран (5.32). 

10. Выберит

Рис. 5.31 

Появится контур скопированного проводника. 
11. Двигайте курсор к середине окна

структуры, чтобы переместить скопированный образец в середину 
окна, затем дважды щёлкните правой кнопкой мышки, чтобы 
повернуть образец на 180 градусов. 

12. Нажмите клавишу Tab, Чт
Coordinates. 

13. Уберите
установить абсолютные координаты. Введите 6 в поле x, введите 5 в 
поле y и нажмите OK. Новая топология показана на рис. (5.33). 

Рис. 5.32 

ыходному проводнику. Чтобы добавить порт и установить референсную плоскость: 
14. Щёлкните левой кнопкой мышки по выходному провод

структуры. 
15. Выбе

Edge Port  на панели инструментов. 
16. Переместите курсор к правому краю проводника, пока не будет отображён квадрат, и 

ту 2. В его углах отобразятся четыре квадрата. 
й 

жмите левую кнопку мышки и, не отпуская кнопки, переместите курсор влево, пока 

щёлкните левой кнопкой мышки, чтобы зафиксировать порт. Небольшой квадрат  с цифрой 2 
будет отображён на правом краю проводника. 

17. Щёлкните левой кнопкой мышки по пор
18. Установите курсор на левый край порта так, чтобы он отображался в виде двойно

стрелки. 
19. На

dx и dy получат значения dx:-1.6, dy:0. Отпустите кнопку мышки, чтобы зафиксировать 
положение референсной плоскости. Законченная топология показана на рис. 5.34. 
 

Рис. 5.33 Рис. 5.34 



Улучшенная вариация частоты (AFS – Advanced Frequency Sweep). 
Решающее устройство EMSight может выполнять улучшенную вариацию частоты (AFS). Заметь-

те, что токи и электрические поля не вычисляются при выполнении AFS. 
Чтобы выполнить AFS: 

1. В окне просмотра проекта щёлкните 
правой кнопкой мышки по имени 
электромагнитной структуры Inter-
digital Filter и выберите Options. 
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2. На вкладке Frequencies открывшегося 
окна опций в поля Start, Stop и Step 
введите 3, 5 и 0.05 соответственно. 
Щёлкните мышкой по кнопке Apply, 
чтобы отобразить введённый диапазон 
в Current Range. 

3. Щёлкните мышкой по кнопке EMSight 
в верхней части окна, чтобы открыть 
эту вкладку (рис. 5.35). В области Ad-
vanced Freq Sweep в левой нижней 
части окна отметьте Enable AFS 
(Включить AFS). 

4. Нажмите OK. 
5. В окне просмотра проекта щёлкните 

правой кнопкой мышки по имени гра-
фика Filter Response и выберите Add 

Measurement. Откроется диалоговое окно Add Measurement (рис. 5.36). 

Рис. 5.35 

6. В окне списка Meas. Type раскройте группу Linear и выберите Port Parameters, выберите 
S в окне списка Measurement (Измеряемая величина), выберите Interdigital Filter в поле 
Data Source Name (Имя источника данных), введите 2 в поле To Port Index, введите 1 в по-
ле From Port Index, отметьте Mag и dB в области Complex Modifier (Представление ком-
плексной величины), нажмите Apply (Применить) и OK. 

Рис. 5.36 Рис. 5.37 

7. Сделайте активным окно графика и щёлкните мышкой по значку Analyze на панели инст-
рументов. Рассчитанный график показан на рис. 5.37. 

 
Добавление электромагнитной структуры в схему и моделирование. 

Вы можете добавить электромагнитную структуру в схему так 
же, как добавляется любая подсхема. 

1. Создайте новую схему, выбрав в меню Project>Add Sche-
matic>New Schematic или щёлкнув мышкой по значку New 

Schematic  на панели инструментов. В открывшемся 
окне введите имя схемы Schematic using EM и нажмите 
OK. 

2. Щёлкните мышкой по значку Subcircuit  на панели ин-
струментов или выберите в меню Draw>Add Subcircuit. 
Откроется диалоговое окно с перечнем всех имеющихся в 
проекте подсхем (рис. 5.38). 

Рис. 5.38 



3. Щёлкните мышкой по имени добавляемой подсхемы 
Interdigital Filter, чтобы выделить её, и нажмите OK. 
Или просто дважды щёлкните мышкой по имени до-
бавляемой подсхемы. 

4. Перемещая мышку, установите подсхему в окне схе-
мы и щёлкните левой кнопкой мышки, чтобы зафик-
сировать. 

5. Щёлкните мышкой по значку Port на панели инстру-
ментов и установите порт на входе схемы. Аналогич-
но установите порт на выходе схемы, предварительно 
два раза щёлкнув правой кнопкой мышки, чтобы раз-

вернуть порт на 180 градусов. Создан-
ная схема должна иметь вид, показан-
ный на рис. 5.39. 

Рис. 5.39 

6. Щёлкните правой кнопкой мышки по 
имени созданной схемы Schematic using 
EM в группе Circuit Schematics в левом 
окне просмотра проекта и выберите Op-
tions. 

7. На вкладке Frequencies открывшегося 
окна опций схемы снимите отметку в 
Use project defaults, в поле Start введи-
те 3, в поле Stop введите 5 и в поле Step 
введите 0.05. Щёлкните мышкой Apply 
и затем OK. 

8. Создайте прямоугольный график с име-
нем Filter Schematic. 
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 мышкой по значку Analyze 

ер моделиро-
вания эл

уры с на-
пылённ

оздание нового проекта. 
e>New Project (Файл>Новый проект). 

роект как). Откроется диалого-

жмите Сохранить. 
ons или дважды щёлкните мышкой по Project Op-

ype вве-

 

9. При активном окне вновь созданного 
графика щёлкните мышкой по значку 
Add Measurement на панели инстру-
ментов. В открывшемся окне введите 
такие же параметры, какие были вве-
дены при создании предыдущего гра-
фика рис. 5.36, только в поле Data 
Source Name введите Schematic using 
EM (рис. 5.40). Нажмите Apply и OK. 

10. Щёлкните

Рис. 5.40 

на панели инструментов. Рассчитан-
ный график показан на рис. 5.41. Он 
такой же, как и график электромаг-
нитной структуры. 

На этом заканчивается прим
ектромагнитной структуры. При желании 

вы можете сохранить проделанную вами работу, 
выбрав а меню File>Save Project. 
 Рис. 5.41 

5.2. Моделирование микрополоскового аттенюатора 
Этот пример показывает, как выполнить электромагнитное моделирование для структ
ыми резисторами. Здесь выполняется моделирование такой же структуры аттенюатора, которая 

использовалась для линейного моделирования в примере 2.3, чтобы можно было сравнить результаты 
линейного и электромагнитного моделирования. Однако размеры элементов топологии несколько изме-
нены (округлены) так, чтобы все размеры были кратны размерам ячеек сетки. 
 
С

1. Выберите в меню Fil
2. Выберите в меню File>Save Project As (Файл>Сохранить п

вое окно Save As. 
3. Наберите At20 и на
4. Выберите в меню Options>Project Opti

tions в левом окне просмотра проекта. Откроется диалоговое окно Project Options. 
5. На вкладке Global Units этого окна в поле Frequency введите GHz, в поле Length t

дите mm и нажмите OK. 



 89

оздание электромагнитной структуры. 

1. Щёлкните левой кнопкой мышки по значку New EM Structure 

С

 на панели инструмен-

 Atr20 в поле Enter a name for the EM 

bstrate Information на пане-

efs в области Dielectric Defini-

еские слои) для слоя 1 в колонке Thickness (Тол-

Boundary (нижняя граница) введите материал 1 oz Cu. 

тов. 
2. Наберите

Structure (Ввод имени для электромагнитной струк-
туры), отметьте AWR EMSight Simulator и нажмите 
Create. На рабочем поле откроется окно электромаг-
нитной структуры. 

3. Щёлкните по значку Su
ли инструментов. На вкладке Enclosure открывше-
гося окна в поле X_Dim введите 13.4, в поле Y_Dim 
введите 6.9, в поле Grid_X введите 0.1 и в поле 
Grid_Y введите 0.05. 

4. На вкладке Material DРис. 5.42 
tions для диэлектрического слоя Diel_1 введите 
Er=10.55, TanD=0.0001. Для области Conductor 
Definitions щёлкните мышкой по кнопке Add, чтобы 
добавить материал проводника. Откроется дополни-
тельное диалоговое окно Add Conductor (рис. 5.42). 
В поле Presets (Предварительные установки) введи-
те Aluminum, щёлкнув по кнопке в правом конце 
этого поля, и нажмите OK. Снова щёлкните мышкой 
по кнопке Add, в поле Presets введите Resist (рис. 
5.43) и нажмите OK. Вкладка Material Defs будет 
выглядеть, как показано на рис. 5.44. 

5. На вкладке Dielectric Layers (Диэлектрич

Рис. 5.43 

Рис. 5.44 

щина) введите 7, в колонке Material Definition введите Air (Воздух), щёлкнув левой кноп-
кой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 1. Для слоя 2 
в колонке Thickness введите 0.5, в колонке Material Definition введите Diel_1, щёлкнув ле-
вой кнопкой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 4, 
чтобы удобнее было просматривать трёхмерное отображение электромагнитной структуры. 
В поле Top Boundary (верхняя граница) введите материал Aluminum, в поле Bottom 
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ите 0.02, в столбце Material Defini-

й кнопкой мышки по значку Rectangle 

6. На вкладке Materials щёлкните мышкой по кнопке Insert. В столбце Name замените поя-
вившееся имя Trace1 на Alum, в столбце Thickness введ
tion введите Aluminum, щёлкнув мышкой по этому полю. Снова щёлкните мышкой по 
кнопке Insert. В столбце Name введите имя материала Res, в столбце Thickness введите 
0.0003, в столбце Material Definition введите Resist, щёлкнув мышкой по этому полю. 
Вкладка Materials будет выглядеть, как показано на рис. 5.45. 

7. Нажмите OK. 

 топологии. Создание
Рис. 5.45 

 на1. Щёлкните лево  панели инструментов или вы-
 Draw>Rectangle. 

Enter Coordinates (Ввод координат). 

oordinates. Устано-
ь относительные координаты. Вве-

берите в меню
2. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab на клавиа-

туре. Откроется диалоговое окно 
3. Введите 0 в поле x, введите 3.2 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter C

вите флажок в переключателе Rel, чтобы активизироват
дите 3 в поле dx, 0.5 в поле dy и нажмите OK. Проводник прямоугольного сечения отобра-
жается в окне электромагнитной структуры. 

5. Повторите пункты с 1-го по 4-ый, но введите 3 в поле x, 3.25 в поле y, 0.5 в поле dx и 0.4 в 
поле dy. 

6. Повторите пункты с 1-го по 4-ый, но введите 3.5 в поле x, 2.95 в поле y, 2 в поле dx и 1 в 
поле dy. 

7. Повторите пункты с 1-го по 4-ый, но введите 5.5 в поле x, 3.25 в поле y, 0.2 в поле dx и 0.4 в 
поле dy. 

8. Повторите пункты с 1-го по 4-ый, но введите 5.7 в поле x, 2.5 в поле y, 2 в поле dx и 1.9 в 
поле dy. 

9. Повторите пункты с 1-го по 4-ый, но введите 7.7 в поле x, 3.25 в поле y, 0.2 в поле dx и 0.4 в 
поле dy. 

10. Повторите пункты с 1-го по 4-ый, но введите 7.9 в поле x, 2.95 в поле y, 2 в поле dx и 1 в 
поле dy. 

11. Повторите пункты с 1-го по 4-ый, но введите 9.9 в поле x, 3.25 в поле y, 0.5 в поле dx и 0.4 в 
поле dy. 

12. Повторите пункты с 1-го по 4-ый, но введите 10.4 в поле x, 3.2 в поле y, 3 в поле dx и 0.5 в 
поле dy. 



Добавление портов и установка референсных плоскостей. 
1. Щёлкните левой кнопкой мышки по значку Zoom Area на панели инструментов и выделите 

левую часть входного проводника. 
2. Щёлкните левой кнопкой мышки по этому проводнику, чтобы выделить его. 
3. Щёлкните левой кнопкой мышки по значку Edge Port  на панели инструментов. 
4. Поместите курсор на левый край входного проводника, пока не отобразится квадрат, и 

щёлкните левой кнопкой мышки, чтобы зафиксировать порт. 
5. Щёлкните левой кнопкой мышки по порту 1. По углам отобразятся четыре квадрата. 
6. Установите курсор мышки на правый край порта так, чтобы курсор отображался в виде 

двойной стрелки. 
7. Нажмите левую кнопку мышки и не отпуская кнопки, перетащите курсор вправо, пока не 

будет отображено dx:1. Отпустите кнопку мышки, чтобы зафиксировать площадку. 
8. Щёлкните левой кнопкой мышки по значку Auto View на панели инструментов, чтобы ото-

бразить всю плату. 
9. Щёлкните левой кнопкой мышки по значку Zoom Area на панели инструментов и выделите 

правую часть выходного проводника. 
10. Щёлкните левой кнопкой мышки по значку Edge Port  на панели инструментов. 
11. Поместите курсор на правый край выходного проводника, пока не отобразится квадрат, и 

щёлкните левой кнопкой мышки, чтобы зафиксировать порт. 
12. Щёлкните левой кнопкой мышки по порту 2. По углам отобразятся четыре квадрата. 
13. Установите курсор мышки на левый край порта так, чтобы курсор отображался в виде 

двойной стрелки. 
14. Нажмите левую кнопку мышки и не отпуская кнопки мышки, перетащите курсор влево, по-

ка не будет отображено dx:-1. Отпустите кнопку мышки, чтобы зафиксировать площадку.  
15. Щёлкните левой кнопкой мышки по значку View All на панели инструментов, чтобы ото-

бразить всю плату. 
 
Назначение материала проводникам. 

1. Щёлкните левой кнопкой мышки по окну топологии, чтобы сделать его активным, если 
оно не активно. 

2. Нажмите клавишу 
Shift и щёлкните левой 
кнопкой мышки поочерёдно 
по всем проводникам (кро-
ме резисторов), чтобы вы-
делить их. Затем щёлкните 
по любому выделенному 
проводнику правой кнопкой 
мышки и выберите Shape 
Properties. (Свойства фор-
мы). Откроется окно Prop-
erties (рис. 5.46). 

3. В поле EM Layer 
введите 2, в поле Material 
введите 1/2oz Cu, щёлкая 
мышкой по кнопке в правом 
конце этих полей, отметьте 
Conductor и нажмите OK. 

4. Повторите пункты 2 
и 3 для всех резисторов то-
пологии аттенюатора, но в 
поле Material введите Res. 

Окончательный вид структу-
ры аттенюатора показан на рис. 5.47. 

Рис. 5.46 

Рис. 5.47 
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оздание выходных параметров и уравнений. 
 группе Output Equations (Выходные урав-

Выберите в меню Draw>Add Output Equation. Откроется диалоговое окно Measure-

 
Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для 

Снова выберите в меню Draw>Add Output Equation. В открывшемся окне в текстовом 

 
S21=atr20: |S(2,)]| 

 
Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для 

Выберите в меню Draw>Add Equation или щёлкните левой кнопкой мышки по значку 

уравнений. В этом окне появится поле ввода. Установите 

 поле вода уравнение: 
 

KstU=(1+S11)/(1-S11) 
 

и щёлкните левой кнопкой мышки вне этого поля или нажмите клавишу 
Ent

7. Снова щёлкните левой кнопкой мышки по значку Equation на 
панели инструментов и поместите новое поле ниже предыдущих 
уравнений. 

8. Введите в поле вода уравнение: 
 

Ldb=20*log10(1/S21) 
 

и щёлкните левой кнопкой е этого поля или нажмите клавишу Enter. Добав-
ленные уравнения будут выгляд казано на рис. 5.49. 

С
1. Дважды щёлкните левой кнопкой мышки по

нения) в окне просмотра проекта. На рабочем поле откроется окно уравнений Output Equa-
tions. 

2. 
ments (Измеряемые величины). В 
текстовом поле Variable name 
(Имя переменной) введите S11, в 
списке Meas. Type отметьте Port 
Parameters, в списке Measure-
ment отметьте S, в поле Data 
Source Name введите atr20, щёл-
кая по кнопке справа от этого по-
ля, введите 1 в оба поля To Port 
Index и From Port Index, щёлкая 
по кнопкам справа от этих полей, 
установите переключатель Mag в 
области Complex Modifier, сни-
мите галочку в переключателях 
Complex и dB, если они установ-
лены, нажмите OK (рис.5.48). В 
окне уравнений появится поле 
ввода с курсором в виде крести-
ка. Двигая мышку, установите 
это поле в верхней части окна 
уравнений и щёлкните левой 
кнопкой мышки. Появится выра-
жение 

S11=atr20: |S(1,1)| 

Рис. 5.48 

 

S11. 
3. 

поле Variable name введите S21, в списке Meas. Type отметьте Port Parameters, в списке 
Measurement отметьте S, в поле Data Source Name введите atr20, щёлкая по кнопке справа от 
этого поля, введите 2 в поля To Port Index и 1 в поле From Port Index, щёлкая по кнопкам 
справа от этих полей, установите переключатель Mag в области Complex Modifier, снимите 
галочку в переключателях Complex и dB, если они установлены, нажмите OK. В окне уравне-
ний появится поле ввода с курсором в виде крестика. Двигая мышку, установите это поле ниже 
предыдущего уравнения и щёлкните левой кнопкой мышки. Появится выражение 

S21. 
4. 

Equation на панели инструментов. 
5. Переместите курсор в окно 

его, двигая мышкой, ниже предыдущего уравнения и щёлкните левой кнопкой мышки, чтобы 
зафиксировать. 

6. Введите в

er. 

Рис. 5.49 

мышки вн
еть, как по



Определение частот для моделирования. 
1. Правой кнопкой мышки щёлкните по подгруппе atr20 в группе EM Structures и выбе-

рите Options во всплывающем меню. Откроется диалоговое окно Options. 
2. Щёлкните панель Frequencies (Частоты) в верхней части окна. 
3. Снимите галочку (если она стоит) на переключателе Use Project Frequency (Использо-

вать частоты проекта), чтобы локальные частоты имели преимущество перед глобальны-
ми частотами проекта. 

4. Установите GHz в поле Data Entry Units, щёлкая по стрелкам справа от этого поля. 
5. Введите 4 в поле Start (Начало), ведите 18 в поле Stop (Конец) и введите 1 в поле Step 

(Шаг). 
6. Нажмите Apply (Применить). В окне списка Current Range (Текущий диапазон) ото-

бражается частотный диапазон и частотные точки с шагом, которые вы только что опре-
делили. 

7. Нажмите OK. 
 
Создание графика, добавление измеряемых величин и анализ. 

1. Щёлкните по значку New Graph на панели инструментов. 
2. Введите имя графика, например, Graph 1 в поле Graph name (Имя графика), выберите 

Rectangular (Прямоугольный) в области Graph Type (Тип графика) и нажмите OK. 
3. Щёлкните правой кнопкой 

мышки по подгруппе Graph 1 
в окне просмотра проекта и 
выберите Add Measurement. 
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ается имя файла 

a File. В 

те по значку Analyze, чтобы со-

4. Выберите Output Equations в 
списке Meas. Type. В окне 
списка Equation Name выбе-
рите KstU, щёлкнув по кнопке 
справа. Отметьте переключа-
тель Mag в области Complex 
Modifier. Уберите галочку в 
окне dB, если она установлена. 
Нажмите Apply. 

5. В окне списка Equation Name 
выберите Ldb и нажмите Ap-
ply. 

6. Нажмите OK. 
7. Щёлкните левой кнопкой мышки по значку Analyze на панели инструментов. Результаты 

анализа отображаются на графике рис. 5.50. 

Рис. 5.50 

 
Вывод результатов в файл. 

1. Щёлкните правой кнопкой мышки по группе Output Files (Выходные файлы). 
2. Выберите Add Port Parameter File (Добавить файл параметра порта), откроется окно 

Output Data File (Выходной файл данных), показанное на рис. 5.51. 
3. Выберите S Parameter в области Data Type (Тип данных). В области Format выберите 

формат данных, сохраняемых в файле, на-
пример, Mag/Ang. 

4. В поле File Name отображ
по умолчанию, причём файл будет сохранён 
в той же папке, где находится проект, если 
нажать кнопку OK. Если вы хотите изме-
нить это имя или сохранить файл в другой 
папке, щёлкните по кнопке Set file name. В 
открывшемся окне укажите папку, где со-
хранить файл, и наберите имя файла или со-
гласитесь с предлагаемым по умолчанию. 
Нажмите Сохранить. Обратите внимание, 
что расширение файла должно быть s2p, где 
2 указывает на количество портов. 

5. Нажмите OK в окне Output Dat
группе Output Files появится имя сохра-
няемого файла, но на диске файл ещё не со-
хранён. 

6. Щёлкни
хранить файл на диске. Рис. 5.51 



Экспорт топологии в DXF файл. 
При создании топологии в электромагнитной структуре мы использовали материалы 1/2oz Cu и 

Res. Этим материалам не назначено слоёв для черчения и для них нет таблиц соответствия слоёв. В этом 
случае Microwave Office для таких материалов автоматически создаёт слои черчения. В нашем случае 
были созданы слои черчения с именами +LAY_2_1/2oz Cu_COND (что можно расшифровать как слой 
черчения на 2-м слое диэлектрика, материал 1/2oz Cu, проводник), и +LAY_2_Res_COND (см. рис. 5.46). 
Но lpf файл автоматически не редактируется и новый не создаётся. Таблицы соответствия для этих слоёв 
также не создаются. Поэтому, если просто экспортировать топологию в dxf файл, щёлкнув правой кноп-
кой мышки по имени электромагнитной структуры в окне просмотра проекта и выбрать Export EM Lay-
out (как это делалось в прежних версиях), то dxf файл будет создан. Но AutoCAD прочесть его не сможет 
и выдаст сообщение, что в файле имеется строка с недопустимым именем слоя (однако прежние версии 
Microwave Office этот файл воспринимают). Тем не менее, экспорт топологии можно выполнить, не из-
меняя lpf файл и не создавая таблиц соответствия, действуя следующим образом. 

Пользуясь тем, что dxf файл не содержит никакой информации о материале топологических эле-
ментов (по существу, это просто таблица координат), мы для экспорта топологии можем назначить всем 
топологическим элементам слой черчения, который уже имеется в lpf файле. В файле default.lpf таким 
слоем является слой с именем Copper и с назначенным материалом Perfect Conductor, для которого име-
ются все необходимые таблицы соответствия. Этот слой черчения и будем использовать. Однако если 
просто переназначить слой черчения в уже существующей электромагнитной структуре, то автоматиче-
ски будет изменён материал слоя и будут потеряны результаты анализа. Чтобы этого не произошло, сде-
лаем копию электромагнитной структуры. 

1. Установите курсор на имя электромагнитной структуры Atr20 в левом окне просмотра про-
екта, нажмите левую кнопку мышки и, не отпуская кнопки, переместите курсор на группу 
EM Structures, отпустите кнопку. На рабочем поле будет создана копия электромагнитной 

структуры с именем Copy of At20. 
2. Установите курсор на это имя, щёлкните 

правой кнопкой мышки и выберите Re-
name EM Structure (Переименовать элек-
тромагнитную структуру). Переименуйте 
скопированную структуру в At20_EM. 

3. Снова щёлкните правой кнопкой мышки по 
имени скопированной структуры и выбери-
те Toggle Enable (Переключатель блоки-
ровки), чтобы запретить выполнять анализ 
этой структуры. 

4. В окне скопированной структуры устано-
вите курсор левее и выше топологии, на-
жмите левую кнопку мышки и переместите 
курсор правее и ниже топологии, чтобы 
выделить все элементы топологии. 

5. Установите курсор мышки на любой выде-

ленный элемент топологии, 
щёлкните правой кнопкой 
мышки и выберите Shape 
Properties. В поле Drawing 
Layer открывшегося окна 
введите Copper, щелкнув по 
кнопке в конце этого поля 
(рис. 5.52). Нажмите OK. 

Рис. 5.52 

6. Щёлкните правой кнопкой 
по имени скопированной 
электромагнитной структу-
ры и выберите Export EM 
Layout. В открывшемся ок-
не установите тип файла 
DXF(DXF Flat, *.dxf) и на-
жмите Сохранить (рис. 
5.53). 

Топология, загруженная в Auto-
CAD из созданного dxf файла, будет вы-
глядеть, как показано на рис. 5.54. Обра-
тите внимание, что в экспортированной 
топологии отброшены отрезки входного 
и выходного проводников от края корпу- 

Рис. 5.53 
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тной 
структу

р

 и положением рефе-

 
платы, э

ленного 
прямоуг

ки. Затем пе-
редвига

ght введите высоту шрифта 0.6 мм и нажмите OK. Выберите в меню 
Draw>T

кнув по реперному знаку или тексту левой кноп-
кой мы

к показано на рис. 5.57. 

са до положения референсных плоскостей. Это хорошо видно, если экспортировать не только 
одну топологию проводников, но и саму плату. Для этого на всю плату нужно также нанести 

слой черчения Copper. 
Щёлкните левой кнопкой мышки 

по значку Rectangle на панели инструмен-
тов. Установите курсор мышки на верхний 
левый угол корпуса электромагни

ры, нажмите левую кнопку мышки 
и переместите курсор на правый нижний 

угол корпуса, отпустите кнопку. Весь пря-
моугольник ко пуса будет выделен. Щёлк-
ните по выделенному прямоугольнику пра-
вой кнопкой мышки, выберите Shape Prop-
erties и в открывшемся окне установите 
Copper в поле Drawing Layer, нажмите OK. 
Выполните экспорт, как описано выше. Те-
перь топология, загруженная в AutoCAD, 
будет выглядеть, как показано на рис. 5.55. 
Здесь хорошо видно, что отрезки линий ме-
жду краями корпуса и референсными плос-
костями удалены при экспорте топологии. 

При моделировании электромагнитной структуры рассчитываются характеристики 
между референсными плоскостями. Отрезки линий между краем корпуса

Рис. 5.54 

Рис. 5.55 

ренсной плоскости решающим устройством исключаются из анализа (так называемая процеду-
ра de-embedding – исключение). Если на реальной плате подводящие отрезки линий согласова-
ны с созданной топологией структуры, то длина подводящих отрезков особого значения не 
имеет. Но в некоторых случаях, например, если подводящие отрезки в моделируемой структу-
ре являются частью трансформатора сопротивлений, их длина в реальной топологии должна 
бать равна расчётной длине, т.е. указанные выше отрезки до референсных плоскостей должны 
быть удалены. Как видно из приведённого примера, Microwave Office делает это автоматически 
при экспорте топологии электромагнитной структуры (в более ранних версиях этого не было). 

Учитывая это, слой черчения для платы можно наносить только между референсными 
плоскостями. Если желательно, чтобы проводники начинались с некоторым отступом от края

тот слой должен несколько выступать за положение референсных плоскостей. 
Дважды щёлкните мышкой по электромагнитной структуре вне топологических эле-

ментов аттенюатора. Установите курсор на ромбик посередине левой стороны выде
ольника, нажмите левую кнопку мышки и сдвиньте эту сторону вправо, не доводя её 

до референсной плоскости, например, на 0.2 мм. Аналогично сдвиньте правую сторону прямо-
угольника на такое же расстояние влево. На созданном прямоугольнике можно нанести допол-
нительные топологические элементы, например, реперные знаки и строки текста. 

Щёлкните мышкой по значку Polygon на панели инструментов. Установите курсор на 
левый верхний угол созданного прямоугольника и щёлкните левой кнопкой мыш

йте курсор, щёлкая мышкой после каждого перемещения на 0.6 вправо, на 0.2 вниз, на 
0.4 влево, на 0.4 вниз, на 0.2 влево и здесь дважды щёлкните левой кнопкой мышки. Щёлкните 
по значку Copy на панели инструментов. Щёлкая мышкой по значку Paste на панели инстру-
ментов и затем, щёлкая правой кнопкой мышки, чтобы развернуть скопированный реперный 
знак соответствующим образом, установите репернные знаки на остальных углах созданного 
прямоугольника. 

Выберите в меню Options>Layout Options и на вкладке Layout Font открывшегося 
окна в поле Hei

ext, переместите курсор на то место в электромагнитной структуре, где должен быть 
текст, и щёлкните мышкой. В образовавшееся поле введите нужный текст, например, Атте-
нюатор, щёлкните мышкой вне поля текста. 

По умолчанию вновь создаваемым топологическим элементам и для текста назначает-
ся слой черчения Copper. Проверьте это, щёл

шки и затем правой кнопкой и выбрав Shape Properties. В противно случае назначте 
этот слой вручную, предварительно нажав клавишу Shift и щёлкая мышкой по реперным зна-
кам и тексту, чтобы выделить их. Электромагнитная структура будет выглядеть, как показано 
на рис. 5.56. 

Выполните экспорт созданной электромагнитной структуры. В AutoCAD она будет 
выглядеть, ка
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Другой способ экспорта электромагнитных структур при установках по умолчанию 
будет рассмотрен в следующем примере. 

Рис. 5.57 Рис. 5.56 

 

5.3 Моделирование микрополоскового двухсекционного 
делителя мощности. 

Создайте новый проект и сохраните его, присвоив имя Divider, как описано в примере 5.2. 
Создайте электромагнитную структуру, как описано в примере 5.2, присвоив ей имя Div. 
На вкладке Enclosure окна свойств электромагнитной структуры в поле X_Dim введите 10, в по-

ле Y_Dim введите 5.1, в поле Grid_X введите 0.1 и в поле Grid_Y введите 0.05. 
На вкладке Material Defs для области Conductor Definitions, щёлкая мышкой по кнопке Add, 

добавьте материалы проводника Aluminum и Resist, как описано в примере 5.2. 
На вкладке Materials щёлкните мышкой по кнопке Insert. В столбце Name замените появившее-

ся имя Trace1 на Alum, в столбце Thickness введите 0.02, в столбце Material Definition введите Alumi-
num, щёлкнув мышкой по этому полю. Снова щёлкните мышкой по кнопке Insert. В столбце Name вве-
дите имя материала Res, в столбце Thickness введите 0.00025, в столбце Material Definition введите Re-
sist, щёлкнув мышкой по этому полю. 

Все остальные параметры на всех вкладках окна свойств электромагнитной структуры введите 
такие же, как и в в примере 5.2. 
 
Создание топологии входного проводника. 

1. Щёлкните левой кнопкой мышки по значку Zoom Area и выделите среднюю часть пла-
ты возле левого края так, чтобы хорошо была видна сетка. Это облегчит рисование. 

2. Выберите в меню Draw>Polygon (Чертить>Многоугольник) или щёлкните левой кноп-
кой мышки по значку Polygon  на панели инструментов. 

3. Переместите курсор в окно электромагнитной структуры, поместите его на левый край 
корпуса примерно в центре по ширине корпуса и щёлкните левой кнопкой мышки, чтобы за-
фиксировать начало рисунка топологии. 

4. Не нажимая кнопки мышки, двигайте курсор вправо так, чтобы было отображено dx:2, 
dy:0. Щёлкните левой кнопкой мышки, чтобы зафиксировать эту точку. 

5. Нажмите клавишу Tab, в открывшемся окне в поле dx введите 0.3, в поде dy введите 
0.15, нажмите OK. 

6. Продолжайте аналогично: 
o двигайте курсор вправо, пока будет dx:0.1 dy:0; 
o двигайте курсор вниз, пока будет dx:0 dy:-0.15; 
o двигайте курсор влево, пока будет dx:-0.1 dy:0; 
o нажмите клавишу Tab, в открывшемся окне в поле dx введите -0.4, в поде dy введите 

-0.25, нажмите OK; 
o нажмите клавишу Tab, в открывшемся  окне в поле dx введите 0.4, в поде dy введите 

-0.25, нажмите OK; 
o двигайте курсор вправо, пока будет dx:0.1 dy:0; 
o двигайте курсор вниз, пока будет dx:0 dy:-0.15; 
o двигайте курсор влево, пока будет dx:-0.1 dy:0; 
o нажмите клавишу Tab, в открывшемся окне в поле dx введите -0.3, в поде dy введите 

0.15, нажмите OK; 
o двигайте курсор влево, пока будет dx:-2 dy:0 и здесь дважды щёлкните левой кноп-

кой мышки; чтобы замкнуть контур. 
7. Щёлкните левой кнопкой мышки по входному проводнику, чтобы его выделить, если он 

не выделен. 



8. Щёлкните по значку Measure на панели инструментов, измерьте расстояния от верхнего 
края проводника до верхнего края корпуса и от нижнего края проводника до нижнего края 

корпуса. Эти расстояния должны быть одинако-
выми. В противном случае поместите курсор на 
созданный проводник, нажмите левую кнопку 
мышки и, двигая проводник, поместите его сим-
метрично относительно стенок корпуса. 

 
Полученная топология входного проводника показана на 
рис. 5.58. Рис. 5.58 
 

Примечание. Если дважды щёлкнуть левой кнопкой по проводнику, в срединах ограничи-
вающих проводник линиях и в углах появятся тёмно-синие точки. Поместив курсор на такую 
точку так, чтобы он отображался в виде двойной стрелки, можно, нажав левую кнопку мышки, 
двигать линию или угол топологии и, таким образом, редактировать топологию. 

 
Создание топологии проводников плеч делителя. 

1. Щёлкните левой кнопкой мышки по значку Rectangle  на панели инструментов. 
2. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab на кла-

виатуре. Откроется диалоговое окно Enter Coordinates. 
3. Введите 2.4 в поле x, введите 2.95 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter Coordinates. Уста-

новите флажок в переключателе Rel, чтобы активизировать относительные координаты. 
Введите 2.2 в поле dx, и -0.15 в поле dy и нажмите OK. 
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структуры и подключите скопированный проводн

.6 в поле x, вве-

 выделен, щёлкни-

 
оздание топологии выходных проводников. 

у Auto View на панели инструментов, чтобы 

ой мышки по значку Zoom Area на панели инструментов и выде-

b на кла-

и 

ой кнопкой мышки по значку Polygon на панели инструментов. 
, щёлкните 

 

5. Выделите созданный проводник, если он не выделен, щёлкните по значку Copy и затем 
по значку Paste на панели инструментов. Переместите курсор в поле электромагнитной 

ик к нижнему плечу делителя. 
6. Повторите пункты с 1-го по 4-

ый, но введите 4
дите 2.8 в поле y, 2.7 в поле dx, 
0.3 в поле dy. 

7. Выделите созданный провод-
ник, если он не

Рис. 5.59 

те по значку Copy и затем по значку Paste на панели инструментов. Переместите курсор в 
поле электромагнитной структуры и подключите скопированный проводник к нижнему 
плечу делителя. Должна получиться топология, показанная на рис. 5.59. 

С
1. Щёлкните левой кнопкой мышки по значк

отобразить всю плату. 
2. Щёлкните левой кнопк

лите правую часть обоих последних проводников делителя так, чтобы была видна сетка. 
3. Щёлкните левой кнопкой мышки по значку Rectangle на панели инструментов. 
4. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Ta

виатуре. Введите 7.3 в поле x, введите 3.1 в поле y и нажмите OK. Нажмите клавишу Tab 
снова. Установите флажок в переключа-
теле Rel, чтобы активизировать относи-
тельные координаты. Введите 0.5 в поле 
dx, и 2 в поле dy и нажмите OK. 

5. Выделите созданный проводник, если он 
не выделен, щёлкните по значку Copy 
затем по значку Paste на панели инстру-
ментов. Переместите курсор в поле элек-
тромагнитной структуры и подключите 
скопированный проводник к правому 
нижнему углу нижнего проводника дели-
теля. Должна получиться топология, по-

казанная на рис. 5.60. 
6. Щёлкните лев

Рис. 5.60 

7. Поместите курсор на правый нижний угол верхнего выходного проводника
левой кнопкой мышки, переместите курсор на 0.5 мм влево, щёлкните левой кнопкой 
мышки, переместите курсор на 0.3 мм вниз и дважды щёлкните левой кнопкой мышки. 



8. Выделите созданный треугольник, если он не выделен. Выберите в меню Edit>Mirror, 
поместите курсор на выделенный прямоугольник, нажмите левую кнопку мышки и вра-
щайте мышкой созданную копию, пока не получите зеркальное отображение треугольни-

ка для соединения нижних проводников и 
щёлкните левой кнопкой мышки. Затем помес-
тите созданный треугольник так, чтобы соеди-
нить нижние проводники, как показано на рис. 
5.61. 

9. Выделите всю созданную топологию. Для это-
го установите курсор левее и выше созданной 
электромагнитной структуры, нажмите левую 
кнопку мышки и переместите курсор правее и 
ниже электромагнитной структуры так, чтобы 
вся топология попала в образовавшийся пря-

моугольник. Или выберите в меню Edit>Select All. 

Рис. 5.61 

10. Щёлкните правой кнопкой мышки по любому выделенному проводнику и выберите 
Shape Properties. В открывшемся окне в поле Material введите 1/2oz Cu и нажмите OK. 

 
Создание топологии резисторов. 

1. Щёлкните левой кнопкой мышки по значку Rectangle на панели инструментов. 
2. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab на клавиа-

туре. Откроется диалоговое окно Enter Coordinates. 
3. Введите 4.5 в поле x, введите 2.1 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова. Установите флажок в переключателе Rel, введите 0.3 в поле 

dx, 0.9 в поле dy и нажмите OK. 
5. Повторите пункты с 1-го по 4-ый, но введите 7.2 в поле x, введите 2.1 в поле y, 0.1 в поле 

dx, 0.9 в поле dy. 
6. Нажмите клавишу Shift и щёлкните левой кнопкой мышки поочерёдно по обоим резисто-

рам, чтобы выделить их. Щёлкните правой кнопкой мышки по любому выделенному рези-
стору и выберите Shape Properties. В открывшемся окне в поле Material введите Res и на-
жмите OK. 

 
Добавление портов и установка референсных плоскостей. 

Добавьте порты к входному проводнику, и 
затем к верхнему и нижнему выходным проводни-
кам, как описано в примере 5.2 и сдвиньте их ре-
ференсные плоскости на 1 мм внутрь электромаг-
нитной структуры. Должна получиться топология, 
показанная на рис. 5.62. 
 
Определение частот для моделирова-
ния. 
 

Рис. 5.62 Определите частоты для моделирования, 
как описано в примере 5.2, но введите 4 в поле 
Start, 18 в поле Stop и 1 в поле Step. 

 
Создание графика и добавление измеряемых величин. 

Создайте график Graph 1 и добавьте к нему измеряемые величины, как описано в примере 5.2. В 
окне Add Measurement выберите Port Pa-
rameter в списке Meas. Type, S в списке 
Measurement, Div в поле Data Source Name, 
2 в поле To Port Index, 1 в поле From Port 
Index, отметьте dB и Mag, нажмите Apply. 
Затем выберите 3 в поле To Port Index и на-
жмите Apply. Нажмите OK. 
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Анализ делителя. 

1. Щёлкните левой кнопкой 
мышки по значку Analyze на панели 
инструментов. Результаты анализа 
отображаются на графике рис. 5.63. 

Рис. 5.63 



Создание второго графика и добавление измеряемых величин. 
Создайте график Graph 2 и добавьте к нему 

следующую измеряемую величину. В окне Add Meas-
urement выберите Port Parameter в списке Meas. Type, 
S в списке Measurement, Del в поле Data Source Name, 
3 в поле To Port Index, 2 в поле From Port Index, от-
метьте DB и Mag, нажмите Apply. Нажмите OK. 
 
Анализ делителя. 
 

1. Щёлкните левой кнопкой мышки по 
значку Analyze на панели инструментов. Ре-
зультаты анализа отображаются на графике 
рис. 5.64. Рис. 5.64  

Создание выходных параметров и уравнений. 
1. Дважды щёлкните левой кнопкой мышки по группе Output Equations в окне просмотра 

проекта. Откроется окно Output Equations. 
2. Щёлкните левой кнопкой мышки по значку Output Equation на панели инструментов. 

Откроется диалоговое окно Measurements (Измеряемые величины). В текстовом поле 
Variable name (Имя переменной) введите S11, в списке Meas. Type отметьте Port Pa-
rameters, в списке Measurement отметьте S, в поле Data Source Name введите div, щёл-
кая по кнопке справа от этого поля, введите 1 в оба поля To Port Index и From Port In-
dex, щёлкая по кнопкам справа от этих полей, установите переключатель Mag в области 
Complex Modifier, снимите галочку в переключателях Complex и dB, если они установ-
лены, щёлкните OK. В окне уравнений появится поле ввода с курсором в виде крестика. 
Двигая мышку, установите это поле в верхней части окна уравнений и щёлкните левой 
кнопкой мышки. Появится выражение S11=div: |S[1,1]|  

3. Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выраже-
ния для S11. 

4. Аналогично создайте переменные S22=div: |S[2,2]| и S33=div: |S[3,3]|. 
5. Выберите в меню Draw>Add Equation или щёлкните левой 

кнопкой мышки по значку Equation на панели инструментов. 
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3. Щёлкните левой кнопкой мышки 

pe. В окне списка Equation Name вы-

кнопкой мышки по 
анели инструментов. Ре-

6. Переместите курсор в окно уравнений. В этом окне появится 
поле ввода. Установите его, двигая мышкой, ниже предыдущего 
уравнения и щёлкните левой кнопкой мышки, чтобы зафикси-
ровать. 

7. Введите в поле вода уравнение: KstU1=(1+S11)/(1-S11) и щёлк-
ните левой кнопкой мышки вне этого поля или нажмите клави-
шу Enter. 

8. Аналогично добавьте уравнения KstU2=(1+S22)/(1-S22) и 
KstU3=(1+S33)/(1-S33). Созданные уравнения будут выглядеть, 

как показано на рис. 5.65. 

Рис. 5.65 

 
Создание третьего графика, добавление измеряемых величин и анализ. 

1. Щёлкните по значку New Graph на панели инструментов. 
2. Введите имя графика, например, Graph 3 в поле Graph name, выберите Rectangular  в 

области Graph Type и нажмите OK. 
по значку Add Measurement на панели инструментов. 

4. Выберите Output Equations в списке 
Meas. Ty
берите KstU1, щёлкнув по кнопке справа. От-
метьте переключатель Mag в области Complex 
Modifier. Уберите галочку в окне dB, если она 
установлена. Нажмите Apply. 

5. В окне списка Equation Name выберите 
KstU2. Нажмите Apply. 

6. В окне списка Equation Name выберите 
KstU3. Нажмите Apply. 

7. Нажмите OK. 
8. Щёлкните левой 

значку Analyze на п
зультаты анализа отображаются на графике 
рис. 5.66. 

Рис. 5.66 



Экспорт топологии в DXF файл. 
В предыдущем примере экспорт топологии выполнялся после предварительного создания копии 

электромагнитной структуры. Другим вариантом экспорта топологии при установках по умолчанию мо-
жет быть предварительное копирование не в другую электромагнитную структуру, а в окно топологии 
схемы. 

1. Щёлкните мышкой по значку New Schematic и создайте схему с именем Div_Schematic. 
Откроется пустое окно схемы. 

2. Щёлкните мышкой по значку New Schematic Layout View на панели инструментов. Откро-
ется пустое окно топологии схемы. 

3. В поле Grid Spacing на панели инструментов введите множитель 0.5, чтобы размер ячеек 
сетки сделать равным 0.05 мм. 

4. Создайте прямоугольник со сторонами, равными сторонам корпуса электромагнитной 
структуры. Для этого щёлкните мышкой по значку Rectangle на панели инструментов. По-
метите курсор в окно топологии схемы и нажмите клавишу Tab. В открывшемся окне в по-
ля x и y ведите 0, нажмите OK и затем клавишу Tab. В открывшемся окне в поле dx введи-

те 10, в поле dy введите 5.1, 
нажмите OK. 

5. Сделайте активным окно 
электромагнитной структу-
ры, выделите всю тополо-
гию и щёлкните по значку 
Copy на панели инструмен-
тов. Сделайте активным 
окно топологии схемы и 
щёлкните по значку Paste 
на панели инструментов. 
Вставьте скопированную 
топологию в созданный 
прямоугольник. Должна 
получиться топология, по-
казанная на рис. 5.67. 

Рис. 5.67 

6. По умолчанию слой чер-
чения для всех элементов 
топологии при копирова-
нии назначен с именем Er-
ror. Установите курсор ле-
вее и выше прямоугольни-
ка топологии, нажмите ле-
вую кнопку мышки и пе-
реместите курсор правее и 
ниже прямоугольника, 
чтобы выделить всю топо-
логию. Щёлкните правой 

кнопкой мышки и выберите Shape Properties. В открывшемся окне в поле Draw Layers 
введите Copper и нажмите OK. 

Рис. 5.68 

7. Выберите в меню Layout>Export. В открывшемся окне установите тип файла DXF(DXF 
Flat, *.dxf) и нажмите Сохранить. 

В AutoCAD топология из созданного DXF файла будет выглядеть, как показано на рис. 5.68. 
В этом примере в окне редактора топологии схемы вначале создавался прямоугольник, покры-

тый слоем черчения, чтобы записать в DXF файл размеры платы. На этом слое вы можете в редакторе 
топологии схемы добавить различные дополнительные топологические элементы, как описано в преды-
дущем примере. Если нужно записать в DXF файл только топологию делителя, заполненного прямо-
угольника создавать не нужно. 

Заметим, что при экспорте топологии вместе с размерами платы подобным образом, нельзя 
включать опцию топологии Union layout shapes (Объединить формы топологии) на вкладке Export/LPF 
открывающегося окна при выборе в меню Options>Layout Options. Если эту опцию включить, при экс-
порте будут объединены проводники делителя со слоем, покрывающим плату, и в AutoCAD будет ото-
бражён только пустой прямоугольник. Эту опцию можно включить, если экспортируется только тополо-
гия делителя. Если желательно объединить проводники делителя, лучше это сделать в редакторе тополо-
гии схемы до экспорта топологии. Нажмите клавишу Shift и, щёлкая мышкой по проводникам делителя 
(кроме резистора), выделите их. Выберите в меню Draw>Modify Shapes>Union или щёлкните по значку 
Union  на панели инструментов и затем выполните экспорт. 

Обратите внимание, что при этом способе экспорта топологии удаление отрезков линии между 
краем корпуса и референсной плоскостью не делается. 
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Импор
тировать топологию непосредственно в электро-

нужно импортировать в редактор топологического чертежа 
Artwork

еню File>New Project и сохраните его под именем Di-

Layer Setup и 

ort LPF. В открывшемся 

Cell Libraries и выберите Import DXF 

импорта найдите 

и элементов 

кая-то их 

ля, чтобы выделить этот 

т топологии из DXF файла. 
В 7-ой версии Microwave Office нельзя импор

магнитную структуру. Сначала топологию 
 Editor, затем копировать и вставлять в редактор электромагнитной структуры. Т.к. импортируе-

мый файл не содержит информации, необходимой для моделирования электромагнитной структуры (но-
мера слоя модели, материала и т.д.), программе нужно указать, как обрабатывать каждую топологиче-
скую форму. В этом примере рассмотрим метод импорта, который можно применить для простой струк-
туры, имеющей только один или немного слоёв. 

Т.к. в каталоге AWR нет DXF файлов, будем использовать файл, созданный в этом примере. 
1. Создайте новый проект, выбрав в м

vider-Import, выбрав в меню File>Save Project As. 
2. Откройте менеджер топо-

логии, щёлкнув мышкой о 
панели Layout в левом 
нижнем углу окна проекта. 

3. Щелкните правой кнопкой 
мышки по 
выберите Import Process 
Definition или выберите в 
меню Project>Process Li-

brary>Imp

Рис. 5.69 

Рис. 5.70 

окне импорта найдите файл Blank.lpf 
(находится в корневом каталоге про-
граммы) и откройте его. В открывшем-
ся окне предупреждения (рис. 5.69) 
нажмите Да. 

4. Щелкните правой кнопкой мышки по 

Library. 
5. В открывшемся окне 

файл, который нужно импорти-
ровать (в нашем случае это бу-
дет Div_Schematic) и откройте 
его. Откроется окно с запросом, 
какие единицы измерения ис-
пользуются в файле (рис. 5.70). 
Введите mm и нажмите OK. 
Откроется следующее окно, в 
котором сообщается, какие слои 
будут созданы автоматически 
(рис. 5.71), нажмите OK. В окне 
менеджера топологии появится 
имя библиотек

Рис. 5.71 

Div_Schematic (с указанием пу-
ти к DXF файлу) и в этой биб-
лиотеке будет ячейка с таким же 
именем. 

6. Щёлкните правой кнопкой 
мышки по имени ячейки в окне 
менеджера топологии и выбери-
те Flatten Layout Cell (Сгладить 
ячейку топологии). 

7. Дважды щёлкните мышкой по 
имени ячейки в появившейся 
библиотеке элементов. Т.к. наша 
плата покрыта слоем черчения, 
то проводники или ка

Рис. 5.72 

часть может быть скрыта этим 
слоем и не видна (рис. 5.72). 
Щёлкните по слою покрытия в 
месте, где нет проводников де-
лите
слой, и нажмите клавишу Delete, 

чтобы удалить слой, покрывающий плату (рис. 5.73). 

Рис. 5.73 
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ect Options. 

 и затем щёлкните по 

 New EM Structure на панели 

z Cu, в поле 

 по кнопке Add для импеданса. В поле 

толщиной 1е-6 и с материалом 
Omega Ply. Аналогично вставьте 
материалы с именем 1 oz Cu тол-
щиной 0.03556 и с материалом 1 oz 
Cu; с именем 1/2 oz Cu толщиной 
0.01778 с материалом 1 oz Cu; с 
именем Alum толщиной 0.02 с ма-
териалом Aluminum; с именем Res 
толщиной 0.00025 с материалом Re-
sist. Т.е. мы добавили все параметры 
для электромагнитной структуры, 

рые были определены в ориги-
й структуре Div, описанной 

ы. 

начьте матери-
ал 1/2 oz Cu. Аналогично резисторам назначьте материал Res. Установите порты. 

Откройте окно просмотра проекта, щёлкнув мышкой по панели Project в левой нижней части 
экрана. 

чно простых структур. Но для многослойных структур с большим количеством тополо-
гически элементов этот метод может быть более предпочтительным. Здесь мы рассмотрим только саму 

8. Выберите в меню Options>Project Options или дважды щёлкните мышкой по Project Op-
tions в левом окне просмотра проекта. Откроется диалоговое окно Proj

9. На вкладке Global Units этого окна в поле Frequency введите GHz, в поле Length type вве-
дите mm и нажмите OK. 

10. Выберите в меню Edit>Select All, чтобы выделить всю топологию
значку Copy на панели инструментов, чтобы ско-
пировать топологию. 

11. Щёлкните по значку
инструментов и создайте электромагнитную струк-
туру с именем Div_EM. 

12. Щёлкните по знаку Substrate Information на пане-
ли инструментов. 

13. В открывшемся окне свойств на вкладке Enclosure 
введите X_Dim=10, Y_Dim=5.1, Grid_X=0.1 и 
Grid_Y=0.05. 

14. На вкладке Material Defs щёлкните по кнопке Add 
для диэлектрического слоя и в открывшемся окне 
(рис. 5.74) в поле Name введите Del_1, в поле Er 
введите 10.55, в поле TanD введите 0.0001 и на-
жмите OK. Щёлкните по кнопке Add для слоя 
проводника. В поле Name введите 1 o

Рис. 5.74 

Conductivity(S/m) введите 5.88е7 и нажмите OK 
(рис. 5.75). Аналогично добавьте материалы про-
водников с именем Aluminum и проводимостью 
3.78е7, с именем Resist и проводимостью 6.7е4. 
Щёлкните
Name введите Omega Ply, в поле Low frequency 
resistance введите 50 и нажмите OK. 

15. На вкладке Dielectric Layers для слоя 1 введите 
толщину 7, материал диэлектрика Air и масштаб отображения 1. Для слоя 2 введите толщи-
ну 0.5, материал диэлектрика Diel_1 и масштаб отображения 4. 

16. На вкладке Materials щёлкните по кнопке Insert и вставьте материал с именем Omega Ply 

Рис. 5.75 

кото
нально

Рис. 5.76 

выше в этом примере. Но это не обязательно, необходимо ввести только используемые ма-
териал

17. Нажмите OK. 
18. Щёлкните по значку Paste на панели инструментов и вставьте скопированную структуру в 

корпус. Электромагнитная структура будет выглядеть, как показано на рис. 5.76. 
19. Выделите все проводники топологии, кроме резисторов, щёлкните по любому проводнику 

правой кнопкой мышки и, выбрав Shape Properties, установите слой 2 и наз

Теперь можно определить частоты, создать графики и выполнять моделирование. 
 

5.4. Моделирование микрополоскового двухсекционного 
симметрированного направленного ответвителя. 

В этом примере отредактируем LPF файл, введя новые слои для черчения электромагнитной 
структуры, и таблицы соответствия слоёв. Как видно из предыдущих примеров, это не обязательно де-
лать для достато

х 
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и слоя вместе со 

охранить. 
й по Project Op-
ptions. 

Редакт

менедж
е мышкой по 

еющихся в LPF 
ayers. 

 (Общие) в левой части окна. Если она 
ры

ого представления структуры; 
слои для трёхмерного отображения топологии схемы; 

, слой не будет отображаться для черчения в нижней части окна 

идею на простом примере структуры с двумя слоями диэлектрика (т.е. всего будет тр
слоем воздуха). 

 
Создание нового проекта. 

6. Выберите File>New Project (Файл>Новый проект) в выпадающем меню. 
Выберите File>Save Project As (Файл>Сохранить проект как) в выпадающем меню7. . Откро-
ется диалоговое окно Save As. 

8. Наберите NO и нажмите С
9. Выберите в меню Options>Project Options или дважды щёлкните мышко

tions в левом окне просмотра проекта. Откроется диалоговое окно Project O
10. На вкладке Global Units этого окна в поле Frequency введите GHz, в поле Length type вве-

дите mm и нажмите OK. 
 

ирование файла LPF и установка таблиц соответствия слоёв. 
Ввести все необходимые слои для черчения на соответствующих слоях диэлектрика лучше до 

создания электромагнитных структур, чтобы не возникло проблем с их установкой в уже созданных 
структурах. 

Щёлкните мышкой по панели Layout в левом нижнем углу окна проекта, чтобы открыть окно 
ера топологии. В верхней части окна менеджера топологии в группе Layer Setup (Установка сло-

ёв) отображается загруженный LPF файл. По умолчанию это default.lpf. Дважды щёлкнит
имени Default этого файла. Откроется окно (рис. 5.77) с перечнем слоёв черчения, им
файле. Альтернативно это окно можно вызвать, выбрав в меню Options>Drawing L

При открытии окна обычно сразу открыта папка General
не отк та, щёлкните по ней мышкой, чтобы открыть. Эта папка содержит три типа слоёв: 

o Drawing Layer 2d – слои черчения для двухмерн

Рис. 5.77 

o Drawing Layer 3d – 
o Drill Hole Layers – слои для черчения отверстий. 

В правой части окна на странице Drawing Layer 2d Properties (Свойства слоёв черчения в двух-
мерном представлении) имеются следующие столбцы: 

o Name – имя слоя; 
o Visible (Видимость) – если отмечено, слой будет отображаться в структуре; 
o Cloak (Скрыть) – если отмечено

менеджера топологии при черчении топологических элементов в окне топологии схемы (не пу-
тайте с окном черчения электромагнитной структуры); 

o Line – дважды щёлкнув мышкой в этом столбце, можно выбрать тип линии и её цвет для черче-
ния топологических элементов; 



o Fill (Заполнение) – дважды щёлкнув мышкой в этом столбце, можно выбрать тип и цвет запол-
нения (штриховки) вычерчиваемых топологических форм. 

o Show Fill (Показать заполнение) – если отмечено, топологическая форма в окне топологии схе-
мы будет отображаться заполненной, в противном случае будет отображаться только её контур. 

o Freeze (Закрепить) – если отмечено, слой будет закреплён. 
Чтобы добавить новый слой черчения, щёлкните мышкой по кнопке New Layer в правой части 

окна. Появится новая строка с именем Layer1 (новый слой устанавливается после того слоя, который 
отмечен в окне). Переименуйте этот слой, введя новое имя в столбце Name, и установите необходимые 
свойства нового слоя в остальных столбцах. Добавьте следующие слои черчения: 

1. С именем Copper1. Отметьте Visible, выберите тип и цвет для линии и заполнения, от-
метьте Show Fill. На этом слое будем вычерчивать медные проводники на 3-м слое, т.е. 

на нижнем слое диэлектрика. Не 
путайте слой черчения с физиче-
ским слоем материала меди, об-
щее у них может быть только 
имя, но и это не обязательно. 

2. С именем Copper2. Отметьте 
Visible, выберите тип и цвет для 
линии и заполнения, отметьте 
Show Fill. Этот слой будем ис-
пользовать для межслойной пе-
ремычки. В структуре будет 
только одна перемычка с третье-
го слоя диэлектрика на нижнюю 
крышку корпуса. Если нужны 
другие перемычки с разных слоёв 
диэлектрика, для них нужно соз-
дать свои слои черчения. 

3. С именем Resist. Отметьте Visi-
ble, выберите тип и цвет для ли-
нии и заполнения, отметьте Show 
Fill. На этом слое будем вычер-
чивать резисторы. 

Рис. 5.78 

4. Два слоя с именами Board2 и Board3. Для этих слоёв отметьте Visible, и Show Fill. Два-
жды щёлкните мышкой в столбце Fill и выберите сплошное заполнение (чёрный квадра-
тик в левом верхнем углу выпадающего окошка на рис. 5.78) и белый цвет. Эти слои бу-
дем использовать только для наглядного отображения структуры при её трёхмерном 
представлении из окна топологии схемы. Для создания электромагнитной структуры и 
анализа они не требуются. Имейте ввиду, что слои Board2 и Board3 являются только 
слоями черчения для отображения реальной платы. 

5. Щёлкните мышкой по EM Layer Mappings. Откроется окно для установки соответствия 
слоёв черчения (Drawing Layer) и слоёв электромагнитной структуры (EM Layer). Эта 
таблица соответствия устанавливает, какие слои черчения можно использовать для за-
данного слоя диэлектрика. 

6. По умолчанию для слоя черчения Copper установлен второй слой диэлектрика. Оставьте 
эту установку без изменения. Для вновь установленных слоёв черчения слои диэлектрика 
не определены. Для слоёв Copper1, Copper2 и Resist определите третий слой, введя 3 в 
столбце EM Layer, для слоёв Board2 и Board3 в этом столбце введите 0 (рис. 5.79). Для 
слоя Copper2 отметьте столбец Via (Межслойный переход). 

7. Щёлкните мышкой по File Export Mappings и затем щёлкните по DXF(DXF). В этой 
таблице определяется, какие слои должны быть записаны в DXF файл при экспорте 
структуры в этом формате. В столбце Write Layer (Записать слой) отметьте слои 
Copper1, Copper2, Resist и Board3, снимите отметки у остальных слоёв. Отмеченные 
слои будут записаны в DXF файл с одинаковым именем слоёв в файле по умолчанию 
Layer1 при экспорте топологии с третьего слоя диэлектрика. Если нужно выполнить экс-
порт топологии со всех слоёв диэлектрика или нескольких, то нужно создать таблицы 
для каждого экспортируемого слоя. Щёлкните правой кнопкой мышки по File Export 
Mappings и выберите New DXF File Export Mapping. В левой части окна появится имя 
новой таблицы соответствия File Map1(DXF). В правой части окна щёлкните по кнопке 
Uncheck All, чтобы снять отметку у всех слоёв и затем отметьте слои Copper и Board2 
(рис. 5.80). Эту таблицу соответствия будем использовать при экспорте топологии со 
второго слоя диэлектрика. 

8. Нажмите OK. 
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Рис. 5.79 
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Теперь создадим электромагнитную структуру. 
Рис. 5.80 

 
Создание электромагнитной структуры. 

1. Щёлкните левой кнопкой мышки по значку New EM Structure  на панели инструмен-
тов. 

2. Наберите no в поле Enter a name for the EM Structure, отметьте AWR EMSight Simulator 
и нажмите Create. На рабочем поле откроется окно электромагнитной структуры. 

3. Щёлкните мышкой по значку Substrate Information на панели инструментов. На вкладке 
Enclosure открывшегося окна в поле X_Dim введите 10, в поле Y_Dim введите 5, в поле 
Grid_X и в поле Grid_Y введите 0.05. 

4. На вкладке Material Defs в области Dielectric Definitions для диэлектрического слоя Diel_1 
введите Er=10.5, TanD=0.0001. Для области Conductor Definitions щёлкните мышкой по 
кнопке Add, чтобы добавить материал проводника. Откроется дополнительное диалоговое 



окно Add Conductor (рис. 5.81). В поле Name введите Copper1, в поле Conductivity(S/m) 
введите 5.88е7 и нажмите OK. Снова щёлкните мышкой по кнопке Add.В поле Name вве-

дите Resist, в поле Conductivity(S/m) введите 6.7е4 и 
нажмите OK. 

5. На вкладке Dielectric Layers для слоя 1 в колонке 
Thickness введите 6, в колонке Material Definition 
введите Air, щёлкнув левой кнопкой мышки по этому 
полю, в колонке Draw Scale  введите 1. Для слоя 2 в 
колонке Thickness введите 0.5, в колонке Material 
Definition введите Diel_1, щёлкнув левой кнопкой 
мышки по этому полю, в колонке Draw Scale  введите 
4, чтобы удобнее было просматривать трёхмерное ото-
бражение электромагнитной структуры. Щёлкните по 

кнопке Insert (Вставить) и для нового слоя 3 введите такие же параметры, как и для слоя 2. 
6. На

Рис. 5.81 

 вкладке Materials щёлкните мышкой по кнопке Insert. В столбце Name замените поя-
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оёв черчения и слоёв ди-

вившееся имя Trace1 на Copper1, в столбце Thickness введите 0.005, в столбце Material 
Definition введите Copper1, щёлкнув мышкой по этому полю. Снова щёлкните мышкой по 
кнопке Insert.В столбце Name замените появившееся имя Trace1 на Resist, в столбце 
Thickness введите 0.00025, в столбце Material Definition введите Resist, щёлкнув мышкой 
по этому полю. Окно будет выглядеть, как показано на рис. 5.82. 

7. На вкладке EM Layer Mapping устанавливается соответствие сл
Рис. 5.82 

электрика. Это соответствие мы уже установили выше (рис. 5.79), однако здесь дополни-
тельно устанавливается соответствие между слоями и материалами. В столбце Material для 
слоя Copper введите материал Copper1, щёлкнув мышкой по этому столбцу в строке Cop-
per. Для слоёв Copper1 и Resist введите соответственно материалы Copper1 и Resist. Для 
слоя Copper2 выделите материал Copper1 и отметьте Via (рис. 5.83). 

8. Нажмите OK. 
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оздание топологии. 
Слой электромагнитной структуры) менеджера топологии введите 3. В поле 

 
Рис. 5.83 

С
1. В поле EM Layer (

Material введите Copper1. Отметьте Conductor. Электромагнитная структура будет выглядеть, 
как показано на рис. 5.84. В нижней части окна менеджера топологии отображается структура 
слоёв и слой, на котором будет выполняться черчение. 

Рис. 5.84 



2. Щёлкните левой кнопкой мышки по значку Rectangle  на панели инструментов или выберите 

 электромагнитной структуры и нажмите клавишу Tab на клавиатуре. 

мите OK. Нажмите клавишу Tab снова, чтобы от-

поле dy. 

-

x и 0.25 в 

те по значку Polygon на панели инструментов. Поместите курсор на левый верхний угол 

ему проводнику, чтобы выделить их. 

овите курсор на скопированные 

 

 

й угол вновь соз-
данного проводника и щёлкните левой кноп-
кой мышки, переместите курсор на верхний 
угол горизонтального проводника и дважды 
щёлкните левой кнопкой мышки (рис. 5.90). 

15. Повторите пункты с 2-го по 4-ый, но введи-
те 7.8 в поле x, 2.8 в поле y, 0.45 в поле dx и 

в меню Draw>Rectangle. 
3. Поместите курсор в окно

Откроется диалоговое окно Enter Coordinates. 
4. Введите 0 в поле x, введите 1.65 в поле y и наж

крыть диалоговое окно Enter Coordinates. Установите флажок в переключателе Rel, чтобы акти-
визировать относительные координаты. Введите 3.2 в поле dx, введите 0.45 в поле dy и нажмите 
OK. Проводник прямоугольного сечения отображается в окне электромагнитной структуры. 

5. Повторите пункты с 2-го по 4-ый, но введите 3,2 в 
поле x, 2,85 в поле y, 2,15 в поле dx и 0.3 в 
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6. Щёлкните левой кнопкой мышки по значку Copy и 
затем по значку Paste на панели инструментов. Ско
пированный проводник подключите к нижнему 
входному проводнику так, чтобы верхние границы 
совпадали, как показано на рис. 5.85. 

7. Повторите пункты с 2-го по 4-ый, но введите 5.65 в поле x, 2,55 в поле y, 2,15 в поле d

Рис. 5.85 

поле dy. 
8. Щёлкни

второго верхнего проводника и щёлкните левой кнопкой мышки, чтобы зафиксировать эту точку. 
Нажмите клавишу Tab, введите -0.3 в поле dx, введите 0.35 в поле dy и нажмите OK. Переместите 
курсор на правый нижний угол первого верхнего проводника и щёлкните мышкой. Переместите 

курсор на левый нижний угол второго 
верхнего проводника и здесь дважды 
щёлкните мышкой. Должна получиться 
топология, показанная на рис. 5.86. 

9. Нажмите клавишу Shift и щёлкните ле-
вой кнопкой мышки по изгибу и второму 
верхнРис. 5.86 

Выберите в меню Edit>Mirror, поместите 
курсор на выделенные проводники, нажми-
те левую кнопку мышки и, вращая провод-
ники мышкой, создайте их зеркальное ото-
бражение так, чтобы можно было подклю-
чить их к нижнему проводнику (рис. 5.87). 

10. Устан
Рис. 5.87 проводники, нажмите левую кнопку мыш-

ки и подключите их нижнему проводнику 
(рис. 5.88). 

Рис. 5.88 

11. Повторите пункты с 2-го по 4-ый, но вве-
дите 2.75 в поле x, 3.15 в поле y, 0.45 в поле 
dx и 1.85 в поле dy. 

12. Щёлкните по значку Polygon на панели 
инструментов. Поместите курсор на левый 
нижний угол вновь созданного проводника 
и щёлкните левой кнопкой мышки, пере-
местите курсор на правый нижний угол 
вновь созданного проводника и щёлкните
левой кнопкой мышки, переместите курсор 
на левый нижний угол верхнего горизон-
тального проводника и дважды щёлкните 
левой кнопкой мышки (рис. 5.89). 

13. Повторите пункты с 3-го по 4-ый, но вве-
дите 7.8 в поле x, 0 в поле y, 0.45 в поле dx и 
2.15 в поле dy. 

14. Щёлкните по значку Polygon на панели ин-
струментов. Поместите курсор на правый

Рис. 5.89 

верхний угол вновь созданного проводника и 
щёлкните левой кнопкой мышки, перемести-
те курсор на левый верхни

Рис. 5.90 



0.5 в поле dy. 
16. Щёлкните по значку Polygon на панели инструментов. Поместите курсор на правый 

нижний угол вновь созданного проводника и 
щёлкните левой кнопкой мышки, переместите 
курсор на левый нижний угол вновь созданно-
го проводника и щёлкните левой кнопкой 
мышки, переместите курсор на нижний угол 
горизонтального проводника и дважды щёлк-
ните левой кнопкой мышки (рис. 5.91). 
17. Создайте контактную площадку для 
заземления резистора. Повторите пункты с 2-
го по 4-ый, но введите 7.8 в поле x, 3.45 в поле 
y, 0.45 в поле dx и 0.5 в поле dy. Рис. 5.91 
18. Создайте резистор. В окне менеджера 
топологии в поле Material введите Resist. По-
вторите пункты с 2-го по 4-ый, но введите 7.95 
в поле x, 3.25 в поле y, 0.15 в поле dx и 0.25 в 
поле dy (рис. 5.92). 
19. Создайте межслойную перемычку для 
заземления резистора. В окне менеджера топо-
логии в поле Material введите Copper1 и от-
метьте Via. Щёлкните по значку Ellipse на па-
нели инструментов. Переместите курсор в ок-
но электромагнитной структуры на 0.1 мм 

правее и ниже верхнего левого угла, нажмите левую кнопку мышки и дви-
гайте мышку по диагонали вправо и вниз пока смещения координат будут 
равны dx:0.25 и dy:-0.25, как показано на рис. 5.93. Установив курсор на соз-
данную перемычку и, двигая мышкой с нажатой левой кнопкой, можно по-
править положение перемычки. 

Рис. 5.92 

20. Щёлкните мышкой по входному горизонтальному проводнику, что-
бы выделить его. Щёлкните мышкой по значку Edge Port на панели инстру-
ментов, установите порт на входе ответвителя и сдвиньте его референсную 
плоскость на 1 мм вглубь структуры. Аналогично установите порты на вы-
ходные проводники, как показано на рис. 5.94. 

Рис. 5.93 

Щёлкните правой кнопкой мышки по значку New Schematic 3D View, чтобы просмотреть 3-х 
мерное изображение и убедиться, что топология создана правильно (рис. 5.95). Если некоторые провод-
ники окажутся не на третьем слое, выделите их в электромагнитной структуре рис. 5.94, щёлкните пра-
вой кнопкой мышки, выберите Shape Properties и в поле EM Layer введите 3. 
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Создание графика и добавление измеряемых величин. 
Рис. 5.94 Рис. 5.95 

1. Щёлкните по кнопке Project, чтобы в левом окне открыть окно просмотра проекта. 
2. Щёлкните по значку Add Graph на панели инструментов. 
3. Введите имя графика, например, Graph 1 в поле Graph name (Имя графика), выберите 

Tabular (Таблица) в области Graph Type (Тип графика) и нажмите OK. 
4. Щёлкните левой кнопкой мышки по значку Add Measurement на панели инструментов. 
5. Выберите Port Parameter в списке Meas. Type, S в списке Measurement, All Sources в поле 

Data Source Name, введите 2 в поле To Port Index, 1 в поле From Port Index, нажимая на 
стрелки, справа от этих полей, отметьте dB и Mag в области Complex Modifier, нажмите 
Apply. 

6. Введите 3 в поле To Port Index и нажмите Apply. 
7. Нажмите OK. 



Определение частот для моделирования и анализ. 
1. Дважды щёлкните левой кнопкой мышки по Pro-

ject Options в окне просмотра проекта. На вкладке 
Frequencies в поле Start введите 4, в поле Stop 
введите 16, в поле Step введите 1. Нажмите Apply 
и OK. 

2. Щёлкните левой кнопкой мышки по значку Ana-
lyze на панели инструментов. Результаты анализа 
отображаются в таблице рис. 5.96. 

 
 
Примечание. Щёлкнув левой кнопкой мышки по значку Print 
на панели инструментов при активном окне графика (таблицы), 
можно распечатать график. Содержание любого активного окна 
можно распечатать, выбрав в меню File>Print View. 
 
 
 Рис. 5.96 
 

Экспорт топологии в DXF файл из окна электромагнитной структуры. 
Щёлкните правой кнопкой мыш-

ки по имени электромагнитной структу-
ры no в окне просмотра проекта и выбе-
рите Export EM Layout. В открывшемся 
окне (рис. 5.97) выберите папку для раз-
мещения файла. В поле Имя файла вве-
дите no1. В поле Тип файла, щёлкнув по 
кнопке в правом конце этого поля, выбе-
рите таблицу соответствия для экспорта 
DXF(DXF Flat, *dxf), которую мы ранее 
определили для третьего слоя. Нажмите 
Сохранить. В AutoCAD сохранённая 
топология будет выглядеть, как показано 
на рис. 5.98. 
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Рис. 5.97 Рис. 5.98 

Если нужно в dxf файл записать контур платы, придётся временно покрыть слоем проводника 
всю плату. 

1. Сделайте активным окно электромагнитной структуры и щёлкните мышкой по кнопке Lay-
out в нижнем левом углу окна, чтобы открыть менеджер топологии. 

2. В окне менеджера топологии в поле EM Layer введите 3, в поле Material введите Copper1, 
отметьте Conductor. 

3. Щёлкните мышкой по значку Rectangle на панели инструментов. Установите курсор на ле-
вый верхний угол структуры, нажмите левую кнопку мышки и переместите курсор на пра-
вый нижний угол структуры. Вся структура будет покрыта слоем материала Copper1. Вы-
полнить анализ такой структуры нельзя, она может использоваться только для экспорта то-
пологии. 

4. При экспорте топологии из окна электромагнитной структуры входные отрезки линий от 
края корпуса до референсных плоскостей удаляются. Это необходимо учитывать. Дважды 
щёлкните по слою покрытия левой кнопкой мышки (вне топологических элементов ответ-
вителя). Установите курсор на ромбик посередине левой стороны покрывающего слоя, на-
жмите левую кнопку мышки и сдвиньте эту сторону, например на 0.8 мм вправо, чтобы 
проводники не начинались от края платы. Аналогично сдвиньте верхнюю сторону покры-
вающего слоя вниз и нижнюю сторону – вверх. 

5. Можно добавить в структуру вспомогательные топологические элементы, например, репер-
ные знаки. Щёлкните мышкой по значку Rectangle на панели инструментов. Установите 



курсор на левый верхний угол слоя покрытия, нажмите левую кнопку мышки и переместите 
курсор вправо и вниз так, чтобы было dx:0.5 и dy:-0.5, отпустите кнопку. В левом верхнем уг-
лу покрывающего слоя появится реперный знак в виде прямоугольника, который будет выде-
лен. Щёлкните по значку Copy на панели инструментов. Щёлкая по значку Paste на панели ин-
струментов, установите реперные знаки на остальные углы покрывающего слоя. Структура бу-
дет выглядеть, как показано на рис. 5.99. Откройте окно просмотра проекта и импортируйте 
структуру в DXF файл, как описано выше. В AutoCAD топология будет выглядеть, как показа-
но на рис. 5.100. 
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Щёлкните мышкой по покрывающему слою, чтобы выделить его, и удалите этот слой, нажав 
клавишу Delete. Реперные знаки удалять не обязательно. Щёлкните по значку Analyze на панели инст-
рументов, чтобы восстановить результаты анализа. 

Рис. 5.100 

Рис. 5.99 

Теперь нанесём топологические формы на второй слой диэлектрика. На этот слой мы нанесём 
только вспомогательные топологические элементы (реперные знаки и текст). 

1. Сделайте активным окно электромагнитной структуры и откройте окно менеджера топол-
гии. В поле EM Layer введите 2, в поле Material введите Copper1. Определённый для вто-
рого слоя диэлектрика слой черчения Copper будет использоваться автоматически. 

2. Щёлкните по значку Polygon на панели инструментов. Установите курсор на верхний ле-
вый угол прямоугольного реперного знака на третьем слое диэлектрика и щёлкните левой 
кнопкой мышки. Затем перемещайте курсор, щёлкая мышкой после каждого перемещения, 
следующим образом: на 0.5 вправо, на 0.2 вниз, на 0.3 влево, на 0.3 вниз, на 0.2 влево и 
здесь дважды щёлкните мышкой, чтобы замкнуть полигон. Щёлкните по значку Copy на 
панели инструментов. Щёлкая по значку Paste на панели инструментов и щёлкая правой 
кнопкой, чтобы развернуть скопированные формы, установите остальные реперные знаки, 
как показано на рис.5.101. 

3. Выберите в меню Options>Layout Options и на вкладке Layout Font открывшегося окна 
опций топологии установите высоту шрифта Height равной 0.3. Нажмите OK. 

4. Выберите в меню Draw>Text, поместите курсор в удобное место на структуре и щёлкните 
левой кнопкой мышки. В появившемся поле ввода наберите Ответвитель. 

Рис. 5.101 

Полученная структура показана на рис. 5.101, на рис. 5.102 – её трёхмерное отображение. 
Рис. 5.102 

Откройте слева окно просмотра проекта. Щёлкните по имени электромагнитной структуры и 
выберите Export EM Layout. В открывшемся окне введите имя файла no2, в поле Тип файла введите 
имя таблицы соответствия для второго слоя FileMap1(DXF Flat, *.dxf) и нажмите Сохранить. В Auto-
CAD экспортированная топология второго слоя диэлектрика будет выглядеть, как показано на рис. 5.103. 
 



Если на втором слое диэлектрика покрыть область, ограниченную реперными знаками (как опи-
сано выше для третьего слоя) тем же слоем, который использовался для создания реперных знаков, и 
выполнить экспорт топологии со второго диэлектрического слоя, то в AutoCAD экспортированная топо-
логия будет выглядеть, как показано на рис. 5.104. 

Рис. 5.103 Рис. 5.104 
 
Экспорт топологии в DXF файл из окна топологии схемы. 

В этом варианте экспорта сначала нужно скопировать созданную топологию в окно топологии 
схемы и затем выполнить экспорт из этого окна. Такой метод может быть предпочтительным, если, на-
пример, электромагнитная структура вставлена в схему в качестве подсхемы и делается экспорт тополо-
гии всей схемы. Для удобства работы с несколькими окнами можно выбрать в меню Window  затем Tile 
Vertical или Tile Horizontal. 

1. Щёлкните по значку New Schematic на панели инструментов и создайте схему с любым 
именем, например по умолчанию, Schematic1. Откроется пустое окно схемы. 

2. Щёлкните по значку New Schematic Layout View на панели инструментов. Откроется пус-
тое окно топологии схемы. 

Рис. 5.105 

3. Сделайте активным окно элек-
тромагнитной структуры и вы-
берите в меню Edit>Select All, 
чтобы выделить всю топологию. 
Щёлкните по значку Copy на 
панели инструментов. 

4. Сделайте активным окно топо-
логии схемы и щёлкните по 
значку Paste на панели инстру-
ментов. Вставьте скопирован-
ную топологию в окно тополо-
гии схемы (рис. 5.105). 

Если сейчас попытаться просмотреть трёхмерное представление скопированной топологии, 
щёлкнув по значку New Schematic 3D View, то увидим только элементы топологии, расположенные на 
третьем слое. Это объясняется тем, что не определены установки для трёхмерного представления струк-
тур, в частности все новые слои имеют нулевую толщину. Чтобы определить необходимые установки, 
сделайте следующее. 

1. Выберите в меню Options>Drawing Layers и в левой части открывшегося окна (рис. 5.106) 
щёлкните мышкой Drawing Layer 3d. 

2. В столбце Opaque (Непрозрачный) снимите отметки у используемых слоёв Copper, 
Copper1, Copper2, Resist, Board2 и Board3, чтобы сквозь верхние слои можно было видеть 
нижние. 

В столбце Thickness устанавливается толщина слоёв. Эта толщина никакого отношения к реаль-
ным толщинам материалов и диэлектриков не имеет и на анализ не влияет. Она устанавливается только 
для удобства объёмного просмотра структуры. В столбце Z-Position устанавливается значение координа-
ты Z, от которой отсчитывается толщина. Если толщина положительная, она отсчитывается вверх от ука-
занной координаты. Если толщина отрицательная, она отсчитывается вниз от указанной координаты. 

3. Для слоя Copper1 установите толщину 0.005 и координату 0 (т.е. начало координат помес-
тим на верхнюю плоскость 3-го слоя диэлектрика, хотя его можно поместить в любое удоб-
ное место). 

4. Для слоя Copper2 установите толщину -0.5 и координату 0. Этот слой является перемычкой 
через третий слой диэлектрика. Поэтому его толщина должна быть равна толщине третьего 
(нижнего) слоя диэлектрика и направлена вниз. 

5. Для слоя Resist установите толщину 0.00025 и координату 0. 
6. Для слоя Board2 установите толщину 0.5 и координату 0.005. Этот слой используется для 

отображения второго (верхнего) слоя диэлектрика и его координата определяется толщиной 
слоя Copper1, который нанесён на третий слой диэлектрика. Хотя, как уже указывалось, это 
не обязательно и можно установить координату 0. 

7. Для слоя Board3 установите толщину -0.5 и координату 0. Этот слой используется для ото-
бражения третьего слоя диэлектрика. 
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8. На втором слое диэлектрика мы используем слой черчения Copper, который имеется в LPF 
файле по умолчанию. Его толщину по умолчанию можно оставить, а значение координаты 
нужно изменить, чтобы она соответствовала верхней поверхности слоя Board2. Поэтому 
измените координату слоя Copper на 0.505 (с учётом толщины слоя Copper1). Нажмите 
OK. 

Все выполненные установки для используемых слоёв показаны на рис. 5.106. Если теперь сде-
лать активным окно топологии схемы и щёлкнуть мышкой по значку New Schematic 3d View, то полу-

чим трёхмерное отображение структуры (рис. 5.107), ко-
торое будет объёмным, но топологические элементы в 
структуре “висят в воздухе”. Поэтому добавим слои плат. 

Рис. 5.106 
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кните по значку Rectangle на панели инструментов. Переместите курсор в окно топо-

, чтобы назначить его для черчения. 

9. Сделайте активным окно топологии схемы и 
откройте окно менеджера топологии. В 
нижней части окна менеджера топологии 
щёлкните мышкой по прямоугольнику слоя 
Board3 (но не по лампочке, иначе слой ста-
нет невидимым), чтобы назначить его для 
черчения. Обратите внимание, что при ко-
пировании в окно топологии схемы и при 
экспорте из этого окна отрезки от края элек-

тромагнитной структуры до референсных плоскостей автоматически не удаляются. Если 
это необходимо сделать, топологию в этом окне нужно отредактировать, укоротив соответ-
ственно входные проводники. Мы оставим размеры структуры без изменения (10х5 мм), но 
плату создадим несколько больше, чтобы проводники имели отступ от краёв платы 0.2 мм. 

10. Щёл

Рис. 5.107 

логии схемы и нажмите клавишу Tab. В поля x и y введите 0, нажмите OK и затем клавишу 
Tab. В поле dx введите 10.4, в поле dy введите 5.4, нажмите OK. Щёлкните мышкой по 
значку View All, чтобы отобразить все элементы топологии и слой платы. Выделите все 
элементы топологии на втором и третьем слоях диэлектрика, кроме слоя платы. Установите 

курсор на любой выделенный элемент и по-
местите топологию на слой платы так, что-
бы края входных проводников отстояли от 
края платы на 0.2 мм. Поочерёдно выделите 
реперные знаки на обоих слоях и поместите 
их по углам платы. Топология должна вы-
глядеть, как показано на рис. 5.108. 

11. В нижней части окна менеджера топологии 
щёлкните мышкой по прямоугольнику слоя 
Board2Рис. 5.108 Щёлкните по значку Rectangle на панели 



инструментов. Установите курсор на верхний левый угол созданной ранее платы, нажмите 
кнопку мышки и переместите курсор на нижний правый угол платы и отпустите кнопку. 

12. Щёлкните по значку New Sche-
matic 3d View на панели инстру-
ментов. Трёхмерное представление 
структуры будет иметь вид, пока
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Чтобы выполнить экспорт топологии с 
третьего слоя, сделайте активным окно тополо-
гии схемы и выберите в меню Layout>Export. 
В открывшемся окне введите имя файла no
s ic, в поле Тип файла введите имя таб-
лицы соответствия для третьего слоя диэлек-
трика DXF(DXF Flat, *.dxf) и нажмите Сохра-

нить. В AutoCAD топология будет выглядеть, как показано на рис. 5.110. 
Если в dxf файл нужно записать контур платы, щёлкните мышкой по значку Options>Drawing 

Layers на панели инструментов. В открывшемс

ic, в поле Тип файла введите имя таб-
лицы соответствия для третьего слоя диэлек-
трика DXF(DXF Flat, *.dxf) и нажмите Сохра-

нить. В AutoCAD топология будет выглядеть, как показано на рис. 5.110. 
Если в dxf файл нужно записать контур платы, щёлкните мышкой по значку Options>Drawing 

Layers на панели инструментов. В открывшемс

Рис. 5.109 

я окне щёлкните по File Export Mappings и затем по 
DXF(DXF). Отметьте столбец Write Layer для слоя Board3. Повторите экспорт топологии с третьего 
слоя. В AutoCAD топология будет выглядеть, как показано на рис. 5.111. 

Чтобы выполнить экспорт топологии со второго слоя диэлектрика, выберите в меню Lay-
out>Export. В открывшемся окне введите имя файла no2-schematic, в поле

F). Отметьте столбец Write Layer для слоя Board3. Повторите экспорт топологии с третьего 
слоя. В AutoCAD топология будет выглядеть, как показано на рис. 5.111. 

Чтобы выполнить экспорт топологии со второго слоя диэлектрика, выберите в меню Lay-
out>Export. В открывшемся окне введите имя файла no2-schematic, в поле

ответствия для второго слоя диэлектрика FileMap1(DXF Flat, *.dxf) и нажмите Сохранить. В 
AutoCAD топология будет выглядеть, как показано на рис. 5.112. 

Чтобы в dxf файл записать контур платы, щёлкните мышкой по значку Options>Drawing Layers 
на панели инструментов. В открывшемся окне щёлкните по F

ответствия для второго слоя диэлектрика FileMap1(DXF Flat, *.dxf) и нажмите Сохранить. В 
AutoCAD топология будет выглядеть, как показано на рис. 5.112. 

Чтобы в dxf файл записать контур платы, щёлкните мышкой по значку Options>Drawing Layers 
на панели инструментов. В открывшемся окне щёлкните по F

XF). Отметьте столбец Write Layer для слоя Board2.Повторите экспорт топологии со второго 
слоя. В AutoCAD топология будет выглядеть, как показано на рис. 5.113. 

 
Импорт топологии из DXF файла. 

XF). Отметьте столбец Write Layer для слоя Board2.Повторите экспорт топологии со второго 
слоя. В AutoCAD топология будет выглядеть, как показано на рис. 5.113. 

 
Импорт топологии из DXF файла. 

го в предыдущем примере, где использовалго в предыдущем примере, где использовал
тот метод может быть более предпочтительным при сложной топологии и большим количеством 

слоёв. Или если предполагается после моделирования и редактирования импортированной электромаг-
нитной структуры снова её экспортировать в DXF файл. 

тот метод может быть более предпочтительным при сложной топологии и большим количеством 
слоёв. Или если предполагается после моделирования и редактирования импортированной электромаг-
нитной структуры снова её экспортировать в DXF файл. 

Рис. 5.110 Рис. 5.111 Рис. 5.110 Рис. 5.111 

Рис. 5.113 Рис. 5.112 



Для импорта будем использовать файлы no1.dxf и no2.dxf., полученные при экспорте топологии 
в этом примере. 
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 mm для длины. 

 

кне отметьте 

логических ячеек с именем no1, ко-

1. Сохраните текущий проект, затем создайте новый проект и сохраните его с именем NO-
DXF

2. Выберите в меню Options>Project Options и на вкладке Global Units введите GHz для час-
тоты и

3. Щёлкните по панели Layout в левом 
нижнем углу окна проекта, чтобы от-
крыть окно менеджера топологии. LPF
файл будем использовать загруженный 
по умолчанию default.lpf. 

4. Щёлкните правой кнопкой мышки по 
Cell Libraries и выберите Import DXF 
Library. В открывшемся о
файл no1 и нажмите кнопку Открыть. 

Откроется окно с запросом, какие 
единицы измерения используются 
в dxf файле (рис. 5.114). Введите 
mm и нажмите OK. Откроется 
окно с сообщением, какие слои 
будут созданы автоматически при 
импорте файла. Имена этим слоям 
присваиваются те же, которые за-
писаны в dxf файле. Нажмите OK. 
Обратите внимание, что будет 
создан только один слой с именем 
Layer1. Дело в том, что ранее при 

создании таблицы соответствия File Export Mappings слоёв черчения и слоёв, записывае-
мых в dxf файл, записываемые в файл имена для всех экспортируемых слоёв черчения были 
оставлены одинаковыми Layer1, установленными по умолчанию. При необходимости в 
этой таблице можно было задать для каждого записываемого в файл слоя индивидуальные 
имена. 

5. В окне менеджера топологии появится библиотека топо

Рис. 5.114 

Рис. 5.115 

торая содержит топологическую ячейку с таким же именем no1. Дважды щёлкните левой 
кнопкой мышки по имени топологической ячейки. На рабочем поле откроется окно редак-
тора топологического чертежа с импортированной структурой, а в нижней части окна ме-
неджера топологии появится список слоёв черчения, имеющихся в LPF файле (рис. 5.116). 

Рис. 5.116 
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 левой 

6. Поскольку при экспорте топологии вся плата покрывалась слоем проводника, то этот слой
также импортирован и его нужно удалить, чтобы иметь возможность выполнять анализ то-
пологии. Щёлкните по этому слою мышкой вне проводников и нажмите клавишу Delete. 
Аналогично можно удалить реперные знаки. Импортированная топология будет выглядеть, 
как показано на рис. 5.117. 

7. В поле ввода Grid Spacing
на панели инструментов 
введите множитель 0.5х, 
чтобы размер ячеек сетки 
был равен 0.05 мм. 

8. Дважды щёлкните
кнопкой мышки по имени 
LPF файла Default в окне 
менеджера программы. В 
открывшемся окне с переч-

нем имеющихся слоёв черчения измените имя слоя Lauer1 на Copper1. Щёлкните мышкой 
по кнопке New Layer и добавьте слой Copper2. Затем добавьте слой Resist. В добавленных 
слоях можете изменить текстуру и цвет заполнения. 

Рис. 5.117 

9. Щёлкните левой кнопкой мышки по EM Layer Mappings. Для трёх добавленных слоёв в 
столбце EM Layer введите 3. Для слоя Copper2 отметьте столбец Via. Нажмите OK. 

10. Щёлкните мышкой по значку New EM Structure на панели инструментов и создайте элек-
тромагнитную структуру с именем NO_DXF и решающим устройством AWR EMSight 
Simulator. 

11. Щёлкните мышкой по значку Substrate Information на панели инструментов. В открыв-
шемся окне свойств электромагнитной структуры на вкладке Enclosure введите размер 10 
по оси X, 5 по оси Y, размер ячеек сетки 0.05 по обеим осям. 

12. На вкладке Material Defs для диэлектрического слоя введите Er=10.5, TanD=0.0001. Для 
проводников добавьте материалы Copper1 с проводимостью 5.88е7 и Resist с проводимо-
стью 6.7е4, нажимая соответствующую кнопку Add. 

13. На вкладке Dielectric Layers для слоя 1 введите толщину 6, для слоя 2 введите толщину 0.5 
и масштаб черчения 4. Добавьте третий слой с такими же параметрами, как и у второго, на-
жав кнопку Insert. 

14. На вкладке Materials добавьте материалы с именами Copper1 и Resist соответственно с 
толщиной 0.005 и 0.00025 и материалами Copper1 и Resist. 

15. На вкладке EM Layer Mapping для слоёв Copper1 и Copper2 назначьте материал Copper1, 
для слоя Resist назначьте материал Resist. Нажмите OK. 

16. Сделайте активным окно редактора топологического чертежа. Нажмите клавишу Shift и, 
щёлкая мышкой по проводникам, выделите их, кроме резистора и межслойной перемычки. 
Щёлкните правой кнопкой мышки по любому выделенному проводнику и выберите Shape 
Properties. В открывшемся окне в поле Model Layers введите Copper1 и нажмите OK. 
Щёлкните по значку Copy на панели инструментов. 

17. Сделайте активным окно электромагнитной структуры. Щёлкните по значку Paste на пане-
ли инструментов и вставьте скопированную топологию в корпус симметрично относитель-

но боковых стенок корпуса 
так, чтобы расстояние от вход-
ного проводника до левого 
края корпуса и расстояния от 
выходных проводников до бо-
ковых стенок корпуса были 
равны 1 мм. Дважды щёлкните 
по входному проводнику, ус-
тановите курсор на ромбик по-
середине его левой стороны, 
нажмите левую кнопку мышки 
и сдвиньте эту сторону до ле-
вого края корпуса. Аналогично 

удлините вертикальные выходные проводники. Топология в окне электромагнитной струк-
туры должна выглядеть, как показано на рис. 5.118. 

Рис. 5.118 

18. Сделайте активным окно редактора топологического чертежа. Щёлкните по резистору ле-
вой кнопкой мышки, затем щёлкните правой кнопкой и выберите Shape Properties. В от-
крывшемся окне в поле Model Layers введите Resist и нажмите OK. Щёлкните по значку 
Copy на панели инструментов. 

19. Сделайте активным окно электромагнитной структуры. Щёлкните по значку Paste на пане-
ли инструментов и вставьте скопированный резистор в электромагнитную структуру. 



20. Сделайте активным окно редактора топологического чертежа. Щёлкните по межслойной 
перемычке левой кнопкой мышки, затем щёлкните правой кнопкой и выберите Shape Prop-
erties. В открывшемся окне в поле Model Layers введите Copper1 и нажмите OK. Щёлкни-
те по значку Copy на панели инструментов. 

21. Сделайте активным окно электро-
магнитной структуры. Щёлкните 
по значку Paste на панели инстру-
ментов и вставьте скопированную 
межслойную перемычку в элек-
тромагнитную структуру. Щёлкни-
те по перемычке правой кнопкой 
мышки (перемычка должна быть 
выделена) и выберите Shape Prop-
erties. В открывшемся окне отметь-
те Via и нажмите OK. 

22. Установите порты и референсные 
плоскости, выделяя входные про-

водники и щёлкая мышкой по значку Edge Port на панели инструментов. 

Рис. 5.119 

Созданная электромагнитная структура должна выглядеть, как показано на рис. 5.119. Просмот-
рите трёхмерное представление электромагнитной структуры, чтобы убедиться, что она создана пра-
вильно. 
 

Замечание. Альтернативно, можно из окна редактора топологического чертежа скопировать 
сразу всю топологию в окно электромагнитной структуры и отредактировать её в этом окне. 

 
Откройте окно просмотра проекта, щёлкнув мышкой по кнопке Project в левом нижнем углу ок-

на проекта. Теперь можно установить частоты для анализа, создать график и выполнить анализ. 
Топологические элементы на других слоях диэлектрика при необходимости копируются в элек-

тромагнитную структуру аналогично. 
 
Создание схемы с электромагнитной структурой. 

Создадим простую схему с электромагнитной структурой в качестве подсхемы. Просто добавим 
элемент MTRACE2 (элемент трассировки) на входе электромагнитной структуры. 

1. Выберите в меню File>Open Project и откройте сохранённый ранее проект NO. 
2. Щёлкните мышкой по значку New Schematic на панели инструментов и создайте схему 

Schematic 2. 
3. Щёлкнув мышкой по панели Elements в левом нижнем углу проекта, откройте окно про-

смотра элементов. 
4. Щёлкните мышкой по группе Subcircuits и перетащите в окно схемы подсхему no. 

5. Раскройте группу Microstrip, щёлкните мышкой по под-
группе Lines, перетащите элемент MTRACE2 в окно схе-
мы и подключите его к узлу 1 подсхемы no. Дважды 
щёлкните мышкой по элементу MTRACE2, в открыв-
шемся окне свойств элемента введите W=0.45 и нажмите 
OK. 
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7. Щёлкните

 

6. В окне просмотра элементов щёлкните мышкой по груп-
пе Substrates и перетащите в окно схемы элемент под-
ложки MSUB. Дважды щёлкните мышкой по этому эле-
менту, в открывшемся окне свойств введите Er=10.5, 
H=0.5, T=0.005, Tand=0.0001, ErNom=10.5 и нажмите 
OK. Рис. 5.120 

 мышкой по значку Port на панели инструмен-
тов и подключите порт ко входу 
схемы. Аналогично подключите 
порты к узлам 2 и 3 подсхемы no, 
щёлкая правой кнопкой мышки, 
чтобы развернуть порты соответст-
вующим образом. Должна полу-
читься схема, показанная на рис. 
5.120. 

8. Щёлкните мышкой по значку Ana-
lyze на панели инструментов. Ре-
зультаты анализа показаны на рис. 
5.121. Рис. 5.121 
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Как видно из результатов анализа, соединения в схеме выполнены правильно для решающего 
устройс

tic 2, чтобы сделать его активным и затем щёлкните 
по значк

 примерно 2 мм по оси 
X. Расст

. Элемент будет выделен и в цен-

нта MTRACE2 изменился в соответствии с выполненным изменением топологии. 

н
айте активным окно 

тополог

ние созданной то-
пологии 4

и. В нижней части окна менеджера топологии отметьте слой Copper1. 

 
гая курсор по контуру эле-

ите 

тва. Однако при создании топологии схемы, просмотре трёхмерного изображения и экспорте то-
пологии в DXF файл могут возникнуть проблемы. 

Щёлкните мышкой по окну схемы Schema
у New Schematic Layout View на панели инструментов (чтобы было удобнее оперировать с раз-

личными окнами проекта, выберите в меню Window>Tile Horizontal). Выберите в меню Edit> Select All 
и щёлкните по значку Snap Together на панели инструментов, чтобы упорядочить созданную топологию 
(рис. 5.122). В поле ввода Grid Spacing на панели инструментов введите коэффициент 0.5x, чтобы сде-

лать размер сетки 0.05 мм. 
Создайте в элементе 

трассировки MTRACE2 два 
изгиба на 90 градусов на рас-
стоянии

ояния между полосками 
при трассировке измеряются 
между осевыми линиями поло-

сок. Поэтому, чтобы изгибы совпадали с сеткой, по оси X нужно будет при трассировке откладывать 
расстояния 2.225 мм. Сделать это мышкой при размерах сетки 0.05 мм не получится, поэтому будем 
пользоваться координатным вводом. 

Дважды щёлкните мышкой по элементу топо

Рис. 5.122 

логии MTRACE2
тре и по краям появятся синие ромбики. Установите курсор мышки на ромбик в правом конце элемента в 
месте соединения элемента трассировки со входом ответвителя так, чтобы курсор отображался в виде 
двойной стрелки, и дважды щёлкните левой кнопкой мышки, чтобы активизировать режим трассировки. 
Нажмите клавишу Tab, в открывшемся окне введите dx=-2.225 и нажмите OK. Переместите курсор 
мышки вверх на  0.5 мм, щёлкните мышкой и нажмите клавишу  Tab.  В открывшемся окне введите  

dx=-2.225, нажмите OK и дважды 
щёлкните мышкой. Выберите в меню 
Edit>Select All и затем щёлкните мыш-
кой по значку Snap Together на панели 
инструментов, чтобы упорядочить то-
пологию. Должна получиться тополо-
гия, показанная на рис. 5.123. 

Сделайте активным окно схе-
мы Schematic 2 и обратите внимание, 

что параметр L элеме

Рис. 5.123 

Сделайте активным окно графика и щёлкните по значку Analyze на панели инструментов, убе-
дитесь, что анализ схемы выполня-
ется ормально. 

Сдел
ии схемы Schematic 2 и 

щёлкните мышкой по значку New 
Schematic 3D View на панели инст-
рументов, чтобы просмотреть трёх-
мерное изображе

 (рис. 5.12 ). В трёхмерном 
изображении видно, что Microwave 

Office при создании топологии схемы поместил элемент трассировки на верхний (второй) слой диэлек-
трика. Соответственно и экспорт в DXF файл будет выполняться не правильно. Поэтому созданную то-
пологию нужно отредактировать. Для наглядности так же добавим отображение плат. Сделать это можно 
следующим образом. 

1. Закройте окно трёхмерного отображения топологии и сделайте активным окно топологии 
схемы Sc

Рис. 5.124 

hematic 2. 
2. Щёлкните мышкой по панели Layout в левом нижнем углу проекта, чтобы открыть окно 

менеджера топологи
3. Щёлкните мышкой по значку Polygon на панели инструментов. 
4. Установите курсор на правый верхний угол элемента трассировки в месте соединения этого

элемента с ответвителем и щёлкните левой кнопкой мышки. Дви
мента трассировки, щёлкая мышкой в точках изгиба, начертите точно такой же элемент. 

5. Теперь нужно удалить элемент топологии, созданный Microwave Office для элемента схемы 
MTRACE2. Для этого сделайте активным окно схемы Schematic 2 и дважды щёлкн
мышкой по элементу MTRACE2. В открывшемся окне свойств элемента откройте вкладку 
Layout, в списке возможных вариантов топологий отметьте [None] и нажмите OK. В этом 
случае для элемента автоматически никакой топологии создаваться не будет. 

6. Сделайте активным окно топологии схемы Schematic 2. 
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е на левый край будущей нижней 

atic 2 щёлкните мышкой по значку Paste на панели инстру-

 Board3. Щёлкните по значку 

о знач-

топол
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отметьте слой Board3. Щёлкните по значку 
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топол
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7. Переместите квадратные реперные знаки на третьем сло
платы. Для этого дважды щёлкните мышкой по топологии ответвителя. Откроется окно 
электромагнитной структуры. Щёлкните левой кнопкой мышки по верхнему левому квад-
ратному реперному знаку на третьем слое (по его видимой части), щёлкните по значку Copy 
на панели инструментов, чтобы скопировать его. Нажмите клавишу Delete, чтобы удалить 
реперный знак. Затем удалите левый нижний квадратный реперный знак. Закройте окно 
электромагнитной структуры. 

8. В окне топологии схемы Schem

 дважды щёлкните мышкой по топологии ответвителя. Откроется окно 
электромагнитной структуры. Щёлкните левой кнопкой мышки по верхнему левому квад-
ратному реперному знаку на третьем слое (по его видимой части), щёлкните по значку Copy 
на панели инструментов, чтобы скопировать его. Нажмите клавишу Delete, чтобы удалить 
реперный знак. Затем удалите левый нижний квадратный реперный знак. Закройте окно 
электромагнитной структуры. 

8. В окне топологии схемы Schem
ментов и поместите скопированный реперный знак на одном уровне с уже имеющимися 
верхними реперными знаками и левее границы элемента трассировки, например, на 0.2 мм. 
Снова щёлкните мышкой по значку Paste на панели инструментов и поместите скопирован-
ный реперный знак на одном уровне с уже имеющимися нижними реперными знаками и ле-
вее границы элемента трассировки на 0.2 мм. 

9. В нижней части окна менеджера топологии 

ментов и поместите скопированный реперный знак на одном уровне с уже имеющимися 
верхними реперными знаками и левее границы элемента трассировки, например, на 0.2 мм. 
Снова щёлкните мышкой по значку Paste на панели инструментов и поместите скопирован-
ный реперный знак на одном уровне с уже имеющимися нижними реперными знаками и ле-
вее границы элемента трассировки на 0.2 мм. 

9. В нижней части окна менеджера топологии отметьте слой
Rectangle на панели инструментов, установите курсор на левый верхний угол левого верх-
него квадратного реперного знака, нажмите левую кнопку мышки и переместите курсор по 
диагонали на нижний правый угол нижнего правого квадратного реперного знака. 

10. В нижней части ок-
на менеджера топо-
логии отметьте 
слой Board2. 
Щёлкните п

Rectangle на панели инструментов, установите курсор на левый верхний угол левого верх-
него квадратного реперного знака, нажмите левую кнопку мышки и переместите курсор по 
диагонали на нижний правый угол нижнего правого квадратного реперного знака. 

10. В нижней части ок-
на менеджера топо-
логии отметьте 
слой Board2. 
Щёлкните п
ку Rectangle на па-
нели инструментов 
и аналогично соз-
дайте слой платы 
между реперными 
знаками второго 
слоя. 
Отредактированная 

огия схемы Schematic 2 
 на рис. 5.125. 
Щёлкните мышкой по 

 New Schematic 3D View 
 инструме

ку Rectangle на па-
нели инструментов 
и аналогично соз-
дайте слой платы 
между реперными 
знаками второго 
слоя. 
Отредактированная 

огия схемы Schematic 2 
 на рис. 5.125. 
Щёлкните мышкой по 

 New Schematic 3D View 
 инструме

Рис. 5.125 

ражение созданной 
топологии показано на рис. 
5.126. Теперь отредакт

ражение созданной 
топологии показано на рис. 
5.126. Теперь отредакт

пологию схемы можно 
экспортировать в DXF файл, 
выб в в меню ayout>Export, 
как описано ранее. 

 
 

пологию схемы можно 
экспортировать в DXF файл, 
выб в в меню ayout>Export, 
как описано ранее. 

 
 

Рис. 5.126 
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